kan man ha internet i linux?

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005

kan man ha internet i linux?

Ja, alltså jag är kraftfullt besviken på ubuntut jag nyligen installerat.

Allt fungerar gott och väl, men internet vägrar konsekvent att infinna sig.

Jag har internet genom en statisk ip över nätverket i studenthemmet. Har lyckats konfigurera nätverket med alla gateways, host och domännamn, dnsservrar osv, men ändå fungerar det inte. Vad gör man i ett sånt läge???

(ps internetet fungerar utmärkt i windows. Och det fungerar i linux med adsl via eget modem.)

De e sossarnas fel.

Trädvy Permalänk
Medlem
Registrerad
Jan 2002

Internet är ett nätverk. Det existerar inte i din maskin om du trodde det.

Jag kan säga att Internet är till större delen uppbyggd av Linux och andra UNIX-dialekter.

Läs manualen.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2004

Jao, eftersom det inte funkar fast du ställt in allt så har det väl blivit något fel någonstans på vägen. Alltså något fel i inställningarna.

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005
Citat:

Ursprungligen inskrivet av zightx
Jao, eftersom det inte funkar fast du ställt in allt så har det väl blivit något fel någonstans på vägen. Alltså något fel i inställningarna.

nej, jag har en kompis som har samma typ av uppkoppling och samma problem, tror inte båda kan ha gjort fel. Alltså alla inställningar som behövs för att det skall funka i windows har vi ställt in i linux men det räcker tydligen inte.

Och sluta rtfma, det har jag gjort.

De e sossarnas fel.

Trädvy Permalänk
Medlem
Registrerad
Jan 2002
Citat:

Ursprungligen inskrivet av dumiskallen
Och sluta rtfma, det har jag gjort.

Inte tillräckligt.

Det är iaf inget fel på din dist..

Trädvy Permalänk
Medlem
Plats
/bin/bash
Registrerad
Mar 2002

För det är ju helt omöjligt att två personer kan göra fel.

Nä jag ska inte vara sån, shit happens och är det första gången kan man missa saker eller helt enkelt missförstå dom. Värsta är om man tror sig förstå en sak men det visar sig vara fel, av vanan kan man då göra samma fel tusen gånger och rätta till dom tusen gånger.

Nåväl. Det intressanta är väl dom mest basic grejjerna. Kan du pinga prylar i nätverket, hur ser din routing tabel samt outputen från ifconfig ut? Om du mot förmodan inte har något annat än följande...

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo

... I din tabel så har du helt enkelt ingen route ut. isf kan du helt sonika skriva följande.

route add default gw ip.till.din.gw

Du kan ju leka runt lite, eftersom ger intrycket av att ha rtfm'at så kanske du kan lista ut resten från detta. GL HF

EDIT: Och det är ALDRIG datorns fel, den gör bara vad du säger till om. Bestämmer man sig för något annat kan man sluta försöka, för man vinner aldrig.

Cisco - Linux - VMWare
-- Citera mig om ni vill få återkoppling --

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005

ok, va schysst.
ska prova.
trodde liksom det skulle gå mer smärtfritt i "användarvänliga" ubuntu.

De e sossarnas fel.

Trädvy Permalänk
Medlem
Plats
sometown
Registrerad
Okt 2001

Ja eller så har du ingen vettig drivrutin för nätverkskortet om du har något särsystem

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

hehe.. hmm

hur ser det ut då där du konfar ditt nätverk?

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005
Citat:

Ursprungligen inskrivet av maDa
hehe.. hmm

hur ser det ut då där du konfar ditt nätverk?

använder nåt som hette networking som följde med i ubuntu.
där ställer man in sin ip, gateway, nätmask, host/domännamn och kryssar i att man aktiverar uppkoppplingen. mer går inte att pilla på. förutom en flik som heter hosts jag inte vet vad den är avsedd för.

Citat:

Ja eller så har du ingen vettig drivrutin för nätverkskortet om du har något särsystem

jodå, det fungerar somsagt med vanligt adslmodem.

De e sossarnas fel.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av dumiskallen
använder nåt som hette networking som följde med i ubuntu.
där ställer man in sin ip, gateway, nätmask, host/domännamn och kryssar i att man aktiverar uppkoppplingen. mer går inte att pilla på. förutom en flik som heter hosts jag inte vet vad den är avsedd för.

okej okej..

och interfacet där heter eth0, eth1 eller något såntdära?

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005

eth0 ja

De e sossarnas fel.

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002

ifconfig eth0

route -n

cat /etc/resolv.conf

Vad säger dom kommandona? det borde ge dig all den information du behöver för att lösa problemet.

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005

hmm...

De e sossarnas fel.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av dumiskallen
hmm...

hmm...?

  • *Kör kommandona i en terminal.

  • *Kopiera sedan bara utresultaten hit.

Om du inte förstår hur du ska tolka det.

.:aixelsyd:.
Remember Google isn't the web! But do use it's power!

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Lura inte in honom på någon vanlig ifconfig lösning. Gör det Ubuntu-way nu istället. ifconfig ger inga permanenta ändringar.

Trädvy Permalänk
Medlem
Plats
Bollnäs
Registrerad
Maj 2002
Citat:

Ursprungligen inskrivet av maDa
Lura inte in honom på någon vanlig ifconfig lösning. Gör det Ubuntu-way nu istället. ifconfig ger inga permanenta ändringar.

Dom vill ju bara se resultatet...

Personligen tror jag på brist på default route

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005

prompt:~$ ifconfig eth0 eth0 Link encap:Ethernet HWaddr 00:50:8D:D1:45:D7 inet addr:192.11.227.88 Bcast:192.11.227.255 Mask:255.255.255.0 inet6 addr: fe80::250:8dff:fed1:45d7/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:487 errors:0 dropped:0 overruns:0 frame:0 TX packets:6 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:40687 (39.7 KiB) TX bytes:468 (468.0 b) Interrupt:201 Base address:0xb400 prompt:~$ route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.11.227.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 prompt:~$ cat /etc/resolv.conf domain sgsnet.se nameserver 193.11.227.3

vet inte riktigt vad man kan utläsa av detta. men vad menas med default route?

De e sossarnas fel.

Trädvy Permalänk
Medlem
Registrerad
Jan 2002

Gateway ser inte riktigt rätt ut.

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005
Citat:

Ursprungligen inskrivet av denka
Gateway ser inte riktigt rätt ut.

nepp, kanske har att att göra med att
när jag i network config väljer default gateway device till eth0 trycker ok och sen går in i config igen så är fältet utgråat (dvs ingen default vald)... fattar inte varför.

edit:

Citat:

Det är iaf inget fel på din dist..

efter lite googlande verkar det faktiskt röra sig om en bugg i ubuntu. det verkar som om jag måste konfigurera manuellt. har ingen aning om hur man sköter det. får gissa lite.

De e sossarnas fel.

Trädvy Permalänk
Medlem
Plats
Bollnäs
Registrerad
Maj 2002

sudo ifconfig eth0 inet <ip> netmask <nätmask>
sudo route add default gw <gateway>

sen ser du till att din resolv.conf är rätt, notera att deta bara fungerar denna boot, för att få det persistent så måste du ändra interfaces-filen i en undermapp i /etc (minns inte riktigt helt)

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005
Citat:

Ursprungligen inskrivet av bogg
sudo ifconfig eth0 inet <ip> netmask <nätmask>
sudo route add default gw <gateway>

prompt:~$ sudo route add default gw 193.11.227.1 SIOCADDRT: Network is unreachable

:S

De e sossarnas fel.

Trädvy Permalänk
Medlem
Registrerad
Jan 2002

192......

Trädvy Permalänk
Medlem
Plats
Rålunden
Registrerad
Maj 2005
Citat:

Ursprungligen inskrivet av denka
192......

hoppsan, slank visst in 192 där..
nu funkar det ju bra
ja det var ju inte pinsamt eller så

De e sossarnas fel.