Trädvy Permalänk
Medlem
Plats
/root
Registrerad
Jul 2001

Linux 2.6.18 ute

Linux 2.6.18 släpptes tidigt på morgonen, finns som vanligt på http://www.kernel.org

Linus announce mail: http://lkml.org/lkml/2006/9/20/2

"to conquer others is to have power, to conquer yourself is to know the way"
Blogg / Browser/OS-sniffer

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Okt 2001

Lite halvnoobig fråga men...

Jag kör Kubuntu. Om jag ska kompilera en ny kernel. Måste jag ställa in ALLT från scratch då I steget då man kommer till den grafiska delen och gör själva configen?

Har ett så välfungerande system just nu så man vill ju inte riskera att pajja något bara för att man är "det-senaste-kåt"

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2005

du kan ju alltid köra

make oldconfig

i /usr/src/linux/ katalogen om du kompilerat kärnan själv tidigare.

.:aixelsyd:.
Remember Google isn't the web! But do use it's power!

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2005

Om du kör Kubuntu borde du hålla dig till de kärnor som tillhandahålls genom apt, eftersom alla övriga drivrutiner (kärnmoduler) är kompilerade just för dessa och Kubuntus egna kernels dessutom antagligen är ganska fett patchade med kubuntuspecifika funktioner.. Kan bli en massa meck m.a.o!

Känner du att du vill ha bleeding edge-paket kan du ju ta och uppgradera Dapper Drake till Edgy Eft istället! För att upgradera, skriv:

$ sudo mv /etc/apt/sources.list /etc/apt/sources.list.backup $ sudo nano /etc/apt/sources.list

Klistra in följande:

## Add comments (##) in front of any line to remove it from being checked. ## Use the following sources.list at your own risk. deb http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse deb-src http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse deb http://archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse ## MAJOR BUG FIX UPDATES produced after the final release deb http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse deb-src http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse ## UBUNTU SECURITY UPDATES deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse ## BACKPORTS REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.) deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse deb-src http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse ## PLF REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.) #deb http://packages.freecontrib.org/plf edgy free non-free #deb-src http://packages.freecontrib.org/plf edgy free non-free ## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu ## servers. RealPlayer10, Opera and more to come.) deb http://archive.canonical.com/ubuntu dapper-commercial main ## Listen deb http://theli.free.fr/packages/ dapper listen

Skriv sedan:

$ sudo aptitude update $ sudo aptitude dist-upgrade

Jag rekommenderar verkligen att du skriver aptitude här istället för apt-get eftersom aptitude löser alla dessa beroenden så mycket bättre, det är ca ett tusental paket som uppgraderas!

Lycka till!

Kubuntu Linux 'Edgy' med kernel 2.6.17.x, xorg 7.x, KDE 3.5.x.
AMD64 3200+, 2 GB Dual-DDR400, 250+160 GB Samsung SATA2

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av greencor
Har ett så välfungerande system just nu så man vill ju inte riskera att pajja något bara för att man är "det-senaste-kåt"

Jag måste varna dig om att ditt betende är ganska farligt. Att köra bleeding-edge programvara är roligt i en dag med alla nya funktioner och grejer, när programmen sen börjar krascha, x inte startar och allt går åt skogen är det inte lika roligt.
Det är bättre att lugna ivern och vänta tills det läggs till "officiella" paket till Ubuntus stabila version.

"Knowledge amplification. What he learns, we all learn. What he knows, we all benefit from."

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Okt 2001

KentRoyal. Jo du har såklart rätt, Men när man kommer från Windowsvärlden så är man oftast van vid att uppgradera = bra. För så är det ju oftast.

Vad är bleeding Edge?

Trädvy Permalänk
Medlem
Plats
sektor 001
Registrerad
Aug 2003
Citat:

Ursprungligen inskrivet av greencor
KentRoyal. Jo du har såklart rätt, Men när man kommer från Windowsvärlden så är man oftast van vid att uppgradera = bra. För så är det ju oftast.

Vad är bleeding Edge?

det senaste sena helt enkelt. dvs inte ens betagrejer alltid utan ibland grymt instabila saker som mest är av intresse för dem som är med och utvecklar eller buggtestar. i Ubuntu finns detta som Efty Etch eller vad det heter, i Debian är det det mindre kryptisk "Debian unstable" vilket ju talar för sig självt bättre.

Operativsystemet som löser nästan alla problem: Mint

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2005

AndreaX: om du hade läst min post hade du sett att nya (k)ubuntu heter edgy eft och inte efty etch

Kubuntu Linux 'Edgy' med kernel 2.6.17.x, xorg 7.x, KDE 3.5.x.
AMD64 3200+, 2 GB Dual-DDR400, 250+160 GB Samsung SATA2

Trädvy Permalänk
Medlem
Plats
sektor 001
Registrerad
Aug 2003

jo jag läste, har inget närminne bara..

Operativsystemet som löser nästan alla problem: Mint

Trädvy Permalänk
Medlem
Plats
Oslo
Registrerad
Jan 2003

Provade själv att slänga in Edgy Eft på laptopen; ingen smart idé i mitt fall kan jag säga. Mängd med paket som blev buggade och xorg ville inte ens starta i början.

Som tur är min laptop mer av en extrem experiment dator i vilket fall, så det spelar ingen roll om den skulle bugga ur totalt. Vilket jag är van vid

Men som sagt, jag rekommenderar ingen att köra ostabila saker om man inte vet vad man pysslar med. Kan knappt räkna hur många gånger jag förstört distar när jag velat köra bleeding edge paket. Dessutom är Edgy Eft ändå planerat att släppas som "stable" redan nu i oktober så man kan lika gärna vänta tills dess.

Laptop: MacBook Pro 15,4" | i7 - 4Gb DDR3 - Intel 320 160Gb SSD | MacBook Air 13,3" | i7 - 4Gb DDR3 - 256Gb SSD
Photoblog: eco.nu | D90 + Nikkor 18-200 VR + Sigma 10-20 + Nikkor 35/1.8 + Sigma 17-50/2.8