Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002

mdadm och raid5 frågor

jag körde:

mdadm --create --verbose /dev/md0 --level=5 --raid-devices=3 /dev/sdc1 /dev/sda1 /dev/hdf1

allt verkade funka fint, men ska /proc/mdstat se ut såhär:
md0 : active raid5 hdf1[3] sda1[1] sdc1[0]
312576512 blocks level 5, 64k chunk, algorithm 2 [3/2] [UU_]
[=======>.............] recovery = 37.8% (59187624/156288256) finish=75.3min speed=21469K/sec

Såhär ser den ut till den kommit nästan till 100% sedan hoppar disk sdc1 ut och blir faulty.

jag har kört westerndigital diag grejj och det är inte fel på disken =/

Trädvy Permalänk
Medlem
Registrerad
Okt 2002

Jag hade nåt liknande problem, och då var det för att disken var trasig. Du säger att du har testat så att disken inte är trasig men det värkar ändå som den inte fungerar som den ska tycker jag. Testa att byta ut disken mot en annan och så om det fungerar bättre, inte så mycket annat man kan göra tyvärr.

http://blinkenshell.org - Gratis shellkonton. Inklusive webbhost med PHP & MySQL.
http://www.blinkenlights.se/ - En site om programmering och spelutveckling på svenska

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Jul 2005

Kan du formatera den som en egen disk?

Är partitionerna exakt lika stora?

Kriga mot min brute: http://gunnard.se.mybrute.com om du vågar :D

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Feb 2005

köp ett raidkort

Server: Intel Pentium D 2.66Ghz, 2x80GB SATA RAID-1, 2GB Ram, FreeBSD-7.0

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002
Citat:

Ursprungligen inskrivet av GunnarD
Kan du formatera den som en egen disk?

Är partitionerna exakt lika stora?

jepp dom är EXAKT lika stora... men nu funkar det.... jag öppnade chassit och 2 av diskarna hade inte nån fläkt och dom var VAAARMA så jag ställde en bordsfläkt vid sidan när jag byggde arrayn och sedan funkade det..

installerade även smartd så jag ser ifall nån disk börjar göra fel.

just nu håller jag på o utökar arrayn med en fjärde disk.. faan va tid det tar..

md0 : active raid5 hde1[3] sdc1[0] hdf1[2] sda1[1]
312576512 blocks super 0.91 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]
[>....................] reshape = 2.6% (4183296/156288256) finish=416.4min speed=6086K/sec

upptäckte nu att smartd sa detta nyss:

Sep 27 17:44:24 localhost smartd[11757]: Device: /dev/sdc, 1 Offline uncorrectable sectors

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Då har du nog något vajsing med den disken.

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002

mm... det är en WD som har garanti till 2008. men kan jag skicka in den även fast den "funkar"? den har inte hoppat ur arrayen ännu men smartd säger:
Sep 27 17:44:24 localhost smartd[11757]: Device: /dev/sdc, 1 Offline uncorrectable sectors

tänk om dom säger att det inte är något fel på disken om jag skickar in den?

Trädvy Permalänk
Medlem
Plats
sometown
Registrerad
Okt 2001

Om smart rapporterar fel på disken så kan dom väl fasen inte säga att den är 100% fungerande?

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Jul 2005

Prova att köra något disktest program på den för att kontrollera disken.

Kriga mot min brute: http://gunnard.se.mybrute.com om du vågar :D

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002
Citat:

Ursprungligen inskrivet av GunnarD
Prova att köra något disktest program på den för att kontrollera disken.

jag körde quick test med western digitals program som fanns på theultimatebootcd.. men jag orkade inte vänta på full-testen ska nog göra det sen innan jag skickar in disken..