Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Apr 2005

Ett gäng problem med Arch

Jag har nyligen (2 dagar sedan) installerat arch och nu har jag sammlat på lite problem som jag skulle vilja ha hjälp med:)

Det första kommer när jag ska starta opera:

ERROR: ls.so: object 'libjvm.so from LD_PRELOAD cannot preload: ignored.
ERROR: ls.so: object 'libawt.so from LD_PRELOAD cannot preload: ignored.

Dom kommer upp men opera startar ändå, dock går det inte att surfa...

Nästa problem:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols

Och nästa:

FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.

Åsså sista:

Locale not supported by C library.
Using the fallback 'C' locale.

Uppskattar verkligen hjälp med dessa

Sen har jag en fråga om rc.conf också, vad ska det stå i CONSOLEFONT, CONSOLEMAP och LOCALES ?

Jag vill använda svenska tecken men programen får väldigt gärna vara på engelska.

Just ja, ibland gäller den om nåt om helvetcia å nå mer skumt när jag startar vissa program men det känns som om det är p.g.a nåt av ovanstående problem.

EDIT: fixade felmeddelanden.

Trädvy Permalänk
Medlem
Registrerad
Nov 2004

Re: Ett gäng problem med Arch

Citat:

Jag har nyligen (2 dagar sedan) installerat arch och nu har jag sammlat på lite problem som jag skulle vilja ha hjälp med:)

Det första kommer när jag ska starta opera:

ERROR: ls.so: object 'libjvm.so from LD_PRELOAD cannot preload: ignored.
ERROR: ls.so: object 'libawt.so from LD_PRELOAD cannot preload: ignored.

Dom kommer upp men opera startar ändå, dock går det inte att surfa...

Det ser ut som om dessa biblotek är en del av java, har du det installerat? finns de här filerna?

Citat:

Åsså sista:

Locale not supported by C library.
Using the fallback 'C' locale.

Uppskattar verkligen hjälp med dessa

Sen har jag en fråga om rc.conf också, vad ska det stå i CONSOLEFONT, CONSOLEMAP och LOCALES ?

så här ser den delen av rc.conf ut för mig:

LOCALE="en_US.utf8" HARDWARECLOCK="localtime" TIMEZONE="CET" KEYMAP="sv-latin1" CONSOLEFONT= CONSOLEMAP= USECOLOR="yes"

i /etc/local.gen har jag "kommenterat av" de locales jag vill använda (en_US.UTF-8, en_US ISO-8859-1, sv_SE.UTF-8 UTF-8 och sv_SE ISO-8859-1). därefter kör du local-gen (som root) för att uppdatera dem.

"FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing."
Det har jag också vid uppstart av X, vet inte vad det gör, sök arch's forum.

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Apr 2005

Tackar så hemskt mycket för hjälpen!

Nu kommer jag med två följd frågaor
1: varför återställer resolv.conf sig till 192.168.1.1 varje gång datorn startar om? :S
2: hur ska jag ställa in eth0 om jag inte vill använda dhcp? (speciellt, vad är broadcast till?)

EDIT: 1 beror nog på att default gateway var inställd på det i rc.conf...

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Feb 2004

Installera java, pacman -S jre

Angående keyboard grejjen, hur ser din InputDevice sektion ut i xorg.conf för ditt tangentbord? Testa med:
Option "XkbModel" "pc105"
Option "XkbLayout" "se"

Detta borde fixa font grejjen:

# cd /usr/share/fonts/misc # mkfontscale # mkfontdir # fc-cache -vf

Detta kör jag på:

LOCALE="sv_SE.UTF-8" HARDWARECLOCK="localtime" TIMEZONE="Europe/Stockholm" KEYMAP="sv-latin1" CONSOLEFONT=lat9w-16 CONSOLEMAP=

eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
istället för
eth0="dhcp"
i rc.conf

Från man ifconfig

broadcast (Inet only.) Specify the address to use to represent broadcasts to the network. The default broadcast address is the address with a host part of all 1's.

Hur man installerar program i *nix | There is no Swedish conspiracy

these days you can't use the Web at 2400 baud because the ads are 24KB - Bill Joy

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Apr 2005

OKej tackar så hemskt mycket för hjälpen!

Opera problemet är borta CONSOLEMAP CONSOLEFONTS och LOCALES har jag fått förklarat men resterande problem kvarstår...

FreeFontPath: FPE problemet är kvar :/
Samma gäller för xkbcomp fast jag ställde det som Lunke sa :/

åsså eth0 vill inte funka nå bra heller... om min router har 192.168.1.1 så borde väl min eth0 rad se ut så här: eth0="eth0 192.168.1.230 netmask 255.255.255.0 broadcast 192.168.1.1" eller ?

resolv.conf gillade iaf när det stod så men jag hade iaf ingen kontakt med nätet :S
lite längre ner i rc.conf står det nåt om gateways vad ska stå där? routerns ip eller dnsen eller kanske nåt helt annat?

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Feb 2004

Din broadcast borde vara 192.168.1.255

Din gateway sektion i rc.conf ska vara:
gateway="default gw 192.168.1.1"
ROUTES=(gateway)

i resolv.conf skriver du in dina dnsserverar, t.ex. om du använder din router som dnsserver:
nameserver 192.168.1.1

Hur man installerar program i *nix | There is no Swedish conspiracy

these days you can't use the Web at 2400 baud because the ads are 24KB - Bill Joy

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Apr 2005

aha hittade felet med hjälp av ditt medelande Lunke jag hade ett ! före gateway i routes så det var inte aktivit...