Php har för låga rättigheter

Trädvy Permalänk
Medlem
Registrerad
Jan 2006

Php har för låga rättigheter

Jag kör Kubuntu 5.10 och har apache och php installerat på det. Jag vill låta php köra vissa systemkommandon på datorn med hjälp av system(), vissa kommandon kan jag redan använda, men tex "dcop" verkar php inte ha rättigheter att använda. Hur ska jag göra för att fixa det?

Trädvy Permalänk
Medlem
Plats
Laholm
Registrerad
Okt 2005

Det är skitkrångligt det du försöker göra! Trust me! Jag har försökt!
Du måste ändra vilka grupper www-data ingår i vilket är extreemt hög säkerhetsrisk då du ska byta den till din grupp vilket medför att han och alla som besöker din sida kan ändra och kolla precis allt du har. Lägg ner det istället. Antar att du ska fixa ett Now Playing plugin till Amarok?
Kolla efter pluginet "Kurrent" istället. Det fixar saken utan att krångla!

ASP.NET programmerare i C#
Twitter: http://www.twitter.com/hagbarddenstore

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2004

Är apache chrootat? Annars kan du ju skapa några symlänkar eller något något krafs.