Pre-release av flash 9 för Linux

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Mar 2002

Pre-release av flash 9 för Linux

Såg precis att det fanns en pre-release av Flash 9 för Linux.
Något jag själv längtat endel efter.

Mer info:
http://labs.adobe.com/downloads/flashplayer9.html

"Knowledge amplification. What he learns, we all learn. What he knows, we all benefit from."

Trädvy Permalänk
Medlem
Registrerad
Feb 2003

Re: Pre-release av flash 9 för Linux

Underbart, där försvann mitt enda irritationsmoment med Linux

Citat:

Ursprungligen inskrivet av KentRoyal
Såg precis att det fanns en pre-release av Flash 9 för Linux.
Något jag själv längtat endel efter.

Mer info:
http://labs.adobe.com/downloads/flashplayer9.html

Trädvy Permalänk
Medlem
Plats
10:e våningen
Registrerad
Feb 2002

Kalla mig gärna dum nu - installationen är verkligen busenkel - men jag får det inte att fungera...

Instruktionerna:

Citat:

* Plugin

o To install the plugin as user:

+ Copy or move libflashplayer.so into your plugins directory (usually located): ~/.mozilla/plugins

+ Create the plugins folder if it doesn't exist

o To install the plugin as root:

+ Copy or move the file into your system browser installed plugins directory (usually located): /usr/lib/<browser_directory>/plugins

+ Create the plugins folder if it doesn't exist

Jag har en ~/.mozilla/ mapp som innehåller mappen firefox.

I .mozilla mappen skapar jag en mapp som heter plugins där jag placerar libflashplayer.so och startar om Firefox - men det fungerar inte.

Skapar jag en plugins mapp i firefox fungerar det heller inte - och jag verkar inte ha någon root-mapp (/usr/lib/ etc ) som jag kan placera den i heller.

Tips ?

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

Adobe borde stämmas för att de släpar efter med linux versionen.
Skulle vara trevligt om de kom en fri variant av flash playar.

Trädvy Permalänk
Medlem
Plats
~
Registrerad
Apr 2003

Funkar bra för mig, jag bytte bara ut mitt gamla plugin i ~/.mozilla/plugins med den nya versionen.
Hade alltid problem med att ljud laggade efter video på bland annat YouTube med version 7, men de klippen jag har kollat med version 9 synkar perfekt

Trädvy Permalänk
Medlem
Plats
10:e våningen
Registrerad
Feb 2002

Nu kom jag på varför jag inte hade flash sedan tidigare - när jag försöker installera den gamla flash-spelaren får jag upp:

Citat:

ERROR: Your architecture, \'x86_64\', is not supported by the Macromedia Flash Player installer.

Känns ju ganska fånigt att de inte har stöd för 64bitars processorer - det borde ju fungera med den nya spelaren (?)

Trädvy Permalänk
Medlem
Plats
~
Registrerad
Apr 2003

Hittade en bugg, vet inte om den fanns i version 7.

1. Öppna en sida med flashinnehåll
2. Högerklicka på flashinnehållet, välj Settings och gå till Mic-inställningarna, stäng settingsrutan.
3. Försök ladda en ny webbsida i samma fönster.

Inget man gör så ofta kanske, men det låser hela FireFox 1.5.0.7 för mig varje gång jag testar.

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Nov 2001
Citat:

Ursprungligen inskrivet av Pulver
Kalla mig gärna dum nu - installationen är verkligen busenkel - men jag får det inte att fungera...

Instruktionerna:

Jag har en ~/.mozilla/ mapp som innehåller mappen firefox.

I .mozilla mappen skapar jag en mapp som heter plugins där jag placerar libflashplayer.so och startar om Firefox - men det fungerar inte.

Skapar jag en plugins mapp i firefox fungerar det heller inte - och jag verkar inte ha någon root-mapp (/usr/lib/ etc ) som jag kan placera den i heller.

Tips ?

Prova att skriv locate libflashplayer.so så ser du vart du hade det installerat förrut.

några ex kan vara, kolla om du har någon av dessa.
/opt/firefox/plugins/libflashplayer.so
/usr/lib/mozilla-snapshot/plugins/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/usr/lib/mozilla-firefox/plugins/libflashplayer.so
/usr/lib/netscape/plugins-libc6/libflashplayer.so

/opt/firefox/plugins var mappen på min dator

Sverige är ett så litet land att det bara får plats en åsikt i taget där.

Trädvy Permalänk
Medlem
Plats
10:e våningen
Registrerad
Feb 2002

Tack för hjälpen

Jag gjorde en lite mer grundlig undersökning och hittade rätt mappar under /usr/lib64/mozilla/plugins samt /usr/lib64/mozilla-firefox-1.5.0.7/plugins

(det var givetvis därför jag inte hittade något under /usr/lib/)

Men när jag placerat libflashplayer.so i dessa mappar och startat om firefox (och även datorn) så fungerar det ändå inte.

Misstänker att den inte stödjer 64bitars processorer (?)

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Nov 2001
Citat:

Ursprungligen inskrivet av Pulver
Tack för hjälpen

Jag gjorde en lite mer grundlig undersökning och hittade rätt mappar under /usr/lib64/mozilla/plugins samt /usr/lib64/mozilla-firefox-1.5.0.7/plugins

(det var givetvis därför jag inte hittade något under /usr/lib/)

Men när jag placerat libflashplayer.so i dessa mappar och startat om firefox (och även datorn) så fungerar det ändå inte.

Misstänker att den inte stödjer 64bitars processorer (?)

Nop, finns ingen 64bits-version.

Sverige är ett så litet land att det bara får plats en åsikt i taget där.

Trädvy Permalänk
Medlem
Plats
10:e våningen
Registrerad
Feb 2002

Ok, tack då vet jag

Får hoppas att det kommer en 64bitars version när de släpper den skarpa versionen.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Dec 2002

Det kommer aldrig att komma en 64bitars version och jag hatar det

Trädvy Permalänk
Medlem
Registrerad
Mar 2003

Funkar perfekt hittills, kan redan se vissa flash-filmer jag inte kunde förut. Och ljudet verkar inte släpa efter på sidor som youtube längre.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2005

Flashstödet verkar fungera utmärkt, men måste det gå så saaatans slött? Det märks tydligt när man kommer in på en sida med flash, menyer hänger sig när man ska öppna länkar i tabbar o.s.v.

Stationär: Intel-baserad, Arch + KDE
Bärbar: Dell XPS 13, Arch + KDE

Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Apr 2004

Underbart att det äntligen händer nåt

Edit: Nu behöver jag inte köra firefox i wine för att man ska kunna titta på flash9 material

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Mar 2002

Det flyter på väldigt bra här men det buggar en hel del.
Ljudet hakar lätt upp sig och börjar loopa 1 sekunds ljud om och om igen. Videon hakar också upp sig lätt. Ofta blir det när jag scrollar på en tungladdad sida men ibland rent spontant när jag bara sitter och tittar.

"Knowledge amplification. What he learns, we all learn. What he knows, we all benefit from."

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Jul 2001

Verkar fungera väldigt dåligt i Opera. Har haft igång browsern i flera dagar i sträck och den hänger sig aldrig annars. Men nu så har den hängt sig 3 gånger efter lite vanlig surfning. Så det blev back to flash 7.

"I don't have time to waste. I'm busy cultivating useless good taste" - helmet
Bärbar: Amilo Si1520 | 1.83 Ghz core duo | 1024 MB DDR II (533) | 100 GB SATA | Intel GMA950 | 12" TFT | Ubuntu Edgy

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Nov 2001
Citat:

Ursprungligen inskrivet av KaY
Verkar fungera väldigt dåligt i Opera. Har haft igång browsern i flera dagar i sträck och den hänger sig aldrig annars. Men nu så har den hängt sig 3 gånger efter lite vanlig surfning. Så det blev back to flash 7.

Funkade inte för mig heller i opera.

Sverige är ett så litet land att det bara får plats en åsikt i taget där.

Trädvy Permalänk
Medlem
Plats
Spånga
Registrerad
Apr 2003

Funkar flawless för mig än så länge i firefox

Trädvy Permalänk
Medlem
Plats
tty0
Registrerad
Feb 2005

Fungerar dåligt för mig också i opera, detta är ju lite tråkigt, som tur är det bara en beta, och förhoppningsvis fixar dem det till senare riktiga 9:an.

Trädvy Permalänk
Medlem
Plats
Göteborg (CTH)
Registrerad
Nov 2003
Citat:

Ursprungligen inskrivet av Pulver
Tack för hjälpen

Jag gjorde en lite mer grundlig undersökning och hittade rätt mappar under /usr/lib64/mozilla/plugins samt /usr/lib64/mozilla-firefox-1.5.0.7/plugins

(det var givetvis därför jag inte hittade något under /usr/lib/)

Men när jag placerat libflashplayer.so i dessa mappar och startat om firefox (och även datorn) så fungerar det ändå inte.

Misstänker att den inte stödjer 64bitars processorer (?)

Lyckas inte heller få igång det i Firefox (2.0 RC3), min mapp är /usr/lib64/mozilla-firefox/plugins. Har en 64bitars processor och kör x86_64 (amd64, Gentoo).

Däremot fungerar det helt perfekt i Opera (9.02), ljud och bild fungerar än så länge utan några problem.

Sen som ett ytterligare "bevis" på att Flash 9 fungerar under x86_64 är paketet net-www/netscape-flash i portage vilket har nyckelordet "~amd64".

Trädvy Permalänk
Medlem
Plats
sometown
Registrerad
Okt 2001

Åh thankyou lord för detta. Som tidigare nämnts, enda irritationsmomentet under mitt trevliga system ^ ^

Trädvy Permalänk
Medlem
Plats
sektor 001
Registrerad
Aug 2003

toppen.

nån som har en länk till en besvärlig sida så man ser hur bra det funkar månne?

Operativsystemet som löser nästan alla problem: Mint

Trädvy Permalänk
Medlem
Registrerad
Feb 2003

www.aftonbladet.se

Citat:

Ursprungligen inskrivet av AndreaX
toppen.

nån som har en länk till en besvärlig sida så man ser hur bra det funkar månne?

Trädvy Permalänk
Medlem
Plats
sektor 001
Registrerad
Aug 2003
Citat:

Ursprungligen inskrivet av depeo
www.aftonbladet.se

haha, ja Aftonbladet lyckas alltid krasha FF för mig. (nu med) frågan är om det hade nått med flasharna att göra dock.. annars funkade filmer och sånt fint efter omstart.

Operativsystemet som löser nästan alla problem: Mint

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2005

swejihad: som du ser går version 7.x också att installera på en amd64 med gentoo portage, men den kommer bara att fungera om du installerar mozilla-firefox-bin som är en förkompilerad 32-bitars binärverison av Firefox. Tror däremed *inte* att version 9.x går att köra med native 64-bit FF!

Kubuntu Linux 'Edgy' med kernel 2.6.17.x, xorg 7.x, KDE 3.5.x.
AMD64 3200+, 2 GB Dual-DDR400, 250+160 GB Samsung SATA2

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Dec 2002
Citat:

Ursprungligen inskrivet av j0nas
swejihad: som du ser går version 7.x också att installera på en amd64 med gentoo portage, men den kommer bara att fungera om du installerar mozilla-firefox-bin som är en förkompilerad 32-bitars binärverison av Firefox. Tror däremed *inte* att version 9.x går att köra med native 64-bit FF!

Helt rätt! Läste en artikel om att det är väldigt krånligt att porta det till amd64, så det lär väl inte komma på ett tag.
Den man kan hoppas på nu är att gnash blir stabilt och användbart...

Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Apr 2004
Citat:

Ursprungligen inskrivet av mrl
Helt rätt! Läste en artikel om att det är väldigt krånligt att porta det till amd64, så det lär väl inte komma på ett tag.
Den man kan hoppas på nu är att gnash blir stabilt och användbart...

så länge gnash ligger på flash 7 nivå är det oanvändbart, tyvärr