Trädvy Permalänk
Medlem
Registrerad
Okt 2003

Hjälp med shorewall.

Hejsan.

Håller på att sätta upp en liten brandvägg/router på min server här hemma.
Har kört in dhcpd sam dnsmasq och det fungerar bra.

Men har ett problem med shorewall.
Har confat det, men när jag ska starta det får jag medelandet:

Setting up Masquerading/SNAT...
ERROR: Unable to determine the routes through interface "eth0"
Processing /etc/shorewall/stop ...
/var/lib/shorewall/.start: line 294: ip: command not found
ERROR: Command "ip link list" Failed
/var/lib/shorewall/.start: line 294: ip: command not found
ERROR: Command "ip link list" Failed

och:
/var/lib/shorewall/.start: line 294: ip: command not found
ERROR: Command "ip link list" Failed
upprepas tills jag trycker ctrl+c.

min masq fil ser ut såhär:

#INTERFACE mple 3: SUBNET ADDRESS PROTO PORT(S) IPSEC
eth1 eth0

Mitt internet är anslutet till eth1, och nätverket till eth0.

Någon som vet vad som kan vara fel?
kan posta fler config filer om det behövs, men vet inte vilken som skulle hjälpa.

tack på förhand

Trädvy Permalänk
Medlem
Plats
Helltown
Registrerad
Nov 2002

Hur ser din interfaces fil ut?

Viva las vegas....

Trädvy Permalänk
Hedersmedlem
Plats
Uppsala
Registrerad
Jul 2001

Har du verkligen iproute2 installerat?
Kör "ip" som root och se om det fungerar.

X370 Taichi / R7 1700 @ 3.75 GHz 1.2 V / 2x8 GB 3200 MHz CL16 / MSI GTX 1070 Gaming, OC / Samsung 960 EVO 500 GB / Corsair RM650x
LG G6 (H870)

Trädvy Permalänk
Medlem
Registrerad
Okt 2003

lando:
Min interface fil ser ut såhär:
#ZONE INTERFACE BROADCAST OPTIONS
net eth1 detect dhcp,routefilter,nosmurfs,logmartians ded white
loc eth0 detect tcpflags,detectnets,nosmurfs

Thomas:
Hade inte iproute2 installerat tydligen, har installerat det nu, ska testa och se om det fungerar bättre. Återkommer med resultat.

*edit*
iproute2 hjälpte kanske lite. felmedelandet som upprepade sig islutet av shorewall start försvann.

postar länkar till outputen från shorewall check och start.

shorewall start
shorewall check

*edit2*
en annan sak ändrades nu också.
Innan var det så att jag inte kunna öppna nya anslutningar från servern/brandväggen efter jag hade kört shorewall start, fast det inte startade.
Men nu fungerade, så stop scriptet fungerar nog bättre nu:)