Permalänk
Medlem

Felkoder vid installation

Hejsan!

Får upp detta varje gång jag ska installera program, allt installeras och det funkar, men är lite nyfiken på vad detta kan vara för fel.
Har haft detta hela tiden jag har haft Kubuntu installerat.

X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device

Jag har Kubuntu 7.04 ATi Radeon x1600 512MB
Har OpenGL stöd installerat och det funkar utan problem.

// Macke

Permalänk
Avstängd

Den klagar på "input device", vilket är tangentbord, möss, gamepads, joysticks, etc.

Kanske något fel i din xorg.conf fil?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av uid313
Den klagar på "input device", vilket är tangentbord, möss, gamepads, joysticks, etc.

Kanske något fel i din xorg.conf fil?

Kollat igenom den men eftersom jag inte är så van Linux ännu så kan iallafall inte jag hitta nå fel, postar den här ifall nån har lust att hjälpa en vilsen nybörjare

# /etc/X11/xorg.conf (xorg X Window System server configuration file) # # This file was generated by dexconf, the Debian X Configuration tool, using # values from the debconf database. # # Edit this file with caution, and see the xorg.conf(5) manual page. # (Type "man xorg.conf" at the shell prompt.) # # This file is automatically updated on xserver-xorg package upgrades *only* # if it has not been modified since the last upgrade of the xserver-xorg # package. # # If you have edited this file but would like it to be automatically updated # again, run the following command: # sudo dpkg-reconfigure -phigh xserver-xorg Section "ServerLayout" Identifier "Default Layout" Screen 0 "aticonfig-Screen[0]" 0 0 InputDevice "Generic Keyboard" InputDevice "Configured Mouse" InputDevice "stylus" "SendCoreEvents" InputDevice "cursor" "SendCoreEvents" InputDevice "eraser" "SendCoreEvents" EndSection Section "Files" # path to defoma fonts FontPath "/usr/share/fonts/X11/misc" FontPath "/usr/share/fonts/X11/cyrillic" FontPath "/usr/share/fonts/X11/100dpi/:unscaled" FontPath "/usr/share/fonts/X11/75dpi/:unscaled" FontPath "/usr/share/fonts/X11/Type1" FontPath "/usr/share/fonts/X11/100dpi" FontPath "/usr/share/fonts/X11/75dpi" FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" EndSection Section "Module" Load "i2c" Load "bitmap" Load "ddc" Load "dri" Load "extmod" Load "freetype" Load "glx" Load "int10" Load "vbe" EndSection Section "InputDevice" Identifier "Generic Keyboard" Driver "kbd" Option "CoreKeyboard" Option "XkbRules" "xorg" Option "XkbModel" "pc105" Option "XkbLayout" "se" Option "XkbOptions" "lv3:ralt_switch" EndSection Section "InputDevice" Identifier "Configured Mouse" Driver "mouse" Option "CorePointer" Option "Device" "/dev/input/mice" Option "Protocol" "ImPS/2" Option "ZAxisMapping" "4 5" Option "Emulate3Buttons" "true" EndSection Section "InputDevice" Identifier "stylus" Driver "wacom" Option "Device" "/dev/input/wacom" Option "Type" "stylus" Option "ForceDevice" "ISDV4" # Tablet PC ONLY EndSection Section "InputDevice" Identifier "eraser" Driver "wacom" Option "Device" "/dev/input/wacom" Option "Type" "eraser" Option "ForceDevice" "ISDV4" # Tablet PC ONLY EndSection Section "InputDevice" Identifier "cursor" Driver "wacom" Option "Device" "/dev/input/wacom" Option "Type" "cursor" Option "ForceDevice" "ISDV4" # Tablet PC ONLY EndSection Section "Monitor" Identifier "SyncMaster" Option "DPMS" EndSection Section "Monitor" Identifier "aticonfig-Monitor[0]" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection Section "Device" Identifier "Allmänt grafikkort" Driver "vesa" BusID "PCI:1:0:0" EndSection Section "Device" Identifier "aticonfig-Device[0]" Driver "fglrx" Option "VideoOverlay" "on" Option "OpenGLOverlay" "off" EndSection Section "Screen" Identifier "Default Screen" Device "Allmänt grafikkort" Monitor "SyncMaster" DefaultDepth 24 SubSection "Display" Depth 1 Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection SubSection "Display" Depth 4 Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection SubSection "Display" Depth 8 Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection SubSection "Display" Depth 15 Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection SubSection "Display" Depth 16 Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection SubSection "Display" Depth 24 Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection EndSection Section "Screen" Identifier "aticonfig-Screen[0]" Device "aticonfig-Device[0]" Monitor "aticonfig-Monitor[0]" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection Section "DRI" Mode 0666 EndSection Section "Extensions" Option "Composite" "0" EndSection

Permalänk
Medlem

Wacom-prylar: stylus (penna) med erasor och cursor är nog inte så vanliga att ha, pröva kommentera ut dem så försvinner nog felmeddelandet.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av ss_lamby
Wacom-prylar: stylus (penna) med erasor och cursor är nog inte så vanliga att ha, pröva kommentera ut dem så försvinner nog felmeddelandet.

Funkade inte problemet kvarstår

Permalänk
Medlem

[..]

#Section "InputDevice"
# Identifier "stylus"
# Driver "wacom"
# Option "Device" "/dev/input/wacom"
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"
# Identifier "eraser"
# Driver "wacom"
# Option "Device" "/dev/input/wacom"
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"
# Identifier "cursor"
# Driver "wacom"
# Option "Device" "/dev/input/wacom"
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

[..]

Det ska vara dessa linjer som orsakar felmedelandet, det finns inget annat i din xorg.conf som kan orsaka det. Jag får precis samma vid ett nyinstallerat Kubuntu system (och det försvinner efter att jag kommenterat bort wacom).

Permalänk
Medlem

hehe jag som hade gjort fel jag gjorde "//" för att kommentera bort dom :/
Funkar fint nu! Tack för hjälpen