linux fdisk + windows = bad?

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002

linux fdisk + windows = bad?

Jag installerade ArchLinux för ett tag sedan (~vecka) sedan efter de lyckades jag förstöra hela partitionstabellen på min systemdisk tur man har flera diskar

Efter de så partitionerade jag om hela systemdisken (hade tänkt göra de ändå). Sedan installerade jag ArchLinux igen, configurerade allt o så. Sen idag tänke jag installera Windows.

Stoppade i XP skivan och tröck valfri knapp för att boota från skivan och det blev svart inget mer förutom att HDn tugga på som om den fått fnatt lr nått. Trodde den dött men linux bootade som vanligt, kopplade ur alla andra hårddiskar och provade igen, fungerade fortfarande inte. Testade med en annan disk för att se så att installationen startar och det gör den.
Så efter mycke testande så rensade jag hela systemdisken från alla partitioner och skapade (i linux) en xp/ntfs partition och testade, igen utan att det fungerar.
Efter mycke testande så kom jag fram till att det ända sättet att komma förbi den svarta skärmen och in i XP installationen var att Inte skapa någon partition alls i fdisk i linux.

Någon som vet varför? det har väll fungerat förut lr minns jag fel ><

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Nov 2001

Varför boota windows när du har arch? Skämt o sido... sata?

Battlestation: 4770k - gtx1070 - 16gb ram - Samsung SSD
Server: 2x Xeon E5-2670 - 64GB Ecc ram
Synology NAS

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av basn
Varför boota windows när du har arch? Skämt o sido... sata?

Föredrar att spela i windows ^ och ja jag har sata diskar, har det någon betydelse vid partitionering?

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
/bin/bash
Registrerad
Mar 2002

Rätta mig om jag har fel men såvida du inte har en XP skiva med SP2 så måste du ladda en drivare för SATA vid cd-booten.

Cisco - Linux - VMWare
-- Citera mig om ni vill få återkoppling --

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av deegan
Rätta mig om jag har fel men såvida du inte har en XP skiva med SP2 så måste du ladda en drivare för SATA vid cd-booten.

Jag får svart skärm direkt efter meddelandet där jag måste trycka en knapp för att boota ifrån skivan.
Med andra ord, Jag har aldrig ens kommit in i Windows XP's installation och kan därmed inte trycka F6 för att ladda Sata drivisar om det skulle behövas, jag installerar ifrån en XP skiva med Sp2 på.

och som jag skrev så fungerar det om jag Inte skapar en partition i linux, och jag vill veta varför.

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
Mora
Registrerad
Dec 2001

Varför inte bara lämna lite opartionerat utrymme och skapa partitionen när du installerar windows?

Underligt är det dock..

När du ser svart & vitt så får du välja fritt!

Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Apr 2004
Citat:

Ursprungligen inskrivet av deegan
Rätta mig om jag har fel men såvida du inte har en XP skiva med SP2 så måste du ladda en drivare för SATA vid cd-booten.

Inte ens sp2 räcker till när det kommer till SATA, fråga min polare hur roligt det var att tjafsa med en windows-installation där det inte fanns stöd för just den sata-kontrollern som fanns på det moderkortet. I linux fungerade det klockrent från början

Trädvy Permalänk
Medlem
Plats
Hur mig veta
Registrerad
Maj 2007
Citat:

Ursprungligen inskrivet av deegan
Rätta mig om jag har fel men såvida du inte har en XP skiva med SP2 så måste du ladda en drivare för SATA vid cd-booten.

Har ingenting och göra med om man har xp med sp2 utan om man har en bios som läser in satan vid boot vilket alla ngt nyare sata moderkort gör

Ontopic:
felet kan ligga i lite olika parametrar kan vara att skivan e kass kan vara att hddn e lite konstig kan vara inprincip vadsomhelst men testa att bränna om xp skivan (och jag menar kopiera original xp skivan så ingen tror jag ger olagliga tips )