mina ögon gillar inte linux

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002

mina ögon gillar inte linux

Så än en gång har jag försökt gå över till linux eftersom jag gillar det operativsystemet. Men det fungerar inte har nu kört ArchLinux med XFCE som DE men efter en stunds surfande lr vad jag nu än gör i X så får jag ont i ögonen som slutar med huvudvärk, detta har aldrig hänt i windows och det går oftast över om jag startar windows och fortsätter surfa där.

Varför jag får ont i ögonen har jag ingen aning om förutom att det måste vara något i "bild-visningen" som skiljer sig åt.

Jag kör samma upplösning 1280x1024@75hz (native på min TFT).

Jag har senaste nvidida linux drivisarna för mitt 8800gts.

Jag har installerat MS fonts och ändrat inställningar så dom ser lika ut som i windows enligt guiden på http://www.sharpfonts.com/ (jag gillar den skarpa "windows" fonten bättre)

Jag har skaffat och modifierat teman för att det ska vara liknande färger i XFCE som i windows, även testat många andra mörka som ljusa teman.

Jag har använt guider (http://www.tftcentral.co.uk/articles/calibrating.htm) för att ställa in brightness/contrast och gamma rätt, har dock bara blivit värre när jag ändrat dom inställningarna = Suddigt och bleka färger.

Inget negativt om linux det är mycket bra OS depprimerande att jag inte kan använda det som windows pga. att det inte "ser" lika ut. mina ögon anser tydligen att det inte ser lika ut eftersom jag måste anstränga dom mer antar jag.

Så någon som råkar ha några tips på vad mer man kan testa?

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
/home
Registrerad
Dec 2004

Kan vara en bra idé att skriva ut vilken skärm och kabel du använder dig utav.. Möjligen klistra in din xorg.conf även!

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002

Jag använder vga kabel (inte DVI) då skärmen inte har DVI.

xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig # nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Jan 11 15:05:59 PST 2008 # nvidia-settings: version 1.0 (buildmeister@builder3) Wed Sep 12 14:30:30 PDT 2007 Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" EndSection Section "Files" RgbPath "/usr/lib/X11/rgb" EndSection Section "Module" Load "glx" # Load "GLcore" Load "record" Load "xtrap" # Load "dri" Load "dbe" Load "ddc" Load "extmod" Load "freetype" EndSection Section "ServerFlags" Option "Xinerama" "0" EndSection Section "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/psaux" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection Section "InputDevice" # generated from default Identifier "Keyboard0" Driver "keyboard" Option "XkbLayout" "se" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Acer AL1714" HorizSync 30.0 - 82.0 VertRefresh 50.0 - 75.0 Option "DPMS" EndSection Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection Section "Device" Identifier "Videocard0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce 8800 GTS" Option "AddARGBGLXVisuals" "True" Option "RenderAccel" "True" Option "DisableGLXRootClipping" "True" EndSection Section "Screen" Identifier "Screen0" Device "Videocard0" Monitor "Monitor0" DefaultDepth 24 Option "TwinView" "0" Option "metamodes" "CRT: 1280x1024_75 +0+0; CRT: nvidia-auto-select +0+0" SubSection "Display" Depth 24 EndSubSection EndSection

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Avstängd
Plats
Nato?
Registrerad
Dec 2005

Alltså om det är exakt samma inställningar på skärmen som du har i Windows är det ju något med Linux du är allergisk emot. Antingen tål du inte utseendet, eller så tål du inte ideologin. Är det samma färger, upplösning och uppdateringsfrekvens finns det ju knappast något du kan ratta på som tar bort det.

Landslide.nu - För er som vill diskutera allt mellan himmel och jord i där demokrati och yttrandefrihet ligger som högsta prio

Trädvy Permalänk
Medlem
Plats
/home
Registrerad
Dec 2004

Testa skapa en egen "Modeline" med hjälp utav xtiming och din manual. Glöm inte kommentera bort "metamodes" och ställa in din modeline med "Modes" inuti 'SubSection "Display"'. Skulle inte heller skada att prova ställa "HorizSync" och "VertRefresh" utefter manualen även.

EDIT: Upptäckte att du körde "nvidia" modulen, testa prova olika "UseEDID" inställningar som finns beskrivet i deras manual. Har själv haft liknande problem med fel EDID värden, bättre att ställa in detta själv om man vet vad som ska användas.

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Jan 2003

Har du provat någon annan fönsterhanterare än XFCE? Jag hade samma problem med Gnome men hade efter diverse trix fått till det så att det var samma känsla som i Windows.

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Jan 2004

Kan även vara så att du behöver gå till optikern och kolla så du inte ha brytningsfel eller dylikt. Inget dumt menat alls, men det kan faktiskt vara något sånt också..

iMac 27" | Mid 2010 | Core i7 2.93Ghz | 20 GB | HD5850 M | Samsung 840 500 GB | 4 TB WD
MacBook Air 11" | Mid 2012 | Core i7 2.0 Ghz | 8 GB | 256 GB SSD
Citera gärna om du svarar på mina inlägg, så hittar jag tillbaka igen! :)

Trädvy Permalänk
Medlem
Registrerad
Jan 2007

Jag förstår inte varför inte sharpfonts inte är standard överallt? tycker att systemens fonts brukar vara ok men i firefox ser det ut som väldigt otydligt och jobbigt för ögonen. Gillar någon det?

Trädvy Permalänk
Medlem
Plats
Hur mig veta
Registrerad
Maj 2007

Jag hade faktiskt exakt samma problem när jag började med xubuntu min lösning blev att jag fick gå från att ha xfce till kde så blev det bättre sen när jag ändrade upplösningen till 1024x768 från 1800x1600 och körde detta på dubbla skärmar så löste det sig fråga mig inte varför tycker själv det är lite mysko (kan också ha varit att jag vande mig efter ett tag men huvudvärken är borta)

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av Fyxim
Testa skapa en egen "Modeline" med hjälp utav xtiming och din manual. Glöm inte kommentera bort "metamodes" och ställa in din modeline med "Modes" inuti 'SubSection "Display"'. Skulle inte heller skada att prova ställa "HorizSync" och "VertRefresh" utefter manualen även.

EDIT: Upptäckte att du körde "nvidia" modulen, testa prova olika "UseEDID" inställningar som finns beskrivet i deras manual. Har själv haft liknande problem med fel EDID värden, bättre att ställa in detta själv om man vet vad som ska användas.

Tack, fixade nu så den använder vert/horiz synctider ifrån skärmen och det blev bättre dock ej 100% än ska testa lite mer.

Citat:

Ursprungligen inskrivet av 2pac
Har du provat någon annan fönsterhanterare än XFCE? Jag hade samma problem med Gnome men hade efter diverse trix fått till det så att det var samma känsla som i Windows.

Ja jag har testat KDEmod, e17 och fluxbox ingen skillnad.

Citat:

Ursprungligen inskrivet av b0bzor!
Kan även vara så att du behöver gå till optikern och kolla så du inte ha brytningsfel eller dylikt. Inget dumt menat alls, men det kan faktiskt vara något sånt också..

kanske de. Men borde jag inte få ont i ögonen/huvudet i windows då oxo?

Citat:

Ursprungligen inskrivet av Girgoo
Jag förstår inte varför inte sharpfonts inte är standard överallt? tycker att systemens fonts brukar vara ok men i firefox ser det ut som väldigt otydligt och jobbigt för ögonen. Gillar någon det?

Jag tycker inte det ser bra ut utan sharpfonts, kommer aldrig att byta bort de

Citat:

Ursprungligen inskrivet av Lighter22
Jag hade faktiskt exakt samma problem när jag började med xubuntu min lösning blev att jag fick gå från att ha xfce till kde så blev det bättre sen när jag ändrade upplösningen till 1024x768 från 1800x1600 och körde detta på dubbla skärmar så löste det sig fråga mig inte varför tycker själv det är lite mysko (kan också ha varit att jag vande mig efter ett tag men huvudvärken är borta)

ändrar jag upplösning från native 1280x1024 på tft blir det "suddigt" eftersom en bildpixel tar flera skärmpixlar osv. men jag har tänkt testa flera fönsterhanterare gillar dock XFCE.

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002

Vill bara slänga in en kommentar om att det ju inte är "Linux" fel att det eventuellt ser suddigt ut eller så. Skulle kunna vara distributionen man kör eller kombinationen skärm+grafikkort som gör att det krånglar. Att det funkar i Windows direkt för dig är ju mer en indikation på att just den kombinationen funkar bättre i Windows från scratch jfr m din Linuxdistribution vilket i mångt och mycket kan ha att göra med hårdvarutillverkarnas negligens i att fixa drivrutiner för multipla OS eller i varje fall släppa källkoden för dem fria.

Jag är väldigt nöjd med hur allt ser ut på min skärm med Linux, bättre än så kan det inte bli. I värsta fall kan du behöva experimentera med modelines för att få din skärm att fungera som den ska vilket isf är något som ligger på skärmtillverkarens bord, för det ska gå att få det att se likadant ut.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av phz
Vill bara slänga in en kommentar om att det ju inte är "Linux" fel att det eventuellt ser suddigt ut eller så. Skulle kunna vara distributionen man kör eller kombinationen skärm+grafikkort som gör att det krånglar. Att det funkar i Windows direkt för dig är ju mer en indikation på att just den kombinationen funkar bättre i Windows från scratch jfr m din Linuxdistribution vilket i mångt och mycket kan ha att göra med hårdvarutillverkarnas negligens i att fixa drivrutiner för multipla OS eller i varje fall släppa källkoden för dem fria.

Jag är väldigt nöjd med hur allt ser ut på min skärm med Linux, bättre än så kan det inte bli. I värsta fall kan du behöva experimentera med modelines för att få din skärm att fungera som den ska vilket isf är något som ligger på skärmtillverkarens bord, för det ska gå att få det att se likadant ut.

Jag har inte sagt att det är något fel på linux heller, det är inställningar nånstans som felar och jag vill veta vilka så jag kan använda linux.

Misstänker att det är något med font-renderingen

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Dec 2006

Om du har inställningar för subpixel antialiasing för teckensnitt (finns i alla fall i gnome/ubuntu 7.10) så prova att mixtra lite med dem, det kanske är så att dina pixel-element i skärmen står i ordningen bgr medans antialiasingen är ställd på rgb t.ex.

I \w+ regular expressions.

Trädvy Permalänk
Medlem
Registrerad
Jul 2001

Ännu värre i OSX, ser rent förj**ligt ut. Trodde att det var fel på min applebok, men efter att ha lagt in vista märker man skillnad. Fonter i OSX renderas dåligt. Finns det nått att göra?

Trädvy Permalänk
Medlem
Plats
/root
Registrerad
Jul 2001

Är det bara jag som tycker att fonterna i Windows ser helt förstörda ut men helt underbara under Linux och OSX?

"to conquer others is to have power, to conquer yourself is to know the way"
Blogg / Browser/OS-sniffer

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2003

Personligen tycker jag typsnitten i OS X är mycket snyggare och behagligare att läsa men smaken är ju olika...

http://www.google.com/search?client=safari&rls=en-us&q=%22os+...

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Sep 2003

McZ Jag har exakt samma problem!
Efter någon timma i Linux så får jag alltid huvudvärk.

Jag tror problemet ligger i att subpixel renderingen hos Linux är annolunda än den i Windows och att dina ögon helt enkelt inte vant sig. Jag upplever som du alla icke pixel fonter i Linux som suddiga. Om jag inte minns fel så finns det ett sätt att använda samma subpxel rendrering som Windows men eftersom det är patentintrång så lär du inte hitta den i repositoryn utan du får googla lite.

Core 2 Quad Q6600 | Gigabyte GA-P35-DS3 | Corsair XMS2-6400 2x2048MB | Corsair HX 520W | BFG 8800GT

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

David Turners patch har Ubuntu tagit in i Gutsy o Gnome

Beskrivning
http://ubuntuforums.org/showthread.php?t=489326

XCFE o Arch ?

I Hardy har man tagit fler steg och testar just nu Cairo patchar.

I Gnome finns det sedan massvis med installningar inkl detaljer.

Redhats Liberation Font och deras Sans version ar kanon i Hardy.
Licenstrubbel dar ocksa tyvarr.

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av jnk3
Personligen tycker jag typsnitten i OS X är mycket snyggare och behagligare att läsa men smaken är ju olika...

http://www.google.com/search?client=safari&rls=en-us&q=%22os+...

Tackar Thinkertool löste biffen : Gick att stänga av foontsmooth och nu ser allt mycket bättre ut

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av altis
McZ Jag har exakt samma problem!
Efter någon timma i Linux så får jag alltid huvudvärk.

Jag tror problemet ligger i att subpixel renderingen hos Linux är annolunda än den i Windows och att dina ögon helt enkelt inte vant sig. Jag upplever som du alla icke pixel fonter i Linux som suddiga. Om jag inte minns fel så finns det ett sätt att använda samma subpxel rendrering som Windows men eftersom det är patentintrång så lär du inte hitta den i repositoryn utan du får googla lite.

Jag hittade precis subpixel patchar för archlinux.. baserat på patcharna från ubuntu och jag håller på att installera nu får se. Även hittat en ombyggd firefox3-beta2 som ska använda systemets (patchade) cairo istället för firefox egna inbyggda.

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
V-ås - är jag inte söt?
Registrerad
Jul 2001

Konstigt att du ännu inte fått standardsvaret när det gäller allsköns problem med Linux. "Linux är perfekt. Det är väl dina ögon som suger."

Coola låtar i massor!
http://revolvermen.com

Trädvy Permalänk
Medlem
Plats
IRC
Registrerad
Nov 2004
Citat:

Ursprungligen inskrivet av Ilja
Konstigt att du ännu inte fått standardsvaret när det gäller allsköns problem med Linux. "Linux är perfekt. Det är väl dina ögon som suger."

Med lite humor kan du få

Citat:

Ursprungligen inskrivet av Girgoo
Jag förstår inte varför inte sharpfonts inte är standard överallt?

att betyda det.

mirkk

Trädvy Permalänk
Medlem
Registrerad
Jan 2007

radhus

OS X har ju nånting liknande från start aktiverat som någon ovan skrev, smooth nåt.

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007
Citat:

Ursprungligen inskrivet av McZ
Jag hittade precis subpixel patchar för archlinux.. baserat på patcharna från ubuntu och jag håller på att installera nu får se. Även hittat en ombyggd firefox3-beta2 som ska använda systemets (patchade) cairo istället för firefox egna inbyggda.

Hittade den har bloggen om Arch och Liberation Fonts

http://lucaserano.blogspot.com/2007/06/liberation-fonts-on-ar...

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Registrerad
Jun 2006

http://www.bronsaldersvagen.se/Eazy/dump.png

Här är mina settings i kde. Jag kan inte med linux fonts för jag får också ont i huvudet. Hos mig ser det ut precis som i windows om inte mer skarpare.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Jag tror ditt problem är samma som mitt, jag gillar verkligen inte de överdrivet stora och luddiga teckensnitten. De är verkligen hemskt utformade och renderar helkass tyvär.

Trädvy Permalänk
Medlem
Plats
Stan
Registrerad
Mar 2004

Jag hade lite liknande problem till en början med Linux (och även XP när jag slog på Cleartype första gången) men jag vande mig efter ett tag. I Linux fick jag byta ut ett par av typsnitten som var angivna som standard och ändra storleken samt mixtra lite med subpixelinställningarna, som sagt. Men efter ett tag vande jag mig.

Citat:

Ursprungligen inskrivet av Ilja
Konstigt att du ännu inte fått standardsvaret när det gäller allsköns problem med Linux. "Linux är perfekt. Det är väl dina ögon som suger."

Räcker inte detta?

Citat:

Ursprungligen inskrivet av Smokerdave
Alltså om det är exakt samma inställningar på skärmen som du har i Windows är det ju något med Linux du är allergisk emot. Antingen tål du inte utseendet, [b]eller så tål du inte ideologin.[/b]

För övrigt anser jag att Sverker Olofsson borde bannlysas, som Cato den Äldre sade.

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Jo jag vet inte vad ni är för samling självplågare....

Mark S skrev det här förra våren som gjorde att Ubuntu blev aktivare
och plockade in patcharna från David Turner (trots patent/licensstrul)

http://www.markshuttleworth.com/archives/119

I Gutsy är det då helt klart OK, med Hardy har man jobbat vidare och
patchat cairo.

Rendering och fonter har varit usla....KDE4 innehåller även det ny font rendering.

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jan 2006

Jag har en idé, testa att sänka ljusstyrkan lite. Brukar ta mindre på ögonen efter en stund.. Lycka till.

Gigabyte-P35-DS4 | Intel Core 2 Quad Q6600 [3 GHz] | 2x1GB Corsair XMS-6400@800Mhz | Nvidia Geforce 460 GTX [975/2000 MHz] | Intel 320 Series 80 GB SSD | | SETI@Home Team: Sweclockers.com