Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2003

Synlig SMB i nätverket

Halloj

Har ett litet problem, alla mina windows-burkar i nätverket dyker upp i Findern i min MacBook (Leopard), förutom min Linuxserver. Och det är just den jag vill få upp då den är filservern

Vad ska jag göra för inställningar i min smb.conf för att linuxburken ska dyka upp? Nu ser den ut såhär:

[global]
workgroup = SKYNET

[Film1]
path = /ftp/Film1
public = yes
write list = bran

[Musik]
path = /ftp/Musik
public = yes
write list = bran

Osv..

Och det funkar ju utmärkt när jag i Findern väljer Go-> Connect to Server, men vill ju som sagt få den att dyka upp automagiskt.

4930K | 32GB @ 2400Mhz | GTX980Ti SLI | LG 34UM95 | Hifiman HE560, Pre Box S2 Digital & Arcam rHead
Sonus Faber Venere 3.0 | 2*XTZ 10.17 | RX-A2070 | Emotiva XPA3 3*200W | Samsung JS9505 65" |

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Testa med, netbios name = dindata.

Sen är även Leopard lite lurigt med att hitta dessa. Funkar det ändå inte testa att skapa en ny network location.

Trädvy Permalänk
Medlem
Plats
irc
Registrerad
Dec 2004

Hur menar du dyker upp? Finns den i findern när servern väl är mountad?

Behind every great fortune there is a crime. - Honoré de Balzac
simonb @ irc

Trädvy Permalänk
Medlem
Plats
Sundsvall
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Movement
Hur menar du dyker upp? Finns den i findern när servern väl är mountad?

Leopard letar rätt på SMB-utdelningar och gör dem synliga i Finder.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av texture
Testa med, netbios name = dindata.

Sen är även Leopard lite lurigt med att hitta dessa. Funkar det ändå inte testa att skapa en ny network location.

Ja nej det funka ju inte tyvärr..

4930K | 32GB @ 2400Mhz | GTX980Ti SLI | LG 34UM95 | Hifiman HE560, Pre Box S2 Digital & Arcam rHead
Sonus Faber Venere 3.0 | 2*XTZ 10.17 | RX-A2070 | Emotiva XPA3 3*200W | Samsung JS9505 65" |

Trädvy Permalänk
Medlem
Plats
irc
Registrerad
Dec 2004
Citat:

Ursprungligen inskrivet av Ibis
Leopard letar rätt på SMB-utdelningar och gör dem synliga i Finder.

Grejjen är ju att det är inte Leopard som letar upp smb-shares, den visar bonjour-shares

Installera avahi-daemon på servern och konfa den för samba så bör servern dyka upp.
Här är för smb-servicen tex:

<?xml version="1.0" standalone='no'?> <service-group> <name>Server SMB</name> <service> <type>_smb._tcp</type> <port>139</port> </service> </service-group>

Behind every great fortune there is a crime. - Honoré de Balzac
simonb @ irc

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av Movement
Grejjen är ju att det är inte Leopard som letar upp smb-shares, den visar bonjour-shares

Installera avahi-daemon på servern och konfa den för samba så bör servern dyka upp.
Här är för smb-servicen tex:

<?xml version="1.0" standalone='no'?> <service-group> <name>Server SMB</name> <service> <type>_smb._tcp</type> <port>139</port> </service> </service-group>

Okej, men den hittar ju XP/Vista burkarna utan problem?

4930K | 32GB @ 2400Mhz | GTX980Ti SLI | LG 34UM95 | Hifiman HE560, Pre Box S2 Digital & Arcam rHead
Sonus Faber Venere 3.0 | 2*XTZ 10.17 | RX-A2070 | Emotiva XPA3 3*200W | Samsung JS9505 65" |

Trädvy Permalänk
Medlem
Plats
irc
Registrerad
Dec 2004

Antagligen för att de redan har något bonjour-liknande.

Behind every great fortune there is a crime. - Honoré de Balzac
simonb @ irc

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Det där har inte jag behövt göra för att få mina smbshares dyka upp. Har inget alls installerat som är med bonjour att göra.

Trädvy Permalänk
Medlem
Plats
irc
Registrerad
Dec 2004

Ska kanske sägas att jag gjorde detta för att få min AFP-share att dyka upp, kanske redan finns något i Samba.

Behind every great fortune there is a crime. - Honoré de Balzac
simonb @ irc

Trädvy Permalänk
Medlem
Plats
Localhost
Registrerad
Mar 2002

global] workgroup = foo server string = foo security = user load printers = no log file = /var/log/samba.%m max log size = 500 socket options = TCP_NODELAY hosts allow = 127.0.0.1 192.168.4.14 hosts deny = 0.0.0.0/0 [home] comment = home path = /home/ writable = yes

Så ser min ut. Och jag får den till att synas i Leopard. Men det tog ett tag innan den dök upp. Jag körde med Connect to server i början. Men den ligger i finder nu.