Flera hemsidor på en webserver

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2005

Flera hemsidor på en webserver

Hej, har precis slängt upp en webserver, och har en dyndns som pekar mot mitt ip. Nu är det så att både jag och min syrra skulle vilja ha våra egna sidor, med egna dyndns.

Just nu i man /var/www/ så finns två mappar, erik och anna. Jag skulle vilja att t.ex. helin.mine.nu pekade mot /var/www/erik och anna.mine.nu pekade mot /var/www/anna.

Går detta att fixa?

AMD Athlon 64 3200+ // Asus K8V-VM // 1 GB DDR 400 // Asus EN7600 GS // Soundblaster Live! // FSP 350W // Ubuntu 9.10
MacBook 13,3 // 2.2 GHz Core 2 Duo // 4 GB DDR2 667 // 120 GB HDD // Intel GMA X3100 // Mac OS X 10.6
HP e-PC 42 // P4 1,7 Ghz // 512MB SDRAM // 500 GB HDD // Ubuntu Server 8.04

Trädvy Permalänk
Medlem
Plats
Tält
Registrerad
Dec 2007

Ja. använd dig av apaches visual hosts.
För att se hur du gör är apaches manualen den bästa du kan hitta. ;D

Trädvy Permalänk
Medlem
Plats
Västkusten
Registrerad
Okt 2002

och det heter förstås virtual hosts, nåt annat kan bli svårt att hitta.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2005

Jag har försökt med virtual hosts nu ett litet tag, men det går inge bra. Så här ser min httpd.conf ut:

ServerName garderoben

NameVirtualHost 85.226.244.179

<VirtualHost 85.226.244.179>
ServerName helin.mine.nu
DocumentRoot /var/www/erik
</VirtualHost>

<VirtualHost 85.226.244.179>
ServerName annahelin.mine.nu
DocumentRoot /var/www/anna
</VirtualHost>

Men det vill ändå inte funka?

AMD Athlon 64 3200+ // Asus K8V-VM // 1 GB DDR 400 // Asus EN7600 GS // Soundblaster Live! // FSP 350W // Ubuntu 9.10
MacBook 13,3 // 2.2 GHz Core 2 Duo // 4 GB DDR2 667 // 120 GB HDD // Intel GMA X3100 // Mac OS X 10.6
HP e-PC 42 // P4 1,7 Ghz // 512MB SDRAM // 500 GB HDD // Ubuntu Server 8.04

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Det ska nog funka ifall du ändrar httpd.conf till:

NameVirtualHost *:80

<VirtualHost *:80>
ServerName helin.mine.nu
DocumentRoot /var/www/erik
</VirtualHost>

<VirtualHost *:80>
ServerName annahelin.mine.nu
DocumentRoot /var/www/anna
</VirtualHost>

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2005

GenuineDexxa: Jag har prövat det, men då klagar den på:

[error] mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

AMD Athlon 64 3200+ // Asus K8V-VM // 1 GB DDR 400 // Asus EN7600 GS // Soundblaster Live! // FSP 350W // Ubuntu 9.10
MacBook 13,3 // 2.2 GHz Core 2 Duo // 4 GB DDR2 667 // 120 GB HDD // Intel GMA X3100 // Mac OS X 10.6
HP e-PC 42 // P4 1,7 Ghz // 512MB SDRAM // 500 GB HDD // Ubuntu Server 8.04

Trädvy Permalänk
Medlem
Plats
In the ghetto
Registrerad
Sep 2005
Citat:

Ursprungligen inskrivet av GenuineDexxa
Det ska nog funka ifall du ändrar httpd.conf till:

NameVirtualHost *:80

<VirtualHost *:80>
ServerName helin.mine.nu
DocumentRoot /var/www/erik
</VirtualHost>

<VirtualHost *:80>
ServerName annahelin.mine.nu
DocumentRoot /var/www/anna
</VirtualHost>

Jag skrev oxå det i min httpd.conf men då fick jag detta felmeddelande när jag starta om apache2:

Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName [Sat Feb 09 19:34:01 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results [Sat Feb 09 19:34:01 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results [Sat Feb 09 19:34:01 2008] [warn] NameVirtualHost *:80 has no VirtualHosts apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName [Sat Feb 09 19:34:12 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results [Sat Feb 09 19:34:12 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results [Sat Feb 09 19:34:12 2008] [warn] NameVirtualHost *:80 has no VirtualHosts

Workstation: Intel Core 2 Duo E6420 | 4GB DDR2 PC5300 | 8800GTS 320Mb | 500Gb Sata2 |
WD My Book Essential Edition 500Gb |

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Om ni har kvar något i tex /etc/apache2/sites-available och /etc/apache2/sites-enabled kanske ni måste ta bort det.

Trädvy Permalänk
Medlem
Plats
Laholm
Registrerad
Okt 2005

Jag har:

NameVirtualHost *

<VirtualHost *>
</VirtualHost>

Funkar kanonbra.

ASP.NET programmerare i C#
Twitter: http://www.twitter.com/hagbarddenstore

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Citat:

Ursprungligen inskrivet av GenuineDexxa
Om ni har kvar något i tex /etc/apache2/sites-available och /etc/apache2/sites-enabled kanske ni måste ta bort det.

De katalogerna finns bara på Debian-baserade system, t ex Ubuntu. Då trådskaparen i detta fall verkar ha just det så får han läsa på om hur Debian sköter sites och sånt.

Istf att ta bort dem så ska man i stället utnyttja det system som finns på Debian-baserade distar och de verktyg som finns för att göra ens liv enklare, såsom a2ensite, a2dissite, a2enmod och a2dismod.

Citat:

Ursprungligen inskrivet av hagbarddenstore
Jag har:

NameVirtualHost *

<VirtualHost *>
</VirtualHost>

Funkar kanonbra.

Jo, men då får ju trådskaparen inte den funktionaliteten som eftersöks.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2005

Det verkar funka med * på NameVirtualHost och sen <VirtualHost *> för varje sida som jag vill ha. Visserligen klagar apache, men det funkar, så det får vara såhär så länge.

Tack för all hjälp!

AMD Athlon 64 3200+ // Asus K8V-VM // 1 GB DDR 400 // Asus EN7600 GS // Soundblaster Live! // FSP 350W // Ubuntu 9.10
MacBook 13,3 // 2.2 GHz Core 2 Duo // 4 GB DDR2 667 // 120 GB HDD // Intel GMA X3100 // Mac OS X 10.6
HP e-PC 42 // P4 1,7 Ghz // 512MB SDRAM // 500 GB HDD // Ubuntu Server 8.04

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jan 2006

Skippa httpd.conf-filen helt, det blir lättare om ni gör ändringarna i /etc/apache2/sites-available/default

Typ så här kan den se ut:

NameVirtualHost *:80 <VirtualHost *:80> ServerName helin.mine.nu DocumentRoot /var/www/erik </VirtualHost> <VirtualHost *:80> ServerName annahelin.mine.nu DocumentRoot /var/www/anna </VirtualHost>

Gigabyte-P35-DS4 | Intel Core 2 Quad Q6600 [3 GHz] | 2x1GB Corsair XMS-6400@800Mhz | Nvidia Geforce 460 GTX [975/2000 MHz] | Intel 320 Series 80 GB SSD | | SETI@Home Team: Sweclockers.com

Trädvy Permalänk
Medlem
Plats
Tomelilla
Registrerad
Okt 2001

Ska man vara riktigt petig så är det snyggare o lägga de i separata filer under sites-avaiable och sen aktivera varje site med a2ensite "site-filens-namn".

t.ex

/etc/apache2/sites-avaiable/helin.mine.nu

NameVirtualHost *:80 <VirtualHost *:80> ServerName helin.mine.nu DocumentRoot /var/www/erik ErrorLog /var/log/apache2/helin.mine.nu.log CustomLog /var/log/apache2/helin.mine.nu.access.log combined </VirtualHost>

/etc/apache2/sites-avaiable/anna.mine.nu

NameVirtualHost *:80 <VirtualHost *:80> ServerName anna.mine.nu DocumentRoot /var/www/anna ErrorLog /var/log/apache2/anna.mine.nu.log CustomLog /var/log/apache2/anna.mine.nu.access.log combined </VirtualHost>

a2ensite helin.mine.nu a2ensite anna.mine.nu /etc/init.d/apache2 force-reload

Ovanstående fungerar iaf på ubuntu.

EDIT: Och först nu läser man resten av tråden och ser att allt de jag skrev redan omnämnts..

Trädvy Permalänk
Medlem
Plats
In the ghetto
Registrerad
Sep 2005

Om jag vill att alla undermappar i en mapp ska se ut så här: mappensnamn.mindomän.se, gör jag det via virtual hosts? Om ja, hur ska jag enkelt fixa det?

Workstation: Intel Core 2 Duo E6420 | 4GB DDR2 PC5300 | 8800GTS 320Mb | 500Gb Sata2 |
WD My Book Essential Edition 500Gb |

Trädvy Permalänk
Medlem
Registrerad
Aug 2003
Citat:

Ursprungligen inskrivet av helino
GenuineDexxa: Jag har prövat det, men då klagar den på:

[error] mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

Byt ut *:80 med [serverns IP]:80 så ska det där felmeddelandet försvinna.

edit: funkar iofs inte på min server... blabla.no-ip.org funkar men inte blablabla.no-ip.org/nåtannat/

Trädvy Permalänk
Medlem
Plats
local
Registrerad
Feb 2004
Citat:

Ursprungligen inskrivet av Ozz_z
Om jag vill att alla undermappar i en mapp ska se ut så här: mappensnamn.mindomän.se, gör jag det via virtual hosts? Om ja, hur ska jag enkelt fixa det?

ja. Kolla dynamisk vhost i apache docen.

http://httpd.apache.org/docs/2.0/mod/mod_vhost_alias.html