Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2005

Linux Arch SSH problem

Tjenare!
Som ni ser på topic så har jag lite problems med min server, då den inte vill acceptera SSH anslutningar.

Om jag testat att köra putty och kontackta serverns ip nummer så säger den bara, "Connection was refused" vilket är lite underligt :S Då känns det som att SSH är igång bara att den inte vill acceptera min anslutnig

Jag kan förövrigt pinga servern. Är det någon som har nån ide på vad felet kan vara?

CPU: Intel 2600k @ Stock | CPU-Kyl: Schyte Infinity | GPU: Nvidia GTX680 2GB @ 1,2GHz | RAM: Corsair XMS3 @ 1600MHz 4x4GB | MB: Asus P8P67 Deluxe | Chassi: Define R3 | SSD: Samsung 840 512GB | PSU: Corsair HX 750W

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2001

Det framgår inte riktigt av topic om du menar distributionen archlinux eller gnu arch, versionshanteringssystemet, men jag gissar utifrån inläggets innehåll att det är det förra.

Skulle jag vara dristad att gissa orsak så är det pga hosts.allow och hosts.deny. Som standard i archlinux är hosts.deny satt till att vägra alla anslutningar, medan hosts.allow är tom. Lägg till följande i /etc/hosts.allow:

sshd: ALL

Alternativt kan man även skriva in ip-ranges, eller enstaka ip-adresser, med mera med mera.

The power of GNU compiles you!
"Often statistics are used as a drunken man uses lampposts -- for support rather than illumination."
#fooblog @ freenode.org, #lysator @ freenode.org

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2005

aah ursäkta, men ja det är disten archlinux jag menade. Tack ska kolla i dom filerna när jag kommer hem

Tack för hjälpen!

CPU: Intel 2600k @ Stock | CPU-Kyl: Schyte Infinity | GPU: Nvidia GTX680 2GB @ 1,2GHz | RAM: Corsair XMS3 @ 1600MHz 4x4GB | MB: Asus P8P67 Deluxe | Chassi: Define R3 | SSD: Samsung 840 512GB | PSU: Corsair HX 750W

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Apr 2005

Om det kode sa inte fungerar kan du prova att ändra en sak i /etc/sysctl.conf .

Grund inställningen är:

net.ipv4.ip_forward=0

att ändra det till:

net.ipv4.ip_forward=1

kan hjälpa.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2001

Du bör förstås också stänga av PermitRootLogin i /etc/ssh/sshd_config, även om det är av en annan anledning.

The power of GNU compiles you!
"Often statistics are used as a drunken man uses lampposts -- for support rather than illumination."
#fooblog @ freenode.org, #lysator @ freenode.org

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Nov 2001

Jo, det är helt rätt vad kode säger, står på wikin...
Wikin är din vän

Battlestation: 4770k - gtx1070 - 16gb ram - Samsung SSD
Server: 2x Xeon E5-2670 - 64GB Ecc ram
Synology NAS

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2005

tack så jättemycket för hjälpen nu ska ja kolla upp allt dettahar precis kommit hem!

EDIT

Har ändrat allt som ni sa, men det ser ändå inte ut att funka som jag vill :S

Får ett fel som säger... "server unexpectedly closed network connection"

EDIT2

Nu funkar det det va min host.allow fil som inte blev sparad :S

CPU: Intel 2600k @ Stock | CPU-Kyl: Schyte Infinity | GPU: Nvidia GTX680 2GB @ 1,2GHz | RAM: Corsair XMS3 @ 1600MHz 4x4GB | MB: Asus P8P67 Deluxe | Chassi: Define R3 | SSD: Samsung 840 512GB | PSU: Corsair HX 750W