Arch Linux, Alsa och Creative Xmod

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Nov 2004

Arch Linux, Alsa och Creative Xmod

Slängde in Arch Linux idag men fastnade på att få min Creative Xmod att fungera.

cat /proc/asound/cards:

0 [ICH6]: ICH4 - Intel ICH6 Intel ICH6 with ALC655 at irq 18 1 [Modem]: ICH-MODEM - Intel ICH6 Modem Intel ICH6 Modem at irq 18 2 [Xmod]: USB-Audio - Creative Xmod Creative Technology Ltd Creative Xmod at usb-0000:00:1d.7-3.1, full speed

Där dyker kortet upp men om jag kör alsaconf så finns bara intel och legacy med.

Har letat runt på nätet ett bra tag nu utan att finna något givande så jag tänkte höra om någon här har några idéer om vad man kan göra?

Behövs mer info så är det bara att säga till.

Tack i förhand!

*edit*

Lite närmare nu (tror jag i alla fall).

Lade till detta till min /etc/modprobe.conf:

alias char-major-116 snd alias char-major-14 soundcore alias snd-card-0 snd-usb-audio alias sound-slot-0 snd-card-0 alias sound-service-0-0 snd-mixer-oss alias sound-service-0-1 snd-seq-oss alias sound-service-0-3 snd-pcm-oss alias sound-service-0-8 snd-seq-oss alias sound-service-0-12 snd-pcm-oss alias /dev/mixer snd-mixer-oss alias /dev/dsp snd-pcm-oss alias /dev/midi snd-seq-oss options snd-usb-audio index=0 alias snd-card-1 snd-intel8x0 alias sound-slot-1 snd-card-1 alias sound-service-1-0 snd-mixer-oss alias sound-service-1-3 snd-pcm-oss alias sound-service-1-12 snd-pcm-oss options snd-intel8x0 index=1 alias /dev/dsp1 snd-pcm-oss options snd cards_limit=2 options snd-usb-audio nrpacks=1

Så nu så står Creative Xmod som "card" i alsamixer men jag får fortfarande inte ut något ljud.

VLC säger:

[00000334] oss audio output error: write failed (Broken pipe)

Så nu är jag fast igen alltså... Några idéer?

*edit2*

dmesg säger:

cannot submit datapipe for urb 0, error -28: not enough bandwidth

Hmm...

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Apr 2005

Är du med i Audio gruppen då? Det är ett måste om du vill ha ljud.
Glömde det själv i Arch förra veckan...

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Nov 2004
Citat:

Ursprungligen inskrivet av Arius
Är du med i Audio gruppen då? Det är ett måste om du vill ha ljud.
Glömde det själv i Arch förra veckan...

Jo, jag har lagt till mig själv. Håller dock just nu på att ändra lite saker i min kernel som jag har hört kan vara fel så får återkomma med besked om hur det gick.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2004

Har du testat spela upp någon .wav fil med "aplay"? Verkar som att VLC använder OSS och inte ALSA om man kollar på felmeddelandet.

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Nov 2004
Citat:

Ursprungligen inskrivet av Dark Defender
Har du testat spela upp någon .wav fil med "aplay"? Verkar som att VLC använder OSS och inte ALSA om man kollar på felmeddelandet.

aplay /usr/share/sounds/alsa/Front_Center.wav Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono aplay: set_params:923: Channels count non available

Ska se om jag kan hitta hur man löser det problemet.

*edit*

ALSA lib pcm_direct.c:975:(snd1_pcm_direct_initialize_slave) unable to install hw params ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to initialize slave aplay: main:564: audio open error: Brutet rör

Samma fel med aplay nu.

*edit*
Fungerar nu! Jag kopplade bara in min xmod rätt in i datorn istället för genom en hub. Verkar vara något allmänt problem det där med hubbarna.