Uppspelning av video i ubuntu = kasst ?

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Uppspelning av video i ubuntu = kasst ?

Hello Boys And Girls

Jag håller på och pillar lite med en htpc som jag tills för ett par dagar sedan körde windows xp plus programmet Mediaportal på. Detta funkade sådär men jag fick åtminstånde riktigt bra bild på allt material jag spelade upp.
Nu har jag installerat Ubuntu 7.10 och alla codecs och drivrutiner man ska ha, (w32codecs och sånt där som finns) men jag lyckas ändå inte få till bilden så där klockren som jag vill ha.
Är detta pga av att ubuntu inte kan använda min hårdvara lika bra som winxp eller är det ngt speciellt man måste göra för att få till videouppspelning? Materialet jag pratar om är xvid och x246/720p.
x264/720p flyter suveränt på winxp men jag antar att det kan bero på codecet Core AVC för om jag inte har det installerat på winxp så får jag precis samma bild som i ubuntu.

Min hårdvara:
Amd x2 4800+
2gig ram
Ati Radeon x1300

Hoppas inlägget inte blev för rörigt.
Mvh Tank

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Apr 2007

installera mediaspelaren mplayer och konfa den rätt så kommer bilden bli perfekt. Det frakommer inte huruvida u installerat drivrutiner för ditt grafikkort eller inte. Sen om det är en mediaenter du använder borde ju Ubuntu 8.04 pass bättre. Men men

Macbook Pro 2011 17" - 8GB Ram@1333 MHz - i7-2720QM - 120GB Vertex 3 Max IOPS

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Jag har installerat mplayer och får samma resultat där. Däremot har jag ej "konfat" den. Har du ngn länk till tillvägagångs-sätt?

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Apr 2007

Drivrutinerna till grafikkortet?

Macbook Pro 2011 17" - 8GB Ram@1333 MHz - i7-2720QM - 120GB Vertex 3 Max IOPS

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Skulle precis edit min post när du skrev svar:)
Ati:s drivrutiner är installerade via Envy om det hjälper.

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Apr 2007

ok, då ska du försöka ställa in mplayer. Jag kör mlayer och inte gmplayer. I din hemkatalog ligger en dold mapp som heter .mplayer, i den mappen finns configurationsfilerna för mplayer.

Min config ser ut så här:

monitoraspect=16:10
stop-xscreensaver=yes
ontop=yes
fs=yes
vo=x11
zoom=yes
double=yes
font=/usr/share/fonts/truetype/msttcorefonts/impact.ttf
ffactor="10"
sub-bg-alpha="0"
sub-bg-color="0"
subfont-text-scale="2"
subfont-blur="2"
spuaa=4
subpos=100
subalign=2
sub-fuzziness=2

Nu har du ett ATI kort men det borde funka bra för dig med. Du kan ändra vo= och testa andra, tex xv o.s.v.

Macbook Pro 2011 17" - 8GB Ram@1333 MHz - i7-2720QM - 120GB Vertex 3 Max IOPS

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Har du ngn erfarmhet av xbmc för linux? Fr det är där jag vill ha den bra bilden och vad jag har förstått så använder dom inte mplayer utan ngn egen spelare. Men jag tänkte att om jag får bra bild i resten av ubuntu så borde det funka i xbmc med. För nu är bilden precis likadan både i ubuntu och inne i xbmc. Kan det stämma?

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Allting är relativt med codecs.... "bless this mess".

Mplayer behöver oftast sitt eget codecs pack
http://www.mplayerhq.hu/design7/dload.html

En bit ner, Binary Codecs Pack

Sen är standard mappen, /usr/local/lib/codecs/

gksudo nautilus så har man root behörighet att skapa mappen och flytta codecsen dit.

Codecsstatus just nu:
http://www.mplayerhq.hu/DOCS/codecs-status.html

-------------------------------------
Bossieman du kan väl ev röja upp i den här soppan och göra några bra guider.

- ubuntu-restricted-extras

- Medibuntu repot

- Mplayer special.

mplayer är helt överlägsen totem junket....

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2003

testa lägg till detta i din config med brukar hjälpa en del
lavdopts=threads=2

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Hej igen.
Har testat era tips utan ngn framgång.
Har skickat upp ett par bilder för att enklare förklara mitt problem och det kanske kan hjälper er, hjälpa mig

http://www.onlinecenter.nu/?913903080421171832
http://www.onlinecenter.nu/?598680080421172312
http://www.onlinecenter.nu/?519204080421172329

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Har du Compiz aktiverat ?

Med Intel samt ATI finns inget DRI2 stöd så då blir det knas, kommer
under året.

Från terminalen

metacity --replace

starta filmen igen och kolla hur det ser ut.

compiz --replace för effekter igen

(i Ubuntu 8.04 finns fusion-icon i repot för enkel skiftning)

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Tyvärr får jag samma resultat då med.

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Vete tusan... ATI...

Om du högerklickar på mplayer och inställningar > Videofliken

Nu kör jag Hardy men jag har 2 OpenGL samt en X11 att välja på.
Skifta och kolla.

"Pixlingen" du har tyder på att det går tungt.

Vad har du för glxgears värden ? Terminalen > glxgears

(iofs inget bra värde men säger ändå om det produceras grafik någotsånär)

Annat att kolla är om du har någon eller några processer som löper amok...

Enklast via Systemverktyg > Systemövervakaren.

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Testat byta melle opengl, 2an och dom andra valen med men dom blir bara värre.
Inga galna processer ser jag heller.

:~$ glxgears
15449 frames in 5.0 seconds = 3089.761 FPS
15482 frames in 5.0 seconds = 3096.310 FPS
15483 frames in 5.0 seconds = 3096.427 FPS
15480 frames in 5.0 seconds = 3095.931 FPS
15480 frames in 5.0 seconds = 3095.876 FPS
15481 frames in 5.0 seconds = 3096.167 FPS
15479 frames in 5.0 seconds = 3095.631 FPS

Vet inte hur detta ska se ut ^^

Det skumma är ju när du säger att det går tungt.. det funkar ju suveränt i winxp... lustigt som fan tycker jag... core avc for linux please...
*edit. När jag försöker spela upp en vanlig xvid får jag samma problem... borde väl tyda på att det inte är ett codec-problem iaf ? Ska kolla över grafikkorts-drivrutinerna igen.*

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Vete tusan igen, glx värdena helt OK

Så här ser ATI gurusarna manual för just Gutsy ut.

http://wiki.cchtml.com/index.php/Ubuntu_Gutsy_Installation_Gu...

2 metoder beskrivs då och det kan kanske vara värt att kolla igenom.

OBS !!!... om det går åt pipsvängen så har du en "Revert" beskrivning på slutet, många
som det blir fel för....

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
M-by
Registrerad
Apr 2003

Kan jag kolla någonstans vilken driver som egentligen används?
Jag kan ju gå in o pilla i ngt som heter Catalyst Control Center så då tycker jag ju att den borde använda atis drivare + att jag kan köra 1360*768 till min plasma.

|EDIT| Hmm så här ser en del av min xorg.conf ut.. tycker det borde stå ATI någonstans men det gör det ej.

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "50PC1R-ZH"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "50PC1R-ZH"
DefaultDepth 24
SubSection "Display"
Modes "1360x768" "1280x1024" "1280x768" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

"He never races anybody, he just sit there and scares the hell out of 'em"
“Eagles may land on the same mountain but they don’t flock together. Eagles fly alone.”

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2004

Testa att med:

aticonfig --initial --input=/etc/X11/xorg.conf

Här finns en hel del bra tips om xorg inställningar också: http://forum.compiz-fusion.org/showthread.php?t=6794
Jag var tvungen att ställa in en hel del i xorg innan XV ville fungerar på mitt x1900

Trädvy Permalänk
Avstängd
Registrerad
Mar 2006

Han kör ju med vesa-drivern? Under "Device", raden "Driver", ändra från vesa till fglrx så kanske de går bättre?

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2004

Jag tror det är bättre om aticonfig fixar xorg.conf åt honom för att vara på den säkra sidan.

Trädvy Permalänk
Medlem
Plats
192.168.1.267
Registrerad
Apr 2003

Hade liknande fel som dig med mitt nvidia kort med senaste drivers på min 42" tv kopplad via dvi>hdmi. Men inte bara i filmer, även när man flyttar fönster på skärmen. Första bilden visar nog mitt fel bäst, men jag hade inte lika mycket. Vet inte riktigt hur man ska förklara det men det blir streck i fönstret som delar upp fönstret i delar och vissa av dom rör sig inte lika snabbt eller smidigt som där det inte är problem.

Gjorde att jag bytte tillbaka till xp igen eftersom jag kollar på väldigt mycket film där problemet snabbt blev väldigt störande.

CCNP

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003

Det finns tydligen en lösning 'coreavc-for-linux'
http://en.wikipedia.org/wiki/CoreAVC
Sen ska det finnas en linux version av coreplayer, men den är "OEM only" enligt siten.

CoreAVC är snabbare än andra codecs, 1080p mkv ger t.ex. en del framedrops i VLC på Macbook Pro men kör man med CorePlayer för OS X bör det inte vara något problem.

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Jo jag googlade på det här och mplayer stödjer ju libFAAD för det här formatet.
Nu orkar inte den decodern med detta. Vidare stödjer varken nVidia eller ATI HD format
så CPUn får ta hela smällen.

En patchning som verkar funka
http://code.google.com/p/coreavc-for-linux/wiki/MplayerInstal...

Här kör de då med gamla codecs placeringen.

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Okt 2003

Problemet är att du inte får hårdvaruaccelerering av hd-material på grafikkortet i Linux plus att CoreAVC som finns på windows är flertrådat vilket är en djävulsk förbättring mot enkeltrådat. På Linux finns varken hårdvaruacceleration eller en enkel lösning för flertrådat.

Som jag förstått det.

Ubuntu, Matlab och Latex, vad mer behövs?

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2004
Citat:

Ursprungligen inskrivet av Gräs-Mannen
Problemet är att du inte får hårdvaruaccelerering av hd-material på grafikkortet i Linux plus att CoreAVC som finns på windows är flertrådat vilket är en djävulsk förbättring mot enkeltrådat. På Linux finns varken hårdvaruacceleration eller en enkel lösning för flertrådat.

Som jag förstått det.

Om inte jag missupfattat något så har man hårdvaruacceleration för video uppspelning i Linux. Annars skulle ju alla köra med X11 rendern som använder bara CPU:n. Det är när man väljer Opengl/Xv som grafikkortet tar och hjälper till. Jag får iallafall mycket lägre CPU belastning och kan spela upp HD-filmer utan problem när jag avänder någon av dessa metoder. Sen kan man ju optimera mplayer efter sin dator så den använder tex 3dNow osv.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Okt 2003
Citat:

Ursprungligen inskrivet av Dark Defender
Om inte jag missupfattat något så har man hårdvaruacceleration för video uppspelning i Linux. Annars skulle ju alla köra med X11 rendern som använder bara CPU:n. Det är när man väljer Opengl/Xv som grafikkortet tar och hjälper till. Jag får iallafall mycket lägre CPU belastning och kan spela upp HD-filmer utan problem när jag avänder någon av dessa metoder. Sen kan man ju optimera mplayer efter sin dator så den använder tex 3dNow osv.

Jag tänker på nya tekniker från AMD och Nvidia som möjliggör närapå 100% avkodning av x264 och allt vad det heter. Ska se om jag hittar lite närmare information.

Ubuntu, Matlab och Latex, vad mer behövs?

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007
Citat:

Ursprungligen inskrivet av Dark Defender
Om inte jag missupfattat något så har man hårdvaruacceleration för video uppspelning i Linux. Annars skulle ju alla köra med X11 rendern som använder bara CPU:n. Det är när man väljer Opengl/Xv som grafikkortet tar och hjälper till. Jag får iallafall mycket lägre CPU belastning och kan spela upp HD-filmer utan problem när jag avänder någon av dessa metoder. Sen kan man ju optimera mplayer efter sin dator så den använder tex 3dNow osv.

För lat att leta upp diskussionen igen men som jag läste igår så använder då Mplayer libfaad som codecs, det är för långsamt och leder till att CPUn får göra jobbet, nVidia samt ATI stödjer inte formatet via drivare. Flertrådigheten är hemligheten.

En liten utvikning så hamnar man direkt i WIndows Vista och den här brännheta artikeln.
http://www.cs.auckland.ac.nz/~pgut001/pubs/vista_cost.html

Klart osäkert hur nVidia o ATI gör med ett ev stöd... industrin enades ju också om Blu-Ray och
bakom kulisserna så pågår det nog mycket.... tex nVidia o MS har nog inte så trevlig business med varandra. Sen MPAA o industrin är en annan historia....

Jag tycker patchen ser intressant ut....:) ska bara besöka "tankbaren" efter labalster

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Registrerad
Aug 2002

Det är så linux är.

Kass ljud och bild jämfört när man spelar upp ljudfiler och filmer i windows

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Sheytan
Det är så linux är.

Kass ljud och bild jämfört när man spelar upp ljudfiler och filmer i windows

Det var skummt för mig var det tvärtom, samma ljud men bättre bild kvalla i filmer, och snabbare uppspelning av HD filmer, kunde knappt titta på dem alls i windows. Men då har jag ett äldre grafik kort oxå.

Manjaro 17 <3, Windows 10pro (för spel). Asus Strix Z270H GAMING// Intel i7 7700k@4700Mhz// MSI GTX 1070 Gaming X 8G// Corsair VENGEANCE LPX 16GB.