conky problem i openbox + lite till

Trädvy Permalänk
Medlem
Plats
sundsvall
Registrerad
Dec 2007

conky problem i openbox + lite till

när jag statar conky så startas den i ett eget fönster inte i bakgrunden :S och conky's hemsida verkar vara nere just nu .S några tips??

+ kan man fixa så att det går att köra komandon utan att öppna en terminal tror det fungerade i fluxbox

2800+ amd64 512mb ram Debian stable
macbook 2ghz 1 gb ram arch linux

Trädvy Permalänk
Medlem
Plats
Söderhamn
Registrerad
Feb 2003

Skriv in detta i din .conkyrc:

own_window no

Vill du ha det i autostart eller vill du ha en "starterapp"?

Citera.mig.för.svar.][resaomkring.blogspot.com][ Intel I5 2.66GHz.4GB DDR3.ATI HD4670][ @Twitter
'We would like to see most of the human race killed off because it is unworthy, it is unworthy of the gift of life' - Behemoth - Antichristian Phenomenon.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Nov 2004

Det är väl bara att ta binären `fbrun` från fluxbox (eller skriva ett par rader tcl/tk) och fixa en tangentbordsbindning.

(

#!/usr/bin/wish proc callback {} { eval exec [.cmdbox get] & destroy . } entry .cmdbox -fg "#909090" -bg "#000000" -font "fixed" -bd 0 wm minsize . 300 14 wm maxsize . 300 14 wm resizable . 0 0 place .cmdbox -x 0 -y 0 -height 14 -width 300 focus .cmdbox bind .cmdbox <Return> {callback}

)

Trädvy Permalänk
Medlem
Plats
~
Registrerad
Apr 2003

Jag använder gmrun och sen en keybinding och application setting i openbox rc.xml för att starta och ge fokus till programmet.

<keybind key="A-e"> <action name="Execute"> <command>"gmrun"</command> </action> </keybind>

<application name="gmrun"> <focus>yes</focus> </application>