Trädvy Permalänk
Medlem
Plats
i min källare
Registrerad
Mar 2005

pdflush gör att det hackar

Som topic lyder Processen : pdflush

gör att varje gång den går upp i 0.7 % cpu så hackar mina spel servrar regält, har fösökt att ta bort det men det går inte. Har lyckats ta bort det flera ggr,men det kommer tillbaka och varje gång det händer så hackar spel servern till rätt fint.

Kernel som körs är 2.6.21.1

har ni något tips?

//mvh

Jag är bäst på det som jag är bra på.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Feb 2006

Du kan inte ta bort pdflush, då den behövs för att skriva ut data till diskarna.

Däremot ska det såklart inte hacka till när den går igång. Misstänker att DMA och/eller interrupts blivit avstängda av någon anledning. Kan vara dålig IDE-controller, dålig IDE-kabel eller någon form av inkompatibilitet. Vad är det för hårdvara du har?

Dator: i7-6700K, Asus Z170 PRO gaming, Noctua NH-D15, 32GB DDR4-3000, Asus 1080ti Strix gaming OC, Seasonic Platinum 1000W, Define XL R2, Intel 750 400GB PCIE Nvme SSD, Dell U2711

Trädvy Permalänk
Medlem
Plats
i min källare
Registrerad
Mar 2005

amd athlon xp 2000 + 2 gb ram.

Detta funka innan jag bytte från orginal kernel, kan det vara så att jag ska testa en annan kernel?

Jag är bäst på det som jag är bra på.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007

Är det en PATA-disk som du kör som systemdisk? Testa i så fall att köra "hdparm -d /dev/hårddisk", där hårddisk givetvis ska bytas ut mot rätt enhet. Då kan du se om DMA är påslaget eller inte.

Trädvy Permalänk
Medlem
Plats
i min källare
Registrerad
Mar 2005

/dev/hda1 heter min, och ja det är PATA / IDE disk.

root@darkstar:~# hdparm -d /dev/hda1

/dev/hda1:
using_dma = 0 (off)

hur sätter jag på detta ?

efter lite efter forskning kom detta fram:

root@darkstar:~# hdparm -d1 /dev/hda1

/dev/hda1:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Invalid argument
using_dma = 0 (off)

Jag är bäst på det som jag är bra på.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2003

vad säger dmesg . kanske står något fel där i

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007

Ok, då har du i alla fall hittat felet, dvs. att DMA är avslaget. Tydligen så fungerar det inte riktigt som det ska med IDE-controllern. Du säger att du har bytt kärna. Till vad, och varför? Förmodligen så har den nya kärnan av någon anledning inte längre stöd för din IDE-controller. Kör en lspci och se om du kan se vad din controller heter, och kör också dmesg och kolla om något fel rapporteras i den loggen.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2003

och hur skapade du den nya kärnan ? manuellt? automagiskt via något script?

Trädvy Permalänk
Medlem
Plats
i min källare
Registrerad
Mar 2005

Manuelt : har gjort så i flera års tid.

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 10)
00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 20)
00:0a.0 Ethernet controller: Accton Technology Corporation EN-1216 Ethernet Adapter (rev 11)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)

VP_IDE: IDE controller at PCI slot 0000:00:07.1
VP_IDE: chipset revision 16
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c686a (rev 22) IDE UDMA66 controller on pci0000:00:07.1
VP_IDE: port 0x01f0 already claimed by ide0
VP_IDE: port 0x0170 already claimed by ide1
VP_IDE: neither IDE port enabled (BIOS)

Probing IDE interface ide0...
hda: ST340823A, ATA DISK drive

hda: max request size: 128KiB
hda: 78165360 sectors (40020 MB) w/1024KiB Cache, CHS=65535/16/63
hda: cache flushes not supported

Måste vara något som glömts i kerneln.

Jag är bäst på det som jag är bra på.