FTP-server - inte bara lokalt!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2006

FTP-server - inte bara lokalt!

Håller på och försöker få min FTP-server att fungera (pure-ftpd) men vet inte hur jag ska göra för att den inte bara ska acceptera lokala anslutningar. Någon som kan hjälpa mig med vad jag behöver göra eller kanske istället ge mig förslag på något enklare program?

Failure is not an option. It comes bundled with your windows installation.
AMD Phenom2 X4 965 | Gigabyte GA-MA790FXT-UD5P | 4GB Corsair XMS3-12800DHX | XFX HD5870 | Asus XONAR D2 | 80GB Intel X25-M | 1TB Western Digital Caviar Green

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Mar 2005

Hej! Är också rätt ny i linux-världen, men har själv lyckats dra igång en ftp-server med hjälp av en guide. Använder vsftpd och Ubuntu Server.

Här är guiden:
http://ubuntu-se.org/phpBB3/viewtopic.php?f=54&t=25817

Här är en annan guide (scrolla ner en bit):
http://sandnabba.se/http_ftp_ssl

Om du vill göra som mig, att alla har "en stor gemensam" mapp så ändra bara till följande i conf-filen:
# user_sub_token=$USER
# local_root=/var/ftp/$USER
local_root=/var/ftp

Sedan har jag installerat "fail2ban" som hindrar brute-force attacker, kan också vara att rekommendera.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jan 2006

Hej!

Annars är "proftpd" ett annat väldigt populärt program till Linux. Kör själv det på en GNU/Debian-maskin, och funkar hur bra som helst. Har t.o.m lyckats få TLS-support.

Finns många guider, sök på nätet så hittar du.

Gigabyte-P35-DS4 | Intel Core 2 Quad Q6600 [3 GHz] | 2x1GB Corsair XMS-6400@800Mhz | Nvidia Geforce 460 GTX [975/2000 MHz] | Intel 320 Series 80 GB SSD | | SETI@Home Team: Sweclockers.com

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2005

Jag kör proftpd på min server och är väldigt nöjd, bortsett från att jag nog har gjort mitt upplägg över utdelning lite dumt men ska nog lösa sig. Jag har TSL aktiverat oxå för SSlkryptering vilket fungerar perfa!

När, iaf jag, installerade proftpd på ubuntu server 7.10 fanns TSLconf med under proftpd.conf men i ubuntu 8.04 fick TSL en egen conffil, jag lade dock till TSL i proftpd.conf som det var i 7.10 vilket fungerade lika bra.

Mitt tips, installera proftpd, openssl. Använd orginalconf och lägg till saker som behövs i den. Jag mixade lite guider när jag fixade min ftp vilka är som följer.

Jag skapade användare till ftp'n enligt denna guid och jag använde även utdelningen av mappar från denna conf vilka jag helt enkelt bara klistrade in i slutet på proftpd.conf och gjorde om dem efter mina krav.
http://ubuntuforums.org/showthread.php?t=79588

För att få TSL aktiverat följde jag denna guid: http://howtoforge.com/proftpd-tls-debian-etch

Som tidigare nämt finns inte TSL sektionen med i proftpd.conf när man apt-getar senaste proftpd i ubuntu 8.04 men klistra bara in <IfModule mod_tls.c> på lämpligt ställe i proftpd.conf så fungerar det lika bra.

Håll till godo, hoppas det fungerar vad du nu än väljer!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2006

Nu har jag gått över till proftpd och konfigurerat med gproftpd. Fungerar utmärkt att ansluta nu! Tack så mycket för all hjälp. Nu har jag bara ett problem kvar att lösa. Jag vill dela en mapp på min nätverksdisk men det verkar som det inte går att tilldela användarmappar som börjar på "smb://". Vad göra?

Failure is not an option. It comes bundled with your windows installation.
AMD Phenom2 X4 965 | Gigabyte GA-MA790FXT-UD5P | 4GB Corsair XMS3-12800DHX | XFX HD5870 | Asus XONAR D2 | 80GB Intel X25-M | 1TB Western Digital Caviar Green

Trädvy Permalänk
Medlem
Plats
/home
Registrerad
Dec 2004

Montera i filsystemet istället med smbfs/cifs, som du sedan kan dela ut med ftp.

Exempel:
mount -t smbfs -o username=[användarnamn] //[dator]/[mapp] /[monteringspunkt]