Trädvy Permalänk
Medlem
Plats
Vid datorn
Registrerad
Aug 2006

Problem med nVidia drivers

Jag installerade linux och kör dual boot med det och vista men när jag
ska installera drivrutinerna till mitt grafikkort i linux så har jag svårt att få
det att funka.
Jag laddar hem drivrutinerna från
nvidias hemsida och får då en .run fil på hårddisken.
När jag sedan öppnar den i terminalen med "sudo sh NVIDIA-Linux-x86-173.08-pkg1.run" så börjar den öppnas men det står att jag måste avsluta x servern. Jag testar då att skriva in samma sak när jag tryckt ctrl+alt+F1 men då händer ingeting.
Jag testar också att skriva "sudo /etc/init.d/kdm stop" innan men då så kommer till någon skärm då jag kan skriva vad som helst men får inte något svar från datorn på det jag skriver... Har googlat lite på det och hittat några guider till hur man installerar drivrutinerna men har inte riktigt fått någon av dom att funka.

Fakta om datorn

Grafikkort: nVidia 9600gt
Linux version: KDE "kubuntu" v.8.04
Drivrutins version: 173.08 (som jag har men inte kan installera

In the end what separates a man from a slave?
Money? Power? No... A man chooses, a slave obeys.
ASUS Z170M-PLUS || Intel Core i7 6700k @ 4,7GHz || 64GB 2133MHz Corsair RAM || EVGA NVIDIA GTX 1080 8GB @ 2,0Ghz || Bifenix Prodigy M || 2x CZ TR150 480GB RAID 0 || EK-CoolStream PE 120 & 240, Radiatorer || EK-DDC 3.2 PWM, Pump || EK-Supremacy MX & EK-FC1080 GTX, Vattenblock || 3x BenQ 24", Skärmar

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

Installera via envy eller ubuntus egna istället. Mycket enklare

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2006

"sudo /etc/init.d/kdm stop" är helt rätt kommando. Men, för att göra det måste du trycka ctrl+alt+f1 först. Du kommer då till en terminal utanför X-servern. Sen får du navigera till filen och köra den där. När du är klar, sudo /etc/init.d/kdm start.

Edit: Kanske förklarar lite konstigt, men precis så gjorde jag iaf och det funkar prima

Trädvy Permalänk
Medlem
Plats
Vid datorn
Registrerad
Aug 2006
Citat:

Ursprungligen inskrivet av KlavKalashj
"sudo /etc/init.d/kdm stop" är helt rätt kommando. Men, för att göra det måste du trycka ctrl+alt+f1 först. Du kommer då till en terminal utanför X-servern. Sen får du navigera till filen och köra den där. När du är klar, sudo /etc/init.d/kdm start.

Edit: Kanske förklarar lite konstigt, men precis så gjorde jag iaf och det funkar prima

Det är det jag har gjort men när jag gör det så kommer jag till en skärm som ser ut som samma som är efter ctrl+alt+F1 men vad jag än skriver så svarar inte datorn. Slutar med att jag får starta om den :/...

edit: jag har lyckats installera drivrutinerna nu men nar jag startar dator sa lyckas den inte starta och jag far starta den i recovery mode och ater stalla datorn. (rakade andra till engelskt tangentbord)... skriv om ni har nagra forslag till att fixa x config installningarna

In the end what separates a man from a slave?
Money? Power? No... A man chooses, a slave obeys.
ASUS Z170M-PLUS || Intel Core i7 6700k @ 4,7GHz || 64GB 2133MHz Corsair RAM || EVGA NVIDIA GTX 1080 8GB @ 2,0Ghz || Bifenix Prodigy M || 2x CZ TR150 480GB RAID 0 || EK-CoolStream PE 120 & 240, Radiatorer || EK-DDC 3.2 PWM, Pump || EK-Supremacy MX & EK-FC1080 GTX, Vattenblock || 3x BenQ 24", Skärmar

Trädvy Permalänk
Medlem
Plats
Europe
Registrerad
Aug 2004

Jag hade problem att få till drivrutinerna till mitt 8800GTS i Ubuntu 8.04.

Jag provade att installera från synaptic manager samt"hardware drivers" där ubuntu känner av ens grafikkort.
Dessa två gav inte bra resultat för mig.

Tillslut kom jag fram till ett sätt som fungerar perfekt för mig.
En fräsch nyinstallation utav ubutu, installerad updateringarna som man får direkt. (Har säkert inget med grafiken att göra dock)

Nvidia krävde libc6-dev så in i synaptic manager/Terminalen och hämta den.

Sedan CTRL+ALT+F1
Logga in som root (sudo -s) <-Vet ej om dett egentligen är nödvändigt men jag gjorde så.
sudo /etc/init.d/gdm stop (sudo killall gdm) kanske också fungerar.
sh NVIDIA-Linux-x86-173.08-pkg1.run (i mitt fall)
-följer anvisningarna-
sudo /etc/init.d/gdm start (sudo gdm start) kanske också fungerar.

Exakt dom stegen gjorde jag, i "hardware drivers" får jag INTE aktivera mitt kort för då brakar grafiken ihop om jag startar om datorn.
Och inga xorg.conf edterings-kommandon eller andra ändringar som gäller grafiken innan nvidia installationen.
Sedan bara in i nvidias settings och ordna (gksudo nvidia-settings)

Intel Core i5 6600K @3600MHz, 8GB RAM, ATI 7850, Corsair 250GB SSD systemdisk, Corsair 500w

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2006
Citat:

Ursprungligen inskrivet av lollol7
Det är det jag har gjort men när jag gör det så kommer jag till en skärm som ser ut som samma som är efter ctrl+alt+F1 men vad jag än skriver så svarar inte datorn. Slutar med att jag får starta om den :/...

edit: jag har lyckats installera drivrutinerna nu men nar jag startar dator sa lyckas den inte starta och jag far starta den i recovery mode och ater stalla datorn. (rakade andra till engelskt tangentbord)... skriv om ni har nagra forslag till att fixa x config installningarna

Installationsprogrammet har en funktion för att uppdatera xorg.conf, om du inte körde den så är det inte så konstigt att det pajjar. Prova den.

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

nVidias binär slängs ut av kärnan om man inte gör rätt.

Nu blir det ibland rätt ändå om man redan har en drivare installerad via Ubuntus
drivarhantering eller Envy.

För ett 9600 kort måste man då pillra manuellt !

"Pillringen" beskrivs så här av nVidia (en bit ner)

http://www.nvnews.net/vbulletin/showthread.php?t=72490

Blir ungefär så här rent praktiskt:

---------------------------------------------------------------------------------

sudo gedit /etc/default/linux-restricted-modules-common (eller sudo nano ....utan X )

DISABLED_MODULES="nv nvidia_new"

sudo apt-get install linux-headers-`uname -r` build-essential gcc gcc-4.2 xserver-xorg-dev

sudo apt-get --purge remove nvidia-glx nvidia-glx-new nvidia-settings nvidia-kernel-common

sudo rm /etc/init.d/nvidia-*

sudo rm /lib/linux-restricted-modules/.nvidia_new_installed

Logout > Ctrl-Alt-F1 and switch to a ttyand login

sudo /etc/init.d/kdm stop (eller gdm för gnome)

sudo sh NVIDIA-Linux-x86-173.08-pkg1.run

Ctrl-Alt-Del for PC restart

---------------------------------------------------------------------------------------

Det brukar räcka med "Disabled Modules" sen stöts inte drivaren bort

Enligt Phoronix så kommer drivaren att ges ut nästa vecka.

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Plats
Vid datorn
Registrerad
Aug 2006

Lyckades efter 6 timmars grejsande få det att funka. Hittade en ganska bra instruktion på http://ubuntuforums.org/showpost.php?p=4707754&postcount=16 . Vet inte riktigt vad jag gjorde men tillslut funkade det

In the end what separates a man from a slave?
Money? Power? No... A man chooses, a slave obeys.
ASUS Z170M-PLUS || Intel Core i7 6700k @ 4,7GHz || 64GB 2133MHz Corsair RAM || EVGA NVIDIA GTX 1080 8GB @ 2,0Ghz || Bifenix Prodigy M || 2x CZ TR150 480GB RAID 0 || EK-CoolStream PE 120 & 240, Radiatorer || EK-DDC 3.2 PWM, Pump || EK-Supremacy MX & EK-FC1080 GTX, Vattenblock || 3x BenQ 24", Skärmar

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jul 2001

Envy gör det mycket enklare, tar c:a 5 min som längst.

Manjaro 17 <3, Windows 10pro (för spel). Asus Strix Z270H GAMING// Intel i7 7700k@4700Mhz// MSI GTX 1070 Gaming X 8G// Corsair VENGEANCE LPX 16GB.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

Problemet är att 9600GT inte finns med i nvidias officiella drivrutiner så man får lägga in betadrivrutin från nvidia istället och då tror jag inte det funkar med envy och liknande.

Jag fick alltså göra detta manuellt:
http://ubuntu-se.org/phpBB3/viewtopic.php?f=186&t=26977

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Jo man kan ju bemöda sig at klicka på nVidia länken och läsa.

Sen hoppar man upp ett hack i hierarkin så har man då allting i nVidias officiella forum
inkl att det är nVidias personal som supportar...

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

KLICK....

Mitt sätt är "tragglat" i Hardys utvecklingsforum och det andra postade sättet är ju exakt samma princip.

Sen finns ju metoden även hos Ubuntu-se men de vägrar ju skapa någon form av ordning
för klistrade trådar. Andra värden som är viktigare än fungerande Ubuntu...

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Registrerad
Sep 2004

Envy Envy Envy

Varför är det egentligen så krångligt att installera Nvidia drivare på Ubuntu? Ingen annan dist jag har använt har behövt ett program(Envy) för att installera Nvidia drivare, utan där har det bara varit att:
Ladda ner drivisen.
Stäng av X.
Kör .run filen och följ instruktionerna.
Låt Nvidia konfa xorg.conf.
Starta X igen.
Klart!

...!?

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt

Trädvy Permalänk
Avstängd
Plats
Norrköping
Registrerad
Okt 2005
Citat:

Ursprungligen inskrivet av synt4x
Envy Envy Envy

Varför är det egentligen så krångligt att installera Nvidia drivare på Ubuntu? Ingen annan dist jag har använt har behövt ett program(Envy) för att installera Nvidia drivare, utan där har det bara varit att:
Ladda ner drivisen.
Stäng av X.
Kör .run filen och följ instruktionerna.
Låt Nvidia konfa xorg.conf.
Starta X igen.
Klart!

...!?

Låter lika enkelt som o installera drivarna i windows.

Satt själv o pillade med Ubuntu igår kväll... men det slutade efter ett par timmar med att hela skiten hakade sig. Testade först att installera genom Ubuntus egna "manager" (eller va sjuttan det heter). Men efter omstarten så var allt SIRAP. Testade att installera om och sen installera via terminalen... men det var hopplöst att få till kommandona rätt (varför kan man inte "copy+paste"? xD).

Intel Core i7 3770K@3.5, ASUS P8Z77V-DELUXE, 16GB RAM, GeForce GTX 660 Ti, ASUS XONAR ESSENCE STX, SAMSUNG 830 256GB SSD, 5x Samsung HD204UI, 4x WD40EFRX, 1x Western Digital Caviar Green WD20EARX, 1x Samsung HD103UJ, Windows 8.1 Pro

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Citat:

Ursprungligen inskrivet av synt4x
Envy Envy Envy

Varför är det egentligen så krångligt att installera Nvidia drivare på Ubuntu? Ingen annan dist jag har använt har behövt ett program(Envy) för att installera Nvidia drivare, utan där har det bara varit att:
Ladda ner drivisen.
Stäng av X.
Kör .run filen och följ instruktionerna.
Låt Nvidia konfa xorg.conf.
Starta X igen.
Klart!

...!?

Så kan man även göra i ubuntu om man vill.
Själv var jag tvungen till det eftersom inget annat sätt funkade.
Är man ovan med att göra saker via kommandoprompten (särskilt när X är avstängt och man inte kan kopiera och klistra in) så känns detta svårt när man aldrig gjort detta förut.

Trädvy Permalänk
Medlem
Registrerad
Sep 2004

Visst, det ska gå att göra så, men ofta fungerar det inte ändå. Ofta står det då att X servern och klienten inte är samma version. Jag har lyckats göra det en gång, men det var länge sen. Typ Ubuntu 5.10

Men men, tur att Envy finns iaf. Det fyller verkligen sitt syfte.

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt

Trädvy Permalänk
Medlem
Plats
sverige
Registrerad
Mar 2008

Har fått mitt nvidia att fungera men det flyter inte bra alls. Det hackar och laggar, skärmsläckaren buggar osv.
Har ett intigrerat nVIDIA Quadro NVS 210S graphic kort och kör dual screens. En DVI till ett extension kort samt VGA till det intigrerade.

Körde en ren ubuntu 7.10 installation och update manager till 8.04 med nvidia-glx drivern.
Körde nvidia-settings och fixade till dual och sparade till xorg.conf.

xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings # nvidia-settings: version 1.0 (buildd@vernadsky) Thu Jun 5 09:26:53 UTC 2008 # xorg.conf (xorg X Window System server configuration file) # # This file was generated by dexconf, the Debian X Configuration tool, using # values from the debconf database. # # Edit this file with caution, and see the xorg.conf manual page. # (Type "man xorg.conf" at the shell prompt.) # # This file is automatically updated on xserver-xorg package upgrades *only* # if it has not been modified since the last upgrade of the xserver-xorg # package. # # If you have edited this file but would like it to be automatically updated # again, run the following command: # sudo dpkg-reconfigure -phigh xserver-xorg Section "ServerLayout" # Uncomment if you have a wacom tablet # InputDevice "stylus" "SendCoreEvents" # InputDevice "cursor" "SendCoreEvents" # InputDevice "eraser" "SendCoreEvents" Identifier "Default Layout" Screen 0 "Screen0" 0 0 Screen 1 "Screen1" RightOf "Screen0" InputDevice "Generic Keyboard" InputDevice "Configured Mouse" EndSection Section "Files" EndSection Section "Module" Load "glx" EndSection Section "ServerFlags" # Removed Option "Xinerama" "0" Option "Xinerama" "1" EndSection Section "InputDevice" Identifier "Generic Keyboard" Driver "kbd" Option "CoreKeyboard" Option "XkbRules" "xorg" Option "XkbModel" "pc105" Option "XkbLayout" "se" EndSection Section "InputDevice" Identifier "Configured Mouse" Driver "mouse" Option "CorePointer" Option "Device" "/dev/input/mice" Option "Protocol" "ImPS/2" Option "ZAxisMapping" "4 5" Option "Emulate3Buttons" "true" EndSection Section "InputDevice" Identifier "stylus" Driver "wacom" Option "Device" "/dev/input/wacom" Option "Type" "stylus" Option "ForceDevice" "ISDV4"# Tablet PC ONLY EndSection Section "InputDevice" Identifier "eraser" Driver "wacom" Option "Device" "/dev/input/wacom" Option "Type" "eraser" Option "ForceDevice" "ISDV4"# Tablet PC ONLY EndSection Section "InputDevice" Identifier "cursor" Driver "wacom" Option "Device" "/dev/input/wacom" Option "Type" "cursor" Option "ForceDevice" "ISDV4"# Tablet PC ONLY EndSection Section "Monitor" Identifier "DELL 2007FP" Option "DPMS" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "DELL 2007FP" HorizSync 30.0 - 83.0 VertRefresh 56.0 - 76.0 EndSection Section "Monitor" Identifier "Monitor1" VendorName "Unknown" ModelName "DELL 2007FP" HorizSync 30.0 - 83.0 VertRefresh 56.0 - 76.0 EndSection Section "Device" Identifier "Generic Video Card" Driver "nvidia" Option "NoLogo" "True" BusID "PCI:0:5:0" EndSection Section "Device" Identifier "Videocard0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce 6150 LE" BusID "PCI:0:5:0" Screen 0 EndSection Section "Device" Identifier "Videocard1" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce 6150 LE" BusID "PCI:0:5:0" Screen 1 EndSection Section "Screen" Identifier "Default Screen" Device "Generic Video Card" Monitor "DELL 2007FP" DefaultDepth 24 SubSection "Display" Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480" EndSubSection EndSection Section "Screen" # Removed Option "metamodes" "CRT: 1600x1200 +0+0; CRT: 1280x1024 +0+0; CRT: 1152x864 +0+0; CRT: 1024x768 +0+0; CRT: 800x600 +0+0; CRT: 640x480 +0+0" Identifier "Screen0" Device "Videocard0" Monitor "Monitor0" DefaultDepth 24 Option "TwinView" "0" Option "TwinViewXineramaInfoOrder" "CRT-0" Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0; CRT: 1152x864 +0+0; CRT: 1024x768 +0+0; CRT: 800x600 +0+0; CRT: 640x480 +0+0" EndSection Section "Screen" Identifier "Screen1" Device "Videocard1" Monitor "Monitor1" DefaultDepth 24 Option "TwinView" "0" Option "metamodes" "DFP: nvidia-auto-select +0+0" EndSection

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jul 2001

Har alldrig behövt krångla, Envy finns i Ubuntus repository av en anledning, tanka/installera. Sen klicka på 2 knappar i envy så är det färdigt sen alldrig mer nå progblem med drivrutiner.

Manjaro 17 <3, Windows 10pro (för spel). Asus Strix Z270H GAMING// Intel i7 7700k@4700Mhz// MSI GTX 1070 Gaming X 8G// Corsair VENGEANCE LPX 16GB.