Bästa Linux för webbserver

Trädvy Permalänk
Medlem
Plats
Nossebro
Registrerad
Dec 2005

Bästa Linux för webbserver

Jag ska lägga över en sida som använder sig av Apache, PHP och Mysql till en Linuxburk.

På burken vill jag då alltså ha MySQL, PHP, Apache samt en Mailserver installerad.

Vilken Linuxvariant passar bäst till mitt ändåmål? Samt, en guide för installation av de programmen skulle uppskattas mycket.

Tack

Trädvy Permalänk
Medlem
Registrerad
Jan 2002

Använd vilken Linuxdistribution du vill, alla klarar det du vill göra. Guider hittar du enkelt via Google.

Trädvy Permalänk
Medlem
Plats
local
Registrerad
Feb 2004

Debian är hyffsat nybörjarvänlig.

Ptja en guide för att installera allt:

[su]
apt-get install mysql-common apache2 php5 php5-mysql exim4

sen kan du slänga med phpmyadmin (apt-get install phpmyadmin) som brukar vara trevligt om man vill ha ett webgui till databasen.

klart.

Vill du ha lite trevliga howtos så rekommenderar jag starkt www.howtoforge.com

Trädvy Permalänk
Medlem
Plats
Nossebro
Registrerad
Dec 2005

Problemet när jag installerar apache2 är att jag kan inte ändra directoryindex. PHP fungerar men jag kan inte ställa in så att min förstafil ska heta index.php. httpd.conf är tom i apache mappen.

Har googlat lite, och folk säger på några ställen att man kan ändra i .htaccess, och det är en fil som jag inte hittar. Har inte riktigt förstått mig på sök kommandona i Debian.

Trädvy Permalänk
Medlem
Registrerad
Jan 2002

Vilken distribution lägger in en tom httpd.conf?

Vanligtvis lägger man directoryindex i httpd.conf.

Kolla också om filen php.conf finns i conf.d, i denna kan directoryindex också finnas. Då ska du inte behöva göra något.

Trädvy Permalänk
Medlem
Plats
Nossebro
Registrerad
Dec 2005

Jag vet faktiskt inte, jag har installerat alla paket som sunnis skrev. Det finns massa konfiguration i fil som heter apache2.conf, men inget om DirectoryIndex, jag har försökt lägga till det, både i apache2.conf och httpd.conf, men inget tycks fungera. *Frustrerad*

i conf.d ligger endast en fil som heter charset.

Trädvy Permalänk
Medlem
Registrerad
Jan 2002
Citat:

Ursprungligen inskrivet av Hoshibo
Jag vet faktiskt inte, jag har installerat alla paket som sunnis skrev. Det finns massa konfiguration i fil som heter apache2.conf, men inget om DirectoryIndex, jag har försökt lägga till det, både i apache2.conf och httpd.conf, men inget tycks fungera. *Frustrerad*

Jag kör inte Debian själv så jag kan inte svara på det. I Fedora läggs en färdig httpd.conf in vid installationen.

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Jun 2005
Citat:

Ursprungligen inskrivet av denka
Vilken distribution lägger in en tom httpd.conf?

En som har tänkt ett steg längre?

Debian använder ett modulärt system för att konfigurera moduler, hosts och annat. Läs mer i /usr/share/doc/apache2.<minor>-common/README.Debian.gz

Trädvy Permalänk
Medlem
Registrerad
Jan 2002
Citat:

Ursprungligen inskrivet av NakedApe
Läs mer i /usr/share/doc/apache2.<minor>-common/README.Debian.gz

Lite svårt då jag inte använder Debian, men tack för informationen.

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Jun 2005
Citat:

Ursprungligen inskrivet av denka
Lite svårt då jag inte använder Debian, men tack för informationen.

Det var inte riktat till dig utan till Hoshibo. Att jag valde att citera ditt inlägg var för att tydliggöra att det är avsiktligt som httpd.conf är tom i Debian.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Mar 2002

/etc/apache2/mods-enabled/dir.conf
/etc/apache2/apache2.conf

I de filerna hittar du det du har sökt.
För att aktivera php efter du installerat det så kör du

sudo a2enmod php5

Vad detta kommando egentligen gör är att skapa en symbolisk länk (man ln) från /etc/apache2/mods-available/php5.load till /etc/apache2/mods-enabled/php5.load och laddar sedan om apache (/etc/init.d/apache2 reload) Mer kan du läsa dig till genom att själv läsa i scriptet (nano /usr/sbin/a2enmod).
Samma modell gäller för virtualhosts fast under mappen /etc/apache2/sites-avaible/enabled osv.

01001000 01100001 01110010 00100000 01100100 01110101 00100000 01110100 01110010 10000110 01101011 01101001 01100111 01110100 00111111 00100000 00111010 00101001

Trädvy Permalänk
Medlem
Plats
Nossebro
Registrerad
Dec 2005
Citat:

Ursprungligen inskrivet av twan
/etc/apache2/mods-enabled/dir.conf
/etc/apache2/apache2.conf

I de filerna hittar du det du har sökt.
För att aktivera php efter du installerat det så kör du

sudo a2enmod php5

Vad detta kommando egentligen gör är att skapa en symbolisk länk (man ln) från /etc/apache2/mods-available/php5.load till /etc/apache2/mods-enabled/php5.load och laddar sedan om apache (/etc/init.d/apache2 reload) Mer kan du läsa dig till genom att själv läsa i scriptet (nano /usr/sbin/a2enmod).
Samma modell gäller för virtualhosts fast under mappen /etc/apache2/sites-avaible/enabled osv.

Problemet är inte att få igång PHP. PHP fungerar som det ska, det är DirectoryIndex som inte fungerar.

--------------------------------

Har kommit på en lösning nu.

I mappen /etc/apache2/sites-avalible finns filen default.

I filen hittade jag en rad som såg ut såhär:
RedirectMatch ^/$ /

Jag tog bort raden, och sen dess har det fungerat som det ska. Vet inte om det är rätt sätt att göra det på, men det tycks fungera i alla fall.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av Hoshibo
Har kommit på en lösning nu.

I mappen /etc/apache2/sites-avalible finns filen default.

I filen hittade jag en rad som såg ut såhär:
RedirectMatch ^/$ /

Jag tog bort raden, och sen dess har det fungerat som det ska. Vet inte om det är rätt sätt att göra det på, men det tycks fungera i alla fall.

Aha, uppfattade inte att det va det som va problemet.
Jo, så kan man göra för att slippa skickas vidare till den där standard "It Works!"-sidan.

01001000 01100001 01110010 00100000 01100100 01110101 00100000 01110100 01110010 10000110 01101011 01101001 01100111 01110100 00111111 00100000 00111010 00101001