problem att connecta till wpa2 med ubuntu

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

problem att connecta till wpa2 med ubuntu

Har efter mycket problem lyckats få igång mitt wlan på en hp som har ett broadcom nätverkskort. Problemet är nu att den kan koppla upp sig på nätverk utan lösenord samt vissa wep anslutningar, men inte till mitt egna nätverk med wpa2 psk. Vad kan detta bero på och hur kan jag lösa detta?

Trädvy Permalänk
Medlem
Plats
Hemma
Registrerad
Jun 2008

Jag har samma problem, dock ingen lösning

Acer Aspire 1360

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

Ok så det är inte min okunnighet, tänkte nämligen att jag gjort något fel vid installationen. Skulle vara uppskattat om någon visste hur man löste det här.

Trädvy Permalänk
Medlem
Plats
Hemma
Registrerad
Jun 2008

Hur installerade du wlanet då? Via Ndiswrapper?

Acer Aspire 1360

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

Nej, jag prövade via ndiswrapper först, men det fungerande inte, sen tryckte jag på hardware knappen och där fanns det redan en drivrutin som jag bara kryssade i rutan på, sen fungerade det, eller ja, fungerade så att jag kan ansluta mig till nätverk utan lösenord iaf. Kör 8.04.1.

Trädvy Permalänk
Medlem
Plats
at home
Registrerad
Nov 2007

Rekommenderar den här tråden som man kör klistrad hos U-F

http://ubuntuforums.org/showthread.php?t=684495

Via terminalen ser man vad som händer.

Sen testas just nu NM 0.7 som är ett stort lyft.

EDIT

Plus den här.... Broadcom superstrultråden

http://ubuntuforums.org/showthread.php?t=880218

ASUS K56CB i7, W10.
HTC 10 ICE InsertCoin SVN, Nougat
ASUS Transformer Prime 32GB, Nougat :)
Ubiquiti Edge Lite, UniFi AP-AC-Lite (AP) samt ASUSAC68U och N66U (AP), fiber 250/100Mbit/s.
Mitt nätverk: http://imgur.com/VYJjrzL Bild http://imgur.com/89WYq81

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

Nu har jag gått igenom bägge trådarna och även sökt förgäves på en hel del forum. Har provat en hel del lösningar, men inget verkar fungera.
Kanske värt att nämna att dom flesta lösningar är till 8.04 och inte 8.04.1. Drivrutinen för broadcom kort finns ju faktiskt i 8.04.1 och man behöver inte köra via ndiswrapper. Trots det kan jag bara ansluta till nätverk utan lösenord, varken wep eller wpa fungerar.
Jag har även provat wicd men där kunde jag inte koppla upp mig överhuvudtaget. Lite tråkigt, jag har faktiskt börjat gilla ubuntu, hade varit dumt om jag blev tvungen att ta bort det bara pga detta. Ingen som har samma problem som mig och lyckats lösa det?

Trädvy Permalänk
Medlem
Plats
/bin/bash
Registrerad
Mar 2002

Provat att använda wpa_supplicant?

Cisco - Linux - VMWare
-- Citera mig om ni vill få återkoppling --

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

Jag tänkte på det och försöka apt-get:a den. Det visade sig att den redan fanns i 8.04.1. Något mer än så vet jag inte, behöver jag göra några inställningar i den eller modifiera någon fil?

Trädvy Permalänk
Medlem
Registrerad
Jul 2001

jag har Broadcomm på min HP och där funkar det med WPA2 utan problem - kommer dock inte ihåg om jag var tvungen att installera osignerade drivers eller ej...Ubuntu funkar mycket bra iaf....

Har varit på detta forum på tok för länge...

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

Du kan inte ta reda på vilket tillvägagångssätt du använde dig av? Jag har slitit med det i dagar utan att lyckas.

Trädvy Permalänk
Medlem
Plats
Huddinge
Registrerad
Nov 2005

Jag använder Ultimate Edition av Ubuntu
http://ultimateedition.info/

Jag gick sedan in i Hardware Drivers och markerade drivrutinerna till mitt trådlösa kort.
Sedan följde jag guiden nedan för att få det trådlösa att fungera smärtfritt:
http://www.debianadmin.com/enable-wpa-wireless-access-point-i...

If you make it idiot proof, someone will find a better idiot.
----------------------------------------
Linux is like a Wigwam. No Gates, No Windows and an Apache inside.

Trädvy Permalänk
Medlem
Plats
/bin/bash
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av Bruticus
Jag tänkte på det och försöka apt-get:a den. Det visade sig att den redan fanns i 8.04.1. Något mer än så vet jag inte, behöver jag göra några inställningar i den eller modifiera någon fil?

Den är lite mer "tricky" än andra alternativ, men inte så mycket - bara lite.

Basicly så ligger dina SSID som du kan ansluta emot i en config fil /etc/wpa_supplicant.conf, och man använder wpa_passphrase för att lägga till SSID med passphrase i den filen mha "wpa_passphrase ssid passphrase >> /etc/wpa_supplicant.conf".

wpa_cli använder du för att se status på anslutningen, det är nödvändigt för att se så att allt går rätt till.

Börja med att lägga till ditt SSID med passphrase med samma kommando som jag skrev ovan, sedan editerar du /etc/wpa_supplicant.conf och kommenterar bort den delen som säger något i stil med "# This is great for hotels and airports where you dont auth...", du vill bara ha ditt SSID där så att den inte försöker ansluta mot vilket som helst (vilket den kommer göra om du lämnar kvar det jag just nämnde).

Sedan kör du följande:

wpa_supplicant -i<interface> -c/etc/wpa_supplicant.conf -WB ; wpa_cli

Det som händer är att du startar wpa_supplicant på ditt <interface> med configfilen och skickar den i bakgrunden och direkt efter startar wpa_cli. Skriv sedan status och tryck enter så ser du hur det går att autensiera, sedan är det bara att jobba dig därifrån. En viktig notering är att dom som gjorde wpa_supplicant inte har alla koppar i skåpet och tycker att man ska sätta ihop växlar OCH värdet så det ska stå -c/wpa_supplicant.conf utan mellanslag samma med interfacet.

lycka till.

Cisco - Linux - VMWare
-- Citera mig om ni vill få återkoppling --

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jun 2004

Jag har inget Broadcom-kort, men jag har inte kunnat ansluta till WPA2-nätverk förrän alldeles nyss. Tidigare så gick det bara att ansluta till öppna och WEP-skyddade nätverk, men nu har jag som sagt äntligen löst det.

Jag vet inte om det här fungerar för dig, men det jag gjorde var att avinstallera network-manager och installera Wicd istället. Med det så kunde jag ansluta till alla sorters nätverk utan problem (t.o.m. de som inte sänder ut SSID)! Mycket lätt att använda var det också.

Om du vill testa Wicd, så börja med att ladda ner network-manager (så du kan gå tillbaka till det om du vill). Du kan ladda ner network-manager här och network-manager-gnome här.

Efter du sparat båda två någonstans, så öppna terminalen och skriv (om du inte kör hardy, byt ut det mot det du kör):

Citat:

echo 'deb http://apt.wicd.net hardy extras' | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install wicd

Efter det så navigerade jag till /opt/wicd/ och körde python gui.py, vilket bör göra så att det grafiska gränssnittet dyker upp. Väl där så är det bara att välja vilket WLAN du vill ansluta till i listan, alternativt skriva in SSID om AP:n inte sänder ut det.

Jag hittade en tråd i Ubuntu-forumet (länk) som också beskriver det hela, fast jag följde någon blogg, men det är sak samma antar jag.

------------------------

Om du vill använda network-manager igen, så öppna terminalen och skriv:

Citat:

sudo apt-get remove wicd
sudo gdebi <plats där deb-filen ligger>/network-manager_0.6.6-0ubuntu5_i386.deb
sudo gdebi <plats där deb-filen ligger>/network-manager-gnome_0.6.6-0ubuntu3_i386.deb

Jag har bara använt Ubuntu i några dagar, så om något jag beskriver är fel så kan ni gurus ryta till.

Trädvy Permalänk
Medlem
Registrerad
Jan 2005

Tack allihop, jag prövade både romulus, deegans och tredoras tips (jag hade dock prövat wicd förut, men tänkte jag kunde ge det en chans till). Inget av dom fungerade. Med wicd får jag inte ens upp något lösenordsförfrågan, vilket jag åtminstone får med network-manager även om den inte kopplar upp sig.

Ni får gärna ge fler tips om någon kommer på något mer.

EDIT: Jag gav upp, jag bytte till mig mammas dell latitude d620. Där funkar allt out of the box, underbart. Nu har jag ett fungerande system! Tack för all hjälp iaf.