Fallout 3 random freezes

Trädvy Permalänk
Medlem
Plats
Märsta
Registrerad
Nov 2008

Fallout 3 random freezes

Jaha då köpte man Fallout 3, fast det var en hel del varningar om jobbiga buggar etc.

Och allt har gått bra tills man kommit ca 10 min in i spelet, då börjar jag få "random freezes", med det menar jag att spelet fryser i typ 5-10 sekunder vid helt oregelbundna tillfällen och ibland mer ofta än andra tillfällen.

Tydligen är detta ett vanligt problem som förekommer (har läst alla forum jag kunnat hitta för lösningar) men hittar inget som kan lösa mitt problem (har provat allt, t.o.m. att köpa mer RAM minne och ett nytt och bättre grafikkort)

Jag har provat saker som att uppdatera Directx, grafikkorts drivers, ljud drivers etc. och inget har hjälpt, jag klarar av att spela spelet med bästa grafik inställningarna, men har även prövat med sämsta inställningar för att se om problemet försvinner.

Men inget verkar fungera, så jag vore tacksam för tips och råd på hur man kan tänkas lösa problemet.

Trädvy Permalänk
Hjälpsam
Plats
Karlskoga
Registrerad
Jan 2007

Om du kör XP, bör du installera AMD Dual-Core Optimizer och AMD Processor Driver.
http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_...
Jag har också sett tips om att man skall stänga av AA helt.

AMD Ryzen 7 1700 | Vega RX 64 | https://valid.x86.fr/ufsz9j | Stockkylaren | Bitfenix Whisper M 750W | Corsair 600T Graphite vit.
AMD FX8350 | Polaris RX 460 4 GB | https://valid.x86.fr/0q5pkm | Cooler Master V 700W | 32 GB ECC-Minnen.
HTPC | https://valid.x86.fr/ez1zxw |

Trädvy Permalänk
Medlem
Plats
Märsta
Registrerad
Nov 2008
Citat:

Ursprungligen inskrivet av Ratatosk
Om du kör XP, bör du installera AMD Dual-Core Optimizer och AMD Processor Driver.
http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_...
Jag har också sett tips om att man skall stänga av AA helt.

Okej tack för tipset ska pröva det och se om det fungerar, med AA antar jag att du menar antialiasing.

Återkommer med ett svar om hur det gick

Okej jag installera dem som du sa, och det verkar som att det hjälpt lite, för nu kommer inte "frysningarna" lika ofta och de är kortare, men jag har inte kört utan AA än så prövar det också sen, så får jag se om de förhoppningsvis försvinner helt. I värsta fall så installerar jag Vista och prövar med det (eftersom det verkar som det har löst sig för en hel del personer med det)

Trädvy Permalänk
Gäst

EXAKT SAMMA PROBLEM!!
frågade de i forumet precis nyss, jag trodde det var min dator som var för dålig, men om du lyckas fixa problemet så får du gärna höra av dig, och jag kan höra av mig till dig.

Kan de inte vara buggar eller liknande? jag har laddat ner spelet iaf,

MVH

Trädvy Permalänk
Medlem
Plats
Märsta
Registrerad
Nov 2008
Citat:

Ursprungligen inskrivet av manuelp
EXAKT SAMMA PROBLEM!!
frågade de i forumet precis nyss, jag trodde det var min dator som var för dålig, men om du lyckas fixa problemet så får du gärna höra av dig, och jag kan höra av mig till dig.

Kan de inte vara buggar eller liknande? jag har laddat ner spelet iaf,

MVH

Ja alltså jag har kollat i princip varje forum som finns och prövat varje lösning, det där med att uppdatera drivrutinerna för processorer och annan hårdvara hjälpte lite men inte helt, har inte hunnit pröva att köra utan AA efter drivrutinsuppdatering eftersom jag är bortrest nu, men prövar så senare idag när jag kommer hem, och åk om hur de gick

Vad jag har hört dock är att vissa har löst problemet genom att installera Vista men har inte fungerat för alla så fungerar inte detta så får jag väl pröva det.

Trädvy Permalänk
Hjälpsam
Plats
Karlskoga
Registrerad
Jan 2007

För en del har det också hjälpt att slå på V-sync.

AMD Ryzen 7 1700 | Vega RX 64 | https://valid.x86.fr/ufsz9j | Stockkylaren | Bitfenix Whisper M 750W | Corsair 600T Graphite vit.
AMD FX8350 | Polaris RX 460 4 GB | https://valid.x86.fr/0q5pkm | Cooler Master V 700W | 32 GB ECC-Minnen.
HTPC | https://valid.x86.fr/ez1zxw |

Trädvy Permalänk
Medlem
Plats
Kiruna
Registrerad
Apr 2007

Hade ett liknande problem men spelet frös helt och hållet. Fick starta aktivitetshanteraren och stänga ner processen. Förstod inte vad problemet var så jag avinstallerade skiten.

Skaparna av Crysis är tre turkiska bröder.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jul 2001

Installera om XP först, fortsätter problemet så testa andra saker. Installera om tar nästan kortast tid och hjälper för det mesta.

Manjaro 17 <3, Windows 10pro (för spel). Asus Strix Z270H GAMING// Intel i7 7700k@4700Mhz// MSI GTX 1070 Gaming X 8G// Corsair VENGEANCE LPX 16GB.

Trädvy Permalänk
Medlem
Registrerad
Jun 2009

gammal tråd men kanske har en lösning om det är nån som behöver?

Trädvy Permalänk
Avstängd
Plats
Kolsva
Registrerad
Sep 2003
Citat:

Ursprungligen inskrivet av Umarrion
gammal tråd men kanske har en lösning om det är nån som behöver?

Den bästa lösningen finns på TPB, tyvärr.
Spelets "kopieringsskydd" ställer till det, tror jag.. men jag hade samma dynga med min köpta FO3, läste någonstans att "fixet" hjälpte, så jag ladda ner det och inga problem efter det.

Men inget mer om det från mig, §7

ATI TALIBAN.
Är inte någon expert, men jag har inte akne heller.
NEVER UNDERESTIMATE THE POWER OF STUPID PEOPLE IN LARGE GROUPS.. "Betala i förskott på blocket?" tråden.

Trädvy Permalänk
Medlem
Registrerad
Jun 2009

securom kan man gå förbi genom att starta .exe filen istälelt för launchern.

överklockat grafik kort/cpu testa original, gamebryo engine är väldigt känslig mot sånt.
stäng av vsync.

gå till c:dokument\my games\ fallout 3 öppna .ini filen leta upp
bUseThreadedAI=0
byt till bUseThreadedAI=1
på raden under lägg till
iNumHWThreads=2

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2005
Citat:

Ursprungligen inskrivet av Umarrion
(...)

gå till c:dokument\my games\ fallout 3 öppna .ini filen leta upp
bUseThreadedAI=0
byt till bUseThreadedAI=1
på raden under lägg till
iNumHWThreads=2

Vad innebär denna modifiering?

Golden oldies: ThinkPad 600, ThinkPad T400, ThinkPad T400s, Mac Pro 5.1, iMac 27", MacBook Air 13"
Arbetshäst: MacBook Pro Retina 15"

Trädvy Permalänk
Medlem
Registrerad
Jun 2009

ifall spelet crashar

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Aug 2002

Bumpar tråden lite med vad jag gjorde för att få markant mkt stabilare spel.

Jag lirade Fallout 3 med en Core2 Duo E6600 förut, och det var inga problem. Det som började spöka för mig var när jag nyligen uppgraderade till nya i7 860, och som ni säkert vet är det också en quad core, det som brukar spöka med fallout3.

Så, jag börja få dessa frysningar etc. precis som ni förklarar här.
Fixen med att editera .ini filen fungerade inte för mig, det vart värre vissa gånger tyckte jag.

Eftersom jag hade gjort backup på mina dokument med saved games etc. så låg ju .ini filen kvar från när jag hade dual core system. Det var den som spökade!

Så, det enda jag gjorde var att, under:
c:\documents and settings\username\my documents\my games\fallout 3\
så bytte jag bara namn på fallout3.ini till fallout3_backup.ini och sedan startade spelet.

Fallout skapade då en ny .ini fil efter mina nya settings etc.
Detta löste i stort sett allt för mig. Jag satt och spelade 3 timmar efter det utan att det crasha eller frös en enda gång.
Precis innan jag skulle avsluta spelet så frös det dock inne på "men's room" i Megaton.
Men! 3 timmar och en frysning istället för att det fryser efter varje 1-2 minuters spelande, det kallar jag ett rejält lyft!

Hoppas denna alternativa lösning fungerar för er som inte fått det fungera med .ini tweaket!

//LeaD

Stationär:[i7 4790K @ 4.6GHz. Intel vattenkylare] [Asus Z97-A] [16gig Corsair Dominator @ 2400Mhz] [Asus DirectCU II GTX 780] Laptop: [MSI GX660-266NE]