Inga spel funkar pga vista?

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007

Inga spel funkar pga vista?

Hej
jag har sökt runt lite men hittar inget liknande fall eller i alla fall inte exakt så som jag har de. Jag har precis gått över från xp till vista och efter det har inga spel funkat. jag kan installera spelen men när jag startar dom kan ja kanske få se intro filmer och liknande men när man ska kunna välja allt som singleplay multiplay osv blir det bara svart skärm. Man hör ljudet från spelet och hur man drar pekaren över alla alternativ vad kan detta bero på?

här är lite fakta om datorn och spel jag testat
cod 4
bioshock
diablo 2
Tft
sen pallade ja inte testa fler spel

Dator typ ACPI x64-based PC
Operativsystem Microsoft Windows Vista Ultimate
DirectX DirectX 10.1

Moderkort
CPU typ QuadCore Intel Core 2 Quad Q9450, 2666 MHz (8 x 333)
Moderkortsnamn Asus P5E Deluxe (2 PCI, 3 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)
Moderkortschipset Intel Beachwood X48
BIOS typ AMI (04/17/08)

Bildskärm
Grafikkort ATI Radeon HD 4800 Series (512 MB)
Grafikkort ATI Radeon HD 4800 Series (512 MB)
3D accelerator ATI Radeon HD 4870 (RV770)
Bildskärm Eizo Nanao FlexScan S2431W (Digital) [24" LCD]
Bildskärm Generic PnP Monitor [NoDB]
DMI BIOS version 0105
DMI Systemprodukt P5E Deluxe
DMI Systemversion System Version
DMI Moderkortsprodukt P5E Deluxe
DMI Moderkortsversion Rev 1.xx

Trädvy Permalänk
Hedersmedlem
Plats
127.0.0.1
Registrerad
Apr 2009

Testa att installera de senaste drivrutinerna till grafikkortet först.

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007

det har ja gjort

Trädvy Permalänk
Medlem
Plats
Dalsjöfors
Registrerad
Aug 2008

Har du uppgraderat från XP till Vista. Elr tog du bort XP och sen installerade Vista?

Intel i7 8700k|Noctua NH-D15|EVGA GTX 1080 FTW|Asus Maximus X Hero|16GB Corsair DDR4 3600MHz|Seasonic Prime Titanium 750W|Samsung SSD 960 PRO 512GB|Phantek Enthoo Primo||Acer XB270HU IPS 144Hz Gsync|BenQ XL2410T 120Hz|Logitech G903|Qpad MK-90|Sennheiser Game Zero Black|

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007

Den installerades typ separat på något skumt vis. tror vissa filer av xp finns kvar i en mapp eller något men det skulle inte störa stod de när ja installera.

Trädvy Permalänk
Medlem
Plats
Dalsjöfors
Registrerad
Aug 2008

Jag skulle Formatera Hårddisken och lägga in Vista elr Windows 7 Betan. Tror det skulle funka.

Intel i7 8700k|Noctua NH-D15|EVGA GTX 1080 FTW|Asus Maximus X Hero|16GB Corsair DDR4 3600MHz|Seasonic Prime Titanium 750W|Samsung SSD 960 PRO 512GB|Phantek Enthoo Primo||Acer XB270HU IPS 144Hz Gsync|BenQ XL2410T 120Hz|Logitech G903|Qpad MK-90|Sennheiser Game Zero Black|

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Feb 2009
Citat:

Ursprungligen inskrivet av eplet
Den installerades typ separat på något skumt vis. tror vissa filer av xp finns kvar i en mapp eller något men det skulle inte störa stod de när ja installera.

Sätt i Vista skivan, formatera om hårddisken och installera om Vista!
Efter det installerar du de senaste drivrutinerna, både till grafikkortet och moderkortet!
Vad har du för nätaggregat?

Trädvy Permalänk
Medlem
Plats
Eskilstuna
Registrerad
Mar 2003

prova och lägg in Dx 9

MSI 990fxa-gd80 ,16 GB ram, AMD FX 8350, MSI GTX 1070 ,Creative X-fi Fatality edit , Fractal R5

Trädvy Permalänk
Avstängd
Plats
Kolsva
Registrerad
Sep 2003

Prova med en annan profil.

ATI TALIBAN.
Är inte någon expert, men jag har inte akne heller.
NEVER UNDERESTIMATE THE POWER OF STUPID PEOPLE IN LARGE GROUPS.. "Betala i förskott på blocket?" tråden.

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007
Citat:

Ursprungligen inskrivet av Grönis
prova och lägg in Dx 9

testat de och de funkade inte.

hmm kommer inte ihåg va de va för nät agg ja köpte...

men jag ska testa att formater om och lägga in vista på nytt.
btw är windows 7 något man ska satsa på eller?

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Feb 2009
Citat:

Ursprungligen inskrivet av eplet
testat de och de funkade inte.

hmm kommer inte ihåg va de va för nät agg ja köpte...

men jag ska testa att formater om och lägga in vista på nytt.
btw är windows 7 något man ska satsa på eller?

Absolut inte om du har en "äkta" Vista! Det är helt självklart att det ska gå att spela på Vista. Om det inte fungerar med Vista kommer det INTE fungera med Windows 7, garanterat!
I såna fall ligger troligtvis problemet någon annanstans.
Men pröva formatera om hårddisken och gör en "ny" installation av Vista.

Hur många Watt är nätaggregatet på? 4870 kräver 2st 6-pin strömkontakter från nätaggregatet, är du säker på att du har kopplat in båda? Låter som att du bara har kopplat in ena och när grafikkortet belastas så får det inte tillräckligt mycket ström för att du (kanske) glömt kabeln.:P

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2006

Verkar som du har ett grafikorts/skärm problem
reagerar rejält tex på detta i din config
"Bildskärm Generic PnP Monitor [NoDB]" så ska det inte se ut
tror du inte har lagt in drivern för skärmen helt enkelt

För tillfället en sketen Acer gaming laptop

Trädvy Permalänk
Medlem
Plats
Dalsjöfors
Registrerad
Aug 2008
Citat:

Ursprungligen inskrivet av eplet
testat de och de funkade inte.

hmm kommer inte ihåg va de va för nät agg ja köpte...

men jag ska testa att formater om och lägga in vista på nytt.
btw är windows 7 något man ska satsa på eller?

Windows 7 Ultimate beta Kör jag med själv. Datorn blev mycket snabbare änn när jag hade Vista. Så W7 är nått man ska satsa på för det kommer ersätta Vista och XP. När Full relesen kommer.

Intel i7 8700k|Noctua NH-D15|EVGA GTX 1080 FTW|Asus Maximus X Hero|16GB Corsair DDR4 3600MHz|Seasonic Prime Titanium 750W|Samsung SSD 960 PRO 512GB|Phantek Enthoo Primo||Acer XB270HU IPS 144Hz Gsync|BenQ XL2410T 120Hz|Logitech G903|Qpad MK-90|Sennheiser Game Zero Black|

Trädvy Permalänk
Medlem
Plats
Storstan
Registrerad
Dec 2003

Dom där spelen ska funka i Vista. Tft vet jag dock inte men du kanske mena tft2 ?
Blev väl något knas vid "uppgraderingen" eller så är det fel drivare.

Verkar konstigt om det vore hårdvarurelaterat då det funakt innan med xp.. men allt är möjligt..

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007
Citat:

Ursprungligen inskrivet av id_hunter
Absolut inte om du har en "äkta" Vista! Det är helt självklart att det ska gå att spela på Vista. Om det inte fungerar med Vista kommer det INTE fungera med Windows 7, garanterat!
I såna fall ligger troligtvis problemet någon annanstans.
Men pröva formatera om hårddisken och gör en "ny" installation av Vista.

Hur många Watt är nätaggregatet på? 4870 kräver 2st 6-pin strömkontakter från nätaggregatet, är du säker på att du har kopplat in båda? Låter som att du bara har kopplat in ena och när grafikkortet belastas så får det inte tillräckligt mycket ström för att du (kanske) glömt kabeln.:P

Det va inte jag som byggde ihop datorn utan en polare som har jobbat med det på ett datorföretag så jag litade på honom men mycket möjligt att det kan vara någon kabel som inte sitter där den ska... men låter inte troligt med tanke på att det har ju funkat perfa i xp i någon månad.

""Bildskärm Generic PnP Monitor [NoDB]" så ska det inte se ut
tror du inte har lagt in drivern för skärmen helt enkelt"

hmm jag installerade drivers till den från skivan som ingick kanske måste ha någon speciel för vista?

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Feb 2009
Citat:

Ursprungligen inskrivet av eplet
Det va inte jag som byggde ihop datorn utan en polare som har jobbat med det på ett datorföretag så jag litade på honom men mycket möjligt att det kan vara någon kabel som inte sitter där den ska... men låter inte troligt med tanke på att det har ju funkat perfa i xp i någon månad.

""Bildskärm Generic PnP Monitor [NoDB]" så ska det inte se ut
tror du inte har lagt in drivern för skärmen helt enkelt"

hmm jag installerade drivers till den från skivan som ingick kanske måste ha någon speciel för vista?

Ladda ner de senaste drivrutinerna:

http://support.amd.com/us/gpudownload/Pages/index.aspx

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007
Citat:

Ursprungligen inskrivet av id_hunter
Ladda ner de senaste drivrutinerna:

http://support.amd.com/us/gpudownload/Pages/index.aspx

Jag har de senaste drivers för grafikkorten men det är för skärmen jag menar men de kanske inte har så stor inverkan med tanke på att skärmen funkar i allt annat förutom spel

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Feb 2009

Men man behöver inte ha drivrutiner för skärmen för att spela!?:P

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007
Citat:

Ursprungligen inskrivet av id_hunter
Men man behöver inte ha drivrutiner för skärmen för att spela!?:P

nee precis

Trädvy Permalänk
Avstängd
Plats
borås
Registrerad
Apr 2009

bra tips till dig: du säger att det inte går att spela. håll dig borta från spel, spel medför bara beroende och gör dig till en nörd. men om du inte kan hålla dig borta från spel så ska du ta ett snöre och knuta fast i datorn dra sedan hårt i snöret så datorn flyger med, har inte detta fixat problemet så kan du ju alltid ta och testa med att hälla vatten inuti ditt nätaggregat och på moderkortet det ska hjälpa annars är din dator pajj.

okej seriöst: formatera om din hårddisk och installera om vista och drivrutiner sen ska det funka.

datordelar for sale: www.marknaden.webs.com

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Har du provat att köra något spel i "window mode"?

T.ex. Diablo 2 kan man ställa i window mode genom att ändra i shortcut. Högerklicka ta Egenskaper/Properties och lägg till -w efter programraden.

Det verkar som spelen fungerar eftersom du får ljud och allting men bildskämen slocknar. ATI har haft en del problem med att man får svart skärm när man bootar, men inte sett någon som fått det bara i spel. Ett spel som D2 går ju inte att köra i mer än 800x600 fullscreen så borde inte vara något problem med monitorläget för det tycker man med tanke på din 24".

I kontrollpanelen för ATI finns 2 inställningar för DVI under Digital Panel->Attributes->DVI Settings. Prova att slå av/på dem och se om det gör någon skillnad. Du kan även prova att byta till en VGA kabel till skärmen och se om det gör någon skillnad.

Trädvy Permalänk
Medlem
Plats
\\Localhost
Registrerad
Mar 2006

skulle kunna tro att det beror på att Dx9 inte är inlaggt .
http://www.softwarepatch.com/windows/directx.html

annars kan det vara att du har UAC igång
testa att högerklicka på spel iconen och starta som Administratör

Asus Z97-A, I7 4790K @4.8GHz 1.29V, 24Gb ram, 2x GIGABYTE GTX 970 WindForce 3X OC @ 1511Mhz/7246Mhz.
[Lista] De bästa gratisprogrammen

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2007
Citat:

Ursprungligen inskrivet av Myllerman
Dom där spelen ska funka i Vista. Tft vet jag dock inte men du kanske mena tft2 ?
Blev väl något knas vid "uppgraderingen" eller så är det fel drivare.

Verkar konstigt om det vore hårdvarurelaterat då det funakt innan med xp.. men allt är möjligt..

tft är Warcraft 3 the frozen throne.

Men helt självklart något problem med drivrutinerna.

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Aug 2007

Nu har ja formaterat om och installerat allt som behövs för att kunna spela. startade bioshock igen då blev de en liten "windowmode" ruta som va ungefär 1/4 av hela skärmstorleken jag gick in i grafikinställningarna och ändrade till samma storlek som jag hade i windows då blev de bara svart skärm igen och ljud :C.

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

1) I kontrollpanelen för ATI finns två inställningar för DVI under Digital Panel->Attributes->DVI Settings. Prova att slå av/på dem och se om det gör någon skillnad.

2) Prova en annan anslutning till din skärm: VGA-sladd

3) Se till att köra GPU-fläkten på 100% (för att utesluta värmeproblem). ATI kontrollpanel -> Overdrive -> Enable Manual Fan Control = 100%.

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Aug 2005

Har du tankat hem alla updateringar till vista från microsoft?
Dvs alla dom man INTE får genom autoupdate, det är väldigt många kan jag lova.

Jag hade ett liknande problem, då var det problem med addresserings problem osv osv.

Ryzen 2700X - Asus X370 Prime - 32gb 2666mhz - 1080TI - 960 Evo 1tb
Asus Strix GL502VM - i7 7700HQ - 24 gb - GTX 1060 6gb - 512gb M.2
Lenovo Thinkpad 440p - i7 4710MQ - 16gb - GTX730m - 256gb SSD

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Nu kan du även testa med Catalyst 9.6.

http://game.amd.com/us-en/drivers_catalyst.aspx

Trädvy Permalänk
Medlem
Registrerad
Feb 2003

edit: nvm