Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jan 2002

SWF vägrar fungera i html.

Hej alla,

Jag har ett jobbigt problem med en .swf-fil som jag försöker visa upp på min hemsida.

Den fungerar som den ska om man bara spelar upp den som vanligt, men när man ska spela upp den genom html-filen så händer inget.

Swf:en är av samma typ som denna:
http://www.tungviktarna.se/tung3/flash/example_xml.swf

Har provat lite olika varianter på kod, men alla ger samma resultat.

T.ex. denna (dreamweavers):

Citat:

<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swfla...','width','1033','height','144','src','flash/bahs','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_...','movie','flash/bahs' ); //end AC code
</script>
<noscript>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swfla..." width="1033" height="144">
<param name="movie" value="flash/example_xml.swf" />
<param name="quality" value="high" />
<embed src="flash/example_xml.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_..." type="application/x-shockwave-flash" width="1033" height="144"></embed>
</object>

Den visar bara en tom laddnings-"bar" utan att det händer något mer.

Förhoppningsvis så är någon här mer haj på detta

//Zidde

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jan 2002

Ingen som har någon tanke om detta?

//Zidde

Trädvy Permalänk
Testpilot
Plats
Norrköping
Registrerad
Sep 2002

Att laddningsmätaren kommer upp tyder ju på att det funkar, det finns ingen inbyggd laddningsmätare i Flash utan det måste man koda själv. Laddningsmätaren du ser är alltså den som finns i SWF-filen och felet ligger någon annanstans.

Jag skulle gissa på att du har fel sökvägar till bilderna som SWF-filen försöker ladda men det är svår att avgöra om du inte ger mer information om vad du försöker göra och hur katalogstrukturen ser ut.

Kolla gärna in min RGB-LED-ljusstake i galleriet
[Gigabyte GA-Z97MX-Gaming 5][Intel Core i5 4690K][Corsair XMS3 8GB][Gigabyte GeForce GTX 970 G1 Gaming]

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jan 2002

Självfallet! Att jag inte tänkte på det. Det var sökvägen

.xml-filen som swf'en hämtar bilderna från får ju en annan sökväg (ur html-sidans synpunkt) när man spelar upp den externt.

Tack så mycket för hjälpen!

//Zidde