Permalänk
Medlem

Webmin och Postfix

Jag håller på att sätta upp en egen mailserver. Just nu så har jag Postfix oxh dovecot installerat, och jag vill kunna kontrollera det via Virtualmin, och ge clienter möjlighet att skapa egna maillådor.

Jag kan logga in på mailservern, och skicka mail från servern, men när jag försöker skicka till server nså får jag följande svar:

Citat:

This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

test@datasidan.se

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 <test@datasidan.se>: Relay access denied (state 14).

----- Original message -----
[...]

Jag har inte lyckats hitta någon bra tutorial på det jag vill göra, även att jag tycker att det borde finnas. Jag kanske är för trött för att googla bra nu

Permalänk
Medlem

Vad säger mailloggen?

brukar ligga under
/var/log/mail.info

Permalänk
Medlem

Dessa rader skrevs när servern tog emot mailet

Citat:

Sep 20 00:26:26 sir postfix/smtpd[8585]: connect from mail-fx0-f206.google.com[209.85.220.206]
Sep 20 00:26:26 sir postfix/smtpd[8585]: NOQUEUE: reject: RCPT from mail-fx0-f206.google.com[209.85.220.206]: 554 5.7.1 <test@datasidan.se>: Relay access denied; from=<xaar@overklockningssidan.se> to=<test@datasidan.se> proto=ESMTP helo=<mail-fx0-f206.google.com>
Sep 20 00:26:26 sir postfix/smtpd[8585]: disconnect from mail-fx0-f206.google.com[209.85.220.206]

Permalänk
Permalänk
Medlem

Här är den!

# See /usr/share/postfix/main.cf.dist for a commented, more complete version # Debian specific: Specifying a file name will cause the first # line of that file to be used as the name. The Debian default # is /etc/mailname. #myorigin = /etc/mailname smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) biff = no # appending .domain is the MUA's job. append_dot_mydomain = no # Uncomment the next line to generate "delayed mail" warnings #delay_warning_time = 4h readme_directory = /usr/share/doc/postfix # TLS parameters smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key smtpd_use_tls = yes smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for # information on enabling SSL in the smtp client. myhostname = sir.ragealot.haxalot.com alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases myorigin = /etc/mailname mydestination = sir.ragealot.haxalot.com, localhost.ragealot.haxalot.com, srv1.$ relayhost = smtprelay1.telia.com mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 mailbox_command = procmail -a "$EXTENSION" mailbox_size_limit = 0 recipient_delimiter = + inet_interfaces = all html_directory = /usr/share/doc/postfix/html transport_maps = hash:/etc/postfix/transport virtual_alias_maps = hash:/etc/postfix/virtual relocated_maps = hash:/etc/postfix/relocated smtpd_sasl_security_options = smtpd_recipient_restrictions = permit_mynetworks permit_inet_interfaces permit_$

Permalänk
Medlem

Kolla om du kan maila på test@mail.domain.com

mailbox_size_limit = 0 ?

Permalänk
Medlem

Nu testade jag att lägga till datasidan.se på raden mydestination. Då får jag inget felmail till min gmail, men det kommer inte heller något meddelande till inkorgen.

Jag använder dovecot som IMAP server.

Permalänk
Medlem

Kör inte dovecot själv så vet inte riktigt hur det ska vara där. Tycker det fortfarande är skumt att mailbox_size_limit är satt till 0. Innebär att du 24-72 timmar efter du skickade mailet från gmail kommer få ett fel som säger att "recipient mailbox is full".

Permalänk
Medlem

Jag har ändrat mailbox_max_size till 51200000 nu (ska vara så som default, även att det tydligen inte var så i min config).

Permalänk
Medlem

Säger den något i loggen nu när du lagt till datasidan.se?

Kan du prova att ansluta till den lokalt med nc/telnet och skicka till [user]@datasidan.se.

Går till så här (ungefär, jag skriver ur minnet):

# nc localhost 25
P: 220 postfix bla bla bla
Y: MAIL FROM: [user]@datasidan.se
P: 250 OK
Y: RCPT TO: [user]@datasidan.se
P: 250 OK
Y: DATA
P: 352 OK, end with bla bla bla
Y: Subject: Testing alalalala
Y: Hejsan, detta är message body...
Y: .
P: 250 OK, queued as [id] (ej helt hundra på denna statuskod, men den ska säga ok och könr)

Du är Y, postfix är P.

Permalänk
Medlem

Logg filen:

Citat:

Sep 21 06:59:20 sir postfix/smtpd[17350]: connect from mail-yx0-f204.google.com[209.85.210.204]
Sep 21 06:59:20 sir postfix/smtpd[17350]: E701A484870: client=mail-yx0-f204.google.com[209.85.210.204]
Sep 21 06:59:21 sir postfix/cleanup[17354]: E701A484870: message-id=<3ddfe8880909202159g30af3096x14922328ca9ad67e@mail.gmail.com>
Sep 21 06:59:21 sir postfix/qmgr[17123]: E701A484870: from=<xaar@overklockningssidan.se>, size=1340, nrcpt=1 (queue active)
Sep 21 06:59:21 sir postfix/local[17355]: E701A484870: to=<test-datasidan.se@sir.ragealot.haxalot.com>, orig_to=<test@datasidan.se>, relay=local, delay=0.61, delays=0.57/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Sep 21 06:59:21 sir postfix/qmgr[17123]: E701A484870: removed

Det stämmer också när jag telnettar till servern

Jag postar dovecot.conf också: (Jag har tagit bort alla kommenterade rader eftersom att den var så stor)

protocols = imap imaps ## ## Logging ## log_timestamp = "%Y-%m-%d %H:%M:%S " ## ## SSL settings ## ## ## Login processes ## ## ## Mailbox locations and namespaces ## mail_location = maildir:~/Maildir # Group to enable temporarily for privileged operations. Currently this is # used only with INBOX when either its initial creation or dotlocking fails. # Typically this is set to "mail" to give access to /var/mail. mail_privileged_group = mail ## ## Mail processes ## ## ## Mailbox handling optimizations ## ## ## Maildir-specific settings ## ## ## mbox-specific settings ## ## ## IMAP specific settings ## protocol imap { } ## ## POP3 specific settings ## protocol pop3 { pop3_uidl_format = %08Xu%08Xv } ## ## MANAGESIEVE specific settings ## protocol managesieve { sieve=~/.dovecot.sieve sieve_storage=~/sieve } ## ## LDA specific settings ## ## ## Authentication processes ## auth default { passdb pam { } userdb passwd { } user = root } ## ## Dictionary server settings ## dict { #quota = mysql:/etc/dovecot-dict-quota.conf } ## ## Plugin settings ## plugin { }

Permalänk
Medlem

Det där ser vettigt ut från postfix synvinkel ju. Den skickar vidare allt till procmail och då har den inte längre kontroll alls över mailet, så den säger att det levererats.

Jag kör varken dovecot eller procmail tyvärr. Men om mail inte dyker upp nu ligger felen troligen i procmail.

Permalänk
Medlem

håller med cl3mens, postfix sätter "status=sent (delivered to command: procmail -a "$EXTENSION")". Kolla på dovecot's community om du hittar nån vettig FAQ kanske.

Permalänk
Medlem

Hittade den här guiden och lyckades få det att fungera