[Ubuntu] Ingen bild på högre upplösningar?

Permalänk
Medlem

[Ubuntu] Ingen bild på högre upplösningar?

Hej!
Snälla hjälp mig med detta, har vänt mig till några olika forum men har blivit totalt dissad
Jag har en HTPC som har både Vista och Karmic, Jaunty går inte att installera(Förklaring följer), med ett intel mobo med integrerat grafikkort som stödjer upplösningen 1920x1080 via DVI.
Detta fungerar klock rent på samma dator med samma uppsättning.

Dock så får jag endast ut 1280x720.
Om jag kör xrandr får jag ut:

Screen 0: minimum 320 x 200, current 1280 x 720, maximum 4096 x 4096 VGA1 disconnected (normal left inverted right x axis y axis) DVI1 connected 1280x720+0+0 (normal left inverted right x axis y axis) 20mm x 10mm 1280x720 60.0* 640x480 60.0 TV1 disconnected (normal left inverted right x axis y axis)

Obersvera: Det finns ingen VGA utgång på denna maskin, endast DVI. Även S-Video, fast det stödjer inte monitorn.

En annan maskin med Jaunty funkar med monitorn klockrent på 1920x1080 (samma sladdar), annat grafikkort.

Om jag nu tvingar fram 1920x1080 @ 60 Hz med xrandr enligt:

xrandr --output DVI1 --scale 1920x1080 --rate 60

Så blir bilden helt svart. Dock har monitorn fortfarande singal ifrån datorn, men bara svart.

Jag tänkte då: Jag installerar Jaunty istället, då många har problem med Karmic.
Men, när jag bootar jaunty installationen blir skärmen också svårt! Detta beror på, enligt min teori, att upplösningen som installationen väljer är "för hög", även om den ska fungera.

Om jag kör cvt 1920 1080 får jag

# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync

Det ser väll helt normalt ut?
Jag hittar inget vettigt om dessa problem... Någon måste ha någon idé om vad det kan vara?
Eftersom att samma dator fungerar så klock rent i Vista, ska det ju inte vara fel på grafikkortet (Dessutom kom den precis ut ifrån service, där de bytte hela moderkortet )

Permalänk
Hedersmedlem

Hoppas jag inte leder dig på för långa villovägar nu, men jag hade problem med att mitt GF5200 inte ville visa 1680x1050 via DVI-kontakten (pga att det är ett strypt budgetkort från en era innan HD).

Jag lyckades få det att lira genom att använda så kallad "Reduced blanking" genom att sätta en viss modeline.

Jag ska inte säga att jag är helt insatt i problemet längre då jag inte använt den konfigurationen prylar på ett bra tag, men jag kan posta min dåvarande xorg.conf (med en projektor som andra monitor vilket inte är relevant, men klistrar in hela för sammanhangets skull):

Section "ServerLayout" Identifier "Default Layout" Screen 0 "Primär" 0 0 Screen 1 "Sekundär" RightOf "Primär" EndSection Section "Monitor" Identifier "Monitor" VendorName "Samsung" ModelName "225MW" ModeLine "1680x1050rb" 119.00 1680 1728 1760 1840 1050 1053 1059 1080 -hsync +vsync Option "ExactModeTimingsDVI" "true" EndSection Section "Monitor" Identifier "Projektor" VendorName "Hitachi" ModelName "PJTX300" HorizSync 31.0 - 64.0 VertRefresh 50.0 - 120.0 EndSection Section "Device" Identifier "DVI ut" Driver "nvidia" VendorName "NVIDIA" BoardName "GeForce FX 5500" BusID "PCI:1:0:0" Screen 0 Option "DPMS" Option "ModeValidation" "NoDFPNativeResolutionCheck" EndSection Section "Device" Identifier "VGA ut" Driver "nvidia" VendorName "NVIDIA" BoardName "GeForce FX 5500" BusID "PCI:1:0:0" Screen 1 EndSection Section "Screen" Identifier "Primär" Device "DVI ut" Monitor "Monitor" DefaultDepth 24 Option "TwinViewXineramaInfoOrder" "DFP-0" Option "metamodes" "DFP: 1680x1050rb +0+0" SubSection "Display" Depth 24 EndSubSection EndSection Section "Screen" Identifier "Sekundär" Device "VGA ut" Monitor "Projektor" DefaultDepth 24 Option "TwinViewXineramaInfoOrder" "DFP-0" Option "metamodes" "CRT: 1280x720 +0+0" SubSection "Display" Depth 24 EndSubSection EndSection

Givetvis ska du inte copy-pastea modelinen då den är specifik för min monitor/grafikkort/upplösning, men du kanske kan få någon info från filen ovan.

"NoDFPNativeResolutionCheck" är till för att skärmen och grafikkortet inte ska kommunicera själva och komma fram till att de inte kan leka i 1680x1050, då de egentligen kan.

"ExactModeTimingsDVI" är ytterligare en option som säger att grafikkortet inte ska tänka så mycket själv utan bara lita på de siffror jag ger det, även om det tror att det inte går.

Googla så kan du säkert hitta någon modeline som fungerar för din konfiguration, någon javascript-modeline-generator eller nåt.

Att det funkar i Windows kanske beror på att de sätter "reduced blanking" automatiskt pga att drivrutinen är mer fancy till den plattformen.

Permalänk
Medlem

Hej!
Tack för snabbt svar.

cvt är en modeline generator, och jag har ingen nuvarande xorg.conf fil, och jag har ingen aning vart jag ska börja för att bygga upp en.

cvt är förövrigt en inbygd modeline generator i ubuntu (säkert i andra distros)

Jag testade att reduce blanking med cvt men det fungerade ändå inte... :(, bara svart!

EDIT: Finns det något sätt att visa modelines för redan inlagda modes i xrandr?