4890 drivrutiner i Ubuntu 9.10 ?

Permalänk
Medlem

4890 drivrutiner i Ubuntu 9.10 ?

Hejj jag har problem med att installera drivrutiner i ubuntu.
har googlat och hittade en guide som verkade bra, testade den men det inget vidare.
jag försökte på det här sättet:

cd/ home
sudo sh ati*.run

då kommmer installationen igång men jag får ett error som lyder:
" error: vcdk is missing. installation aborted. "

har även testat att installera xorg men där installeras bara catalyst men inga drivers
när jag försöker med envy så vill den inte starta alls :s
hjälp mig vad ska jag göra ? håller på att bli galen

Permalänk
Inaktiv

Kan du inte bara gå in i System>Administration>Programvarukällor och aktivera alla, ladda om, sen kolla Hardware drivers? Är säker på att Ubuntu har några att rekommendera. Man måste inte alltid göra på Windows-sättet

Permalänk

står det inte exakt i texten, som följer med drivrutinerna från ati's site, hur man gör?

Permalänk
Medlem

ingen lycka där heller tyvärr... listan står tom som innan

jo det finns en readme fil på deras sida men den fungerar ju inte hos mig.....
där får jag errors som jag skrev tidigare. vcdk missing blalabla

Permalänk
Inaktiv
Citat:

Ursprungligen inskrivet av infexis

när jag försöker med envy så vill den inte starta alls :s

sudu apt-get update
sudo apt-get install envyng-core
sudo envyng -t

Startar inte envy efter detta?

Permalänk
Medlem

Försök INTE att installera ATIs egna drivrutiner själv, det kräver grym handpåläggning och är i princip dömt att misslyckas.

Det bästa är att köra "resticted drivers manager" under "administration", då skall Ubuntu hitta färdiggjorda ATI-drivrutiner som du ombeds att installera.

Är inte 100% säker på att det finns någon bra sådan ännu för HD4890, men om den finns är det där den skall finnas.

Om de inte finns, så får man köra med den inbyggda drivruitnen i Ubuntu, den har iaf 2D-acceleration och videostöd men saknar tyvärr 3D än så länge.

Permalänk
Medlem

ibyggda ubuntu drivers verkar inte finnas har redan sökt igen databasen.

sen så har jag lyckats komma vidare med "sudo sh ati*.run"
där verkar ju allting som att det installeras men i slutsteget när jag trycker "ok" så händer absolut ingenting efter, försöker reboota men hjälper inte heller.

jag har även försökt med envy en gång till och lyckades starta den, men nu har jag större problem än tidigare
när datorn ska starta, så står den fast vid bootskärmen och flashar (blinkar) hela tiden och jag lyckas inte komma förbi det

Permalänk
Medlem

Som sagt, fiddla INTE med ATIs egen drivrutin, det slutar så som det gjort för dig: något står och blinkar.

"restricted drivers" är det som gäller, och fungerar inte det får du glömma 3D helt tillsvidare.

Den inbyggda drivrutinen heter inte "ATI", den heter "radeon" så det är den du får installlera istället. Den skall normalt bli installerad automatiskt vid nyinstallation av operativet. Men det är möjligt att den inte stöder HD4890.

Var det den här guiden du använde?:

https://help.ubuntu.com/community/BinaryDriverHowto/ATI

om inte, kan du prova den istället om du absolut vill ha "fglrx".

För övrigt finns det en anledning att de flesta som är seriösa med Linux ser till att använda Nvidia istället ...

Permalänk
Medlem

jag ger inte upp så lätt så fort jag stöter på ett problem,
btw, finns det ngt sätt så jag ändrar att mitt inbyggda mobo graffe är standard på linux? då kanske det går bättre eller vad tror ni ?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av infexis
jag ger inte upp så lätt så fort jag stöter på ett problem,
btw, finns det ngt sätt så jag ändrar att mitt inbyggda mobo graffe är standard på linux? då kanske det går bättre eller vad tror ni ?

Om du vill få igång ATI-kortet är det bästa att du STÄNGER AV det inbyggda grafikkortet i bios. Dubbelgrafikkortsstöd är ingen höjdare på Linux, så bort med det.

Permalänk
Medlem

lägg filen i hem mappen.
sudo bash ''fil namn''

Permalänk
Medlem

Eller som det står i guiden jag länkade till(glöm inte att glömma ATI-filen du laddat ner):

Enable the accelerated ATI graphics driver in the 'Hardware Drivers' (System->Hardware drivers), then do: sudo dpkg-reconfigure -phigh linux-restricted-modules-`uname -r` sudo insmod /lib/modules/`uname -r`/volatile/fglrx.ko Log out and log in.

Det är allt man skall behöva göra. I alla fall var det så på 9.04, 9.10 bör inte vara allt för annorlunda.

Permalänk
Medlem

som jag sa tidigare så är den listan helt tom, finns inget att aktivera där!
tro mig jag hade föredragit det sättet men eftersom inte det går så måste jag ju testa andra alternativ.

jag kör ubuntu i virtualbox på windows 7, mitt problem är att jag inte kan ändra upplösningen och jag kan inte ändra visuella effekter.
det är det som stör mig och därför vill jag kunna ha drivisarna

Permalänk
Hedersmedlem
Citat:

Ursprungligen inskrivet av infexis
som jag sa tidigare så är den listan helt tom, finns inget att aktivera där!
tro mig jag hade föredragit det sättet men eftersom inte det går så måste jag ju testa andra alternativ.

jag kör ubuntu i virtualbox på windows 7, mitt problem är att jag inte kan ändra upplösningen och jag kan inte ändra visuella effekter.
det är det som stör mig och därför vill jag kunna ha drivisarna

Men säg att du kör virtualbox direkt då.

Du ska inte ha ATI-grafikdrivers utan Virtualbox egna drivrutiner. Klicka på enheter > installera gästtillägg så löser det sig. Notera att Virtualbox endast har experimentellt 3D-Stöd.

Permalänk
Medlem

FAIL BIGTIME... fan vad jag e trög!

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av the squonk
Försök INTE att installera ATIs egna drivrutiner själv, det kräver grym handpåläggning och är i princip dömt att misslyckas.

Det bästa är att köra "resticted drivers manager" under "administration", då skall Ubuntu hitta färdiggjorda ATI-drivrutiner som du ombeds att installera.

Är inte 100% säker på att det finns någon bra sådan ännu för HD4890, men om den finns är det där den skall finnas.

Om de inte finns, så får man köra med den inbyggda drivruitnen i Ubuntu, den har iaf 2D-acceleration och videostöd men saknar tyvärr 3D än så länge.

Installerade alltid ATI's egna när jag körde, var ju otroligt lätt. "sudo sh ...", reboot sen var det klart.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av MarcusW
Installerade alltid ATI's egna när jag körde, var ju otroligt lätt. "sudo sh ...", reboot sen var det klart.

Inte om man har HD4***, vilket inte är purfärskt längre men likförbannat strular hårt under Linux.

Äldre ATI-kort fungerar hyfsat, som du säger. Med Nvidia fungerar alla kort.

Som sagt, det hade underlättat om vi vetat att det var virtualbox, då hade alla kunnat säga gästtillägg på en gång

Permalänk
Medlem

grabbar.. jag har nu fått igång guest addition i virtualbox.. upplösningen kan jag ändra nu men jag kan fortfarande inte använda visuella effekterna... inte ens på "normal" nivå?
Vad är det som kan vara fel nu då ?

Permalänk
Medlem

Det är virtuellt, det blir nog inte så mycket bättre än som du har det för tillfället, tyvärr. Virtuell 3D är _mycket_ experimentellt än så länge så det är inget du kan räkna med alls.

Vill du ha "the real deal" får du installera på riktigt utan virtualbox.

Du kan dock påverka prestanda litegrann i virtualbox inställningar genom att tilldela mer minne till den virtuella maskinen(jag vill minnas att man måste ha grafikminnes-regeln på max för att få full hårdvaruacceleration i virtualbox-drivern), och så antar jag att du har provat att kryssa i rutan "3D" under inställningar. Annars har du inte ens försökt.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av the squonk
Inte om man har HD4***, vilket inte är purfärskt längre men likförbannat strular hårt under Linux.

Äldre ATI-kort fungerar hyfsat, som du säger. Med Nvidia fungerar alla kort.

Som sagt, det hade underlättat om vi vetat att det var virtualbox, då hade alla kunnat säga gästtillägg på en gång

Sade inget om äldre, HD4850 var det. I värsta fall fanns inte 3d-stöd när man startade X igen, men då var det bara att installera om föregående drivrutin.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av MarcusW
Sade inget om äldre, HD4850 var det. I värsta fall fanns inte 3d-stöd när man startade X igen, men då var det bara att installera om föregående drivrutin.

Inget 3D-stöd är illa nog enligt mig, då kan man lika gärna köra den fria drivrutinen. Dessutom är man bunden till en viss kernel, vill man köra en nyare kernel pgs andra nytillkomna finesser är det tji. Klart strul enligt mig, även om det i vissa fall och under vissa kriterier kan fungera.

Med Nvidia fungerar det alltid, med alla kort, alla drivrutiner och alla kernels. Många plus där imho.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av the squonk
Inget 3D-stöd är illa nog enligt mig, då kan man lika gärna köra den fria drivrutinen. Dessutom är man bunden till en viss kernel, vill man köra en nyare kernel pgs andra nytillkomna finesser är det tji. Klart strul enligt mig, även om det i vissa fall och under vissa kriterier kan fungera.

Med Nvidia fungerar det alltid, med alla kort, alla drivrutiner och alla kernels. Många plus där imho.

Nja, beror på hur man tänker. Riskfyllt ser jag som att om något går fel startar inte X nästa gång. Det råkade jag inte ut för med det kortet. Fick aldrig problem vid byte av Kernel heller, men körde iofs bara säkerhetsuppdateringar.

Permalänk
Medlem

jag har fortfarande inte lyckats fixa visuella effekter i min linux virtual.
3d är påslaget enligt inställningarna, men när jag aktiverar det i ubuntu så blir hela den väldigt konstig och ehla systemet buggar och blir översegt. vad göra ?