[Ubuntu] XBMC - Spela upp DVD. Vad har jag missat?

Permalänk
Medlem

[Ubuntu] XBMC - Spela upp DVD. Vad har jag missat?

Tjena
Försöker spela upp en dvd-image, självklart legal, på xbmc.

Det laddar lite grann efter jag bläddrat upp filen sedan stängs XBMC ner tyst.
Sista raderna i loggen visar inga direkt fel?

22:12:55 T:2902915952 M:1941241856 INFO: ffmpeg[AD06FB70]: Duration: N/A, bitrate: N/A 22:12:55 T:2902915952 M:1941241856 NOTICE: Opening video stream: 0 source: 256 22:12:55 T:2902915952 M:1941241856 INFO: GetVideoAspectRatio - Aspect wanted: 3, Scale permissions: 2 22:12:55 T:2902915952 M:1941241856 NOTICE: Creating video codec with codec id: 2 22:12:55 T:2902915952 M:1941241856 NOTICE: Trying VDPAU-MPEG from FFMPEG 22:12:55 T:2902915952 M:1941241856 DEBUG: FactoryCodec - Video: - Opening 22:12:55 T:2902915952 M:1941241856 DEBUG: SECTION:LoadDLL(special://xbmc/system/players/dvdplayer/swscale-0.6.1-i486-li...) 22:12:55 T:2902915952 M:1941241856 DEBUG: Loading: /usr/share/xbmc/system/players/dvdplayer/swscale-0.6.1-i486-linux.so 22:12:55 T:2902915952 M:1940987904 NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(720x576)

Någon som har koll? Jag har en Out-of-the-box ubuntu på en htpc med en out-of- the-box Xbmc på sig, alltså så har det aldrig funkat för mig, vanliga AVI filer fungerar klockrent, även rarade.
Självklart inget piratkopierat!

EDIT: jag tog bort allt med vdpau et c i synapic och sedan valde jag "Software" Som renderer i settings > Video i xbmc... För lätt för att jag skulle fatta

Permalänk
Inaktiv

fast vdpau vill man ju ha. Det är tydligen ASBRA(har inte själv provat). Installerat ubuntu-restricted-extras? Där har du flash, codecs, java, och alla annan sån där proprietär skit som man vill ha bara för att man måste

edit: Och dvd

Permalänk
Medlem

http://en.wikipedia.org/wiki/VDPAU

Du ska nog inte stänga av VDPAU, nej.
Software låter ganska så tungrott..?

Permalänk
Medlem
Permalänk
Medlem

har intel kort, vilket jag inte tror stödjer vdpau?

Jag har alla libs ni förslår

Permalänk
Medlem

Jag har också problem med iso-filer i xbmc, speciellt de som jag tillverkat själv från videokameran. Men detta verkar vara en bugg i vissa versioner av xbmc vad jag har läst. Kan nämna att jag kör med vdpau eftersom jag har rätt klen processor (AMD 3400+) men bra stöd av grafikkortet (8400gs pci).

Efter att uppgraderat till en testversion (svn något) så hänger sig inte xbmc men jag får ändå inte bild på vissa iso-filer (bara ljud). Som jag fattat det så ska codecs och sådant vara integrerat i xbmc så jag tror inte det hjälper med att lägga till sådana.

Jag ska testa med nya alfa-versionen av xbmc live bootat från en CD och se hur det funkar (där är ju allting redan konfigurerat).

Permalänk
Medlem

Det funkar inte att lägga till codecs i efterhand, typ ubuntu-restricted.
För att aktivera VDPAU i xbmc tror jag man måste man ha nvidia 185 drivrutinen.
Med ATi kort vet jag tyvärr inte.

Testa med XBMC SVN
PPA: https://launchpad.net/~team-xbmc-svn/+archive/ppa

PPA nyckeln: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 64234534

Permalänk
Medlem

Behöver man verkligen nvidia-185 drivaren för att kunna få vdpau att fungera? Jag kör med nvidias senaste på min server/htpc och eftersom xbmc inte finns färdigt för 9.10 än så har jag inte kommit mig för att undersöka hur pass xbmc och mitt inbyggda 8300 fungerar.

Permalänk
Medlem

Vilken version av Ubuntu och vilken version av XBMC?

Jag har aldrig stött på problem med att spela upp filmer vare sig de är .avi, .mkv, .iso eller ens .rar

Enda problemet jag har haft är att få ut ljudet via S/PDIF men det har med sucky hårdvara (eller snarare brist på drivrutiner) att göra.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Benkaboy
Behöver man verkligen nvidia-185 drivaren för att kunna få vdpau att fungera? Jag kör med nvidias senaste på min server/htpc och eftersom xbmc inte finns färdigt för 9.10 än så har jag inte kommit mig för att undersöka hur pass xbmc och mitt inbyggda 8300 fungerar.

Det är vad jag tror, att VDPAU "slogs på" i 185 drivrutinen och senare. På XBMC formet rekomenderas att man använder senaste drivrutinerna och länkar till Current NVIDIA drivers. Men, som sagt detta är något jag vill minnas myntats på forumet hos XBMC.nu eller .org..
Det sägs på UF att för att använda VDPAU i mplayer rekommenderas minst 180 drivern. Jag kanse är ute och cyklar..

Benkaboy, märker du någon stor skillnad mellan 185 och 190 drivern?