Permalänk
Proffsmoddare

Hdio_get_identity

Hejsan,

Har länge försökt få Ubuntu 9.10 installerat på min dator, men får alltid detta felmeddelande (HDIO_GET_IDENTITY failed for '/dev/.tmp-block-8:208'), och systemet bootar inte.

Det konstiga är att detta kommer alltid efter man har installerat någonting. Först trodde jag det var pga atis grafikdrivare, men det var endast för att jag alltid installerar dessa först som det händer (Blev samma fel när jag installerade emacs). Någon som har lite info om detta?

Har ett SAS-kort i systemet, och mina googlingar har alltid haft något med lagring i servrar att göra.

Tack på förhand!

Permalänk
Medlem

Fungerar Ubuntu 9.04? Efter lite googlande så verkar det som att felmeddelandet du får inte hindrar andra som rapporterat problemet att boota.
Har du testat att bara lägga in något på hårdisken och boota om? DVS inte installera något utan bara lägga in en fil på några hundra mb.
Om du har tid kan du ju testa om det löser sig om du uppgraderar kerneln. Kan ju vara någon drivrutin som inte var helt stabil i ubuntu 9.10 kerneln.

Edit: Om du nu kör hårdisken på sas korten kan du testa att använda en vanlig ATA/SATA hdd?
Du kan ju också söka på ditt sas kort om du finns några kända problem i linux. Och i så fall hur man fixar det.
Jag hade problem med ett sata kontroller kort för ett tag sen. Var bara in och patcha kerneln eller vänta tills nästa version släpptes.

Permalänk
Proffsmoddare

Vet ej då jag inte hade detta kort då, körde på ett billigt pcikort som förmodligen var vanligare och hade bättre stöd.

Ja det har jag och då startar den som vanligt. Eller rättare sagt, det finns fortfarande där men hindrar inte systemet från att boota. Om man inte rör vid något efter installationen utan bara startar om så händer det inget (vore dock ganska opraktiskt ^^). Har testat med drivrutinerna från tillverkaren men det gjorde ingen skillnad, dock så var detta en rpm till fedora som jag körde genom alien för att installera, fanns inte speciella till debian/ubuntu.

Jag ska testa med att uppdatera kerneln så snart jag kan, görs det enklast genom uppdateringshanteraren eller är det nånting man får göra manuellt? (har ej gjort det innan som jag vet om).

Jag har testat att köra den disken via sata direkt på moderkortet men det var ingen skillnad.

Tack för tipsen

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av SleepstreameR

Jag har testat att köra den disken via sata direkt på moderkortet men det var ingen skillnad.

Efter eller före du uppdaterade? Om det var innan du uppdaterade systemet så tycker iallafall jag att det är konstigt att båda kontrollerkorten (det på mobot och ditt SAS) har problem :S Om nu så är fallet att det blir fel med båda så kan det kanske vara HDDn i sig som är paj?

Jag kör tyvärr gentoo så jag är inte så insatt hur man installerar eller konfigurerar kerneln i ubuntu. Efter att ha kolla i ubuntu dokumentationen så verkar det onödigt krångligt imo https://help.ubuntu.com/community/Kernel/Compile?highlight=%2...
Och i och med det så kan det bli mer problem. Men du kommer nog lära dig en del om du bara försöker till det fungerar!
Det jag gör i gentoo är "make menuconfig" metoden. DVS jag tar och väljer ut alla drivrutiner som bara min hårdvara behöver. Och för att detta ska gå så smidigt som möjligt kan du använda dig a din moderkorts manual (där brukar det stå vad de olika chipen heter osv). Du kan också använda dig av "lspci" som root för att se vad som ubuntu redan hittat.
I menuconfig kommer du hitta massor olika menyer där du kan välja CPU typ osv. Om du använder hjälp funktionen där får du ganska bra förklarat för dig vad sakerna gör och om du behöver dom eller inte.

Men innan jag skiver en (inte så bra) miniguide så kanske du ska läsa på/felsöka lite mer innan du bestämmer dig... Kan bli ganska många timmar om det inte går vägen. Och så kanske det inte var det det var fel på heller

Vad heter ditt SAS kort BTW?

Permalänk
Proffsmoddare
Citat:

Ursprungligen inskrivet av Dark Defender
Efter eller före du uppdaterade? Om det var innan du uppdaterade systemet så tycker iallafall jag att det är konstigt att båda kontrollerkorten (det på mobot och ditt SAS) har problem :S Om nu så är fallet att det blir fel med båda så kan det kanske vara HDDn i sig som är paj?

Jag kör tyvärr gentoo så jag är inte så insatt hur man installerar eller konfigurerar kerneln i ubuntu. Efter att ha kolla i ubuntu dokumentationen så verkar det onödigt krångligt imo https://help.ubuntu.com/community/Kernel/Compile?highlight=%2...
Och i och med det så kan det bli mer problem. Men du kommer nog lära dig en del om du bara försöker till det fungerar!
Det jag gör i gentoo är "make menuconfig" metoden. DVS jag tar och väljer ut alla drivrutiner som bara min hårdvara behöver. Och för att detta ska gå så smidigt som möjligt kan du använda dig a din moderkorts manual (där brukar det stå vad de olika chipen heter osv). Du kan också använda dig av "lspci" som root för att se vad som ubuntu redan hittat.
I menuconfig kommer du hitta massor olika menyer där du kan välja CPU typ osv. Om du använder hjälp funktionen där får du ganska bra förklarat för dig vad sakerna gör och om du behöver dom eller inte.

Men innan jag skiver en (inte så bra) miniguide så kanske du ska läsa på/felsöka lite mer innan du bestämmer dig... Kan bli ganska många timmar om det inte går vägen. Och så kanske det inte var det det var fel på heller

Vad heter ditt SAS kort BTW?

Uppdaterade vad? Har inte uppdaterat någonting hittills vad jag vet. Nej det på mobot är förmodligen okej, men jag måste ta ur SAS kortet ur datorn för att få bort problemet, spelar ingen roll vilken disk/diskar som sitter kopplade till det.

Jag har inget emot att sitta ett tag med att fixa med kerneln, ser det som ett litet äventyr Men jag ska väl testa den enkla vägen först genom att bara uppdatera kerneln på vanligt sätt och se om det hjälper, om inte, så får jag väl försöka patcha den istället. Återkommer med resultat efter uppdateringen

Det är egentligen därför jag vill ha linux så jag kan lära mig lite nytt, känner mig lite halvhaj på just terminalkommandon och sånt men att kompilera kärnan är något helt nytt för mig. men nån gång ska ju vara den första!

Sånt här kort är det:
http://www.mullet.se/product.html?product_id=332092

Sen sitter det även ett likadant SAS-chip på mitt moderkort (ASUS P6T7 WS SuperComputer).

Permalänk
Medlem

Ah ok trodde att det kanske var så att det blev bara fel när hårdisken som användes var kopplad till SAS kortet.
Kul att du ser det hela som en utmaning!
Men om man kollar på sida du länkade till verkar det inte båda gott:
090918 - Det verkar vara stora problem med källkoden till Linuxdrivisen och supporten från Marvell - köp inte om du vill kunna kompilera om drivrutinen

Jag kollar om det finns några drivrutiner till den i kerneln som jag kör ATM (2.6.31)

Edit: Jo då! Den finns in 2.6.31 kerneln!
CONFIG_SCSI_MVSAS:
This driver supports Marvell's SAS/SATA 3Gb/s PCI-E 88SE64XX and 6Gb/s PCI-E 88SE94XX chip based host adapters.

Så du ska inte behöva ladda ner några patchar eller drivrutiner om du har 2.6.31 eller senare.
För att kolla vilken version du kör nu kan du skriva "uname -a" i terminalen!

Permalänk
Medlem

Det verkar som om det är ett rätt vanligt problem med HDIO_GET_IDENTITY på SAS-kontrollers i kombination med SATA-diskar. Eftersom HDIO_GET_IDENTITY är en gammal ATA-ioctl så antar jag att det är något som är buggigt och som inte hunnit fixas eftersom den mesta mödan i Linux antagligen lagts på att implementera SCSI-delen.
Rapportera buggen så kommer det nog att fixa sig eftersom drivern finns i kärnan. Tills dess får du nog köra på inbyggda kontrollern.

Permalänk
Proffsmoddare

Ledsen för att det tog lite tid, mycket att göra såhär i juletider

Har testat att uppgradera till ny kernel men det gjorde ingen skillnad (Dock spelar det ingen roll då jag redan innan hade 2.6.31). Verkar som att det du NakedApe skriver är det mest troliga. Det är lite lustigt bara, har nu lagt in Linux Mint 8 (x64) och detta verkar funka. Får samma meddellande men det fortsätter boota, så nu har jag nått som går att använda iaf. Tycker det är lite skumt bara eftersom Mint är Ubuntu i stort sett.

Permalänk
Medlem

Jo det är konstigt att det fungerar med en annan dist... Aja kul att det fungerar nu iallafall!

Permalänk
Proffsmoddare

Oja helt klart! Förövrigt måste jag säga att det var tur att Ubuntu inte fungerade för Mint 8 är ju helt underbart att använda
Tack så mycket för ditt engagemang även om inte problemet i sig löstes