Permalänk
Medlem

stänga av samba?

Hej!

Vill inte att samba skall starta när man startar datorn, vill hellre ha netatalk. Men vill ändå inte ta bort samba..

Hur disablar jag samba i startup?

uname -a

Linux ubuntu 2.6.31-14-server #48-Ubuntu SMP Fri Oct 16 15:07:34 UTC 2009 x86_64 GNU/Linux

Permalänk
Medlem

aa just det.. vill ju att netatalk skall starta vid boot

edit: fel, vill att avahi-daemon skall starta. ligger i /etc/init.d

Permalänk
Medlem

Du kan ju alltid bara förhindra att sambas startscript kan köras vid boot:
sudo chmod -x /etc/init.d/samba

Edit:
sudo update-rc.d samba disable

Edit2:
sudo update-rc.d -f samba remove
tar bort scripten helt ifrån runlevelsen, men tror dom automatiskt installeras igen vid nästa update av samba.

Permalänk
Medlem

update-rc.d: warning: samba start runlevel arguments (none) do not match LSB Default-Start values (2 3 4 5)
update-rc.d: warning: samba stop runlevel arguments (none) do not match LSB Default-Stop values (0 1 6)
Disabling system startup links for /etc/init.d/samba ...
Removing any system startup links for /etc/init.d/samba ...
/etc/rc0.d/K19samba
/etc/rc1.d/K19samba
/etc/rc2.d/K80samba
/etc/rc3.d/K80samba
/etc/rc4.d/K80samba
/etc/rc5.d/K80samba
/etc/rc6.d/K19samba
Adding system startup for /etc/init.d/samba ...
/etc/rc0.d/K19samba -> ../init.d/samba
/etc/rc1.d/K19samba -> ../init.d/samba
/etc/rc6.d/K19samba -> ../init.d/samba
/etc/rc2.d/K80samba -> ../init.d/samba
/etc/rc3.d/K80samba -> ../init.d/samba
/etc/rc4.d/K80samba -> ../init.d/samba
/etc/rc5.d/K80samba -> ../init.d/samba

Vafan betyder det här då?
kör sudo update-rc.d samba disable

ser ju ut som att den lägger tillbaka samba direkt efter att den tagit bort det.

Permalänk
Medlem

Är du säker på att samba har startats upp med K80?

K80 (Kill med pririty 80) ska nämligen inte starta upp samba.
S20 (Start med priority 20) som är standard gör det däremot.

Permalänk
Medlem

ingen aning :S

kör samba direkt från "orginal installationen", men jag har bestämt mig för att skita i samba. har försökt få bort det. Men likt förbannat när jag startar om datorn, så ser man att det "hoppar" till i min finder.

Men jag fattar inte varför avahi-daemons inte startar vid boot!!!!?

Permalänk
Medlem

okej, det är löst nu.

Hittade massa guider på nätet att man skulle ändra i /etc/default/avahi-daemon, men jag hade inte den på min burk!(?)

Men då gjorde jag så att jag helt enkelt skapade den och la till följaden; AVAHI_DAEMON_DETECT_LOCAL=0

Eftersom att det var problem med .local domains, som tydligen beror på felkonfigurerad ISP.

Nu har jag netatalk med avahi up and running! Men om det är så mycket bättre än samba som folk påstår vet jag inte... har problem med att ta bort filer på servern.