Ubuntu 32/64-bitars med Atom?

Permalänk
Medlem

Ubuntu 32/64-bitars med Atom?

Min server ska få lite ny hårdvara och dessutom få dubbla som HTPC.

Moderkortet är ett ION-baserat med en Atom 330.
Releasen blir antagligen Ubuntu 9.10, men frågan är 32 eller 64-bit?
Ska köra webserver, lite databas, filserver och XBMC.

Finns det några fördelar med att köra 64-bit på den här nivån?

Permalänk
Medlem

Atom är väl endast 32-bit?

EDIT: Fel av mig, 330:n verkar ha det.

Permalänk
Medlem

64-bit tenderar väl att använda lite mer minne jämfört med 32-bit.

Jag skulle nog själv använt 32-bit om jag skulle lagt in den, på en såpass "klen" burk.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Schrimp
64-bit tenderar väl att använda lite mer minne jämfört med 32-bit.

Jag skulle nog själv använt 32-bit om jag skulle lagt in den, på en såpass "klen" burk.

Varför då?

Permalänk
Medlem

Det känns som att det skulle vara mindre tungt, med tanke på minnet.
Jag la in 32-bit på min htpc, med 2GB ram t.ex.

Dom är väl ganska likvärdiga i prestanda på en mindre burk, men det känns inte som att 32-bit försvinner inom den närmaste tiden. Det var väl lite magkänsla bara..

Permalänk
Medlem

64-bit är väl bra om man har 4GB RAM eller mera eftersom 32-bit inte kan adressera mer än 4 GB.

Permalänk
Permalänk
Medlem

Sålänge du inte behöver kunna använda flash perfekt tycker jag du borde köra 64bit, just för att det ger bättre prestanda.

EDIT:
http://www.phoronix.com/scan.php?page=article&item=ubuntu_32_...

Permalänk
Medlem

Ok, det verkar väga ganska jämt mellan 32/64-bit.

Eftersom jag varken ska köra jättekrävande applikationer eller ha mer än 4Gb minne så tror jag det blir 32bit ändå.

Tack för tipsen.

Permalänk
Medlem

64bit helt klart. Går att köra 64bit på under 100mb ram, så känner själv att det inte finns någon större anledning att välja den något segare 32bit utgåvan.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av rool
Ok, det verkar väga ganska jämt mellan 32/64-bit.

Eftersom jag varken ska köra jättekrävande applikationer eller ha mer än 4Gb minne så tror jag det blir 32bit ändå.

Tack för tipsen.

Kollade du min länk? Skulle inte kalla det jämt.

Permalänk
Inaktiv

Vad är det för fel på flash på 64-bitars? Funkar rätt bra på min 1,3 ghz cpu... Inga problem på wtso.net iaf, det enda som räknas

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av KlavKalashj
Vad är det för fel på flash på 64-bitars? Funkar rätt bra på min 1,3 ghz cpu... Inga problem på wtso.net iaf, det enda som räknas

Mitt flash fungerar inte perfekt iaf (UL30A, 1,3ghz cpu). Knappar som inte funkar ibland, fullscreen lyder inte alltid, allmänt ostabilt. Kör du med flash från ubunturepot?

Permalänk
Medlem

Flash fungerar väl inte riktigt bra i linux oavsett?

Permalänk
Medlem

För XBMC brukar man rekommendera 32-bit (eftersom det är 32-bit ubuntu som supportas av utvecklarna). Men det kan ju funka bra ändå i 64-bit trots det...

Permalänk
Inaktiv
Citat:

Ursprungligen inskrivet av MarcusW
Mitt flash fungerar inte perfekt iaf (UL30A, 1,3ghz cpu). Knappar som inte funkar ibland, fullscreen lyder inte alltid, allmänt ostabilt. Kör du med flash från ubunturepot?

Segt, jag har samma dator, och upplever det som rätt bra faktiskt på wtso.net funkar det oftast perfekt, dom har lite olika spelare men de 3 vanligaste funkar bra. På Youtube kan jag inte köra HQ, och oftast inte heller i fullskärm, men det hade jag nog inte gjort ändå, hänger inte där så mycket. Vanliga videos där går iaf perfa.

Ok, inser nu att jag kanske överdrev lite, men man kan väl sammanfatta att så länge det inte är fullskärm och/eller HQ så är det inga problem. Fullskärm går på vissa sidor

Citat:

Ursprungligen inskrivet av ronnylov
För XBMC brukar man rekommendera 32-bit (eftersom det är 32-bit ubuntu som supportas av utvecklarna). Men det kan ju funka bra ändå i 64-bit trots det...

XBMC funkar ok på min dator (UL30A, fortfarande, och x86_64). Vissa tillägg krashar dock.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Schrimp
64-bit tenderar väl att använda lite mer minne jämfört med 32-bit.

Jag skulle nog själv använt 32-bit om jag skulle lagt in den, på en såpass "klen" burk.

sluta lev på 90talet och sprid propaganda om det.
det är sånna som du som är bakåtsträvare och kör säkert iso8859-X.
Här på 2000-2010 har vi 64bitar som funkar bra och vi kör unicode.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Breddas
Flash fungerar väl inte riktigt bra i linux oavsett?

Jodå, håller man sig till låg upplösning (720p) så funkar det perfekt.

Permalänk
Medlem

Jag har byggt en linuxserver med ION och Atom330.

Jag har valt att köra med 64 bitars ubuntu server edition, funkar klockrent.

Tyvärr så stöder inte ION "Memory Remapping" (i alla fall inte ASUS AT3N7A-I)

vilket innebär att sätter du i maximalt med minne som ION stöder dvs 4Gb, så kan du inte använda mer än ca 3.5Gb, även med 64 bitars Ubuntu.

Så den största fördelen med 64bit OS på ION/atom330 försvinner. Det fick jag surt erfara.
Bortsett från det så fungerar som sagt 64bitars Ubuntu lika bra som 32 bitars Ubuntu.

Och flash finns ju som 64bit till linux som det redan påpekats.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av spaam
sluta lev på 90talet och sprid propaganda om det.
det är sånna som du som är bakåtsträvare och kör säkert iso8859-X.
Här på 2000-2010 har vi 64bitar som funkar bra och vi kör unicode.

Oj, det var ett krystat inlägg.
Kan du komma med lite belägg för varför han ska använda 64-bit, mer än att det är modernare än 32-bit, istället för att hoppa på mig?

Tagga ner lite så ska jag förklara mig..

Jag menade inte att propagera för något, och om du läst min info, så hade du sett att jag kör 64-bit och har gjort sedan Ubuntu släppte 7.04.

Jag försöker bara se det lite objektivt.. 32-bitars stöds och utvecklas. Och du får hemskt gärna motbevisa mig i att en 64-bitars normalinstallation tar mer ram än en 32-bit dito.
På en arbetsstation så tycker jag absolut man ska satsa på 64', men nu är detta ingen arbetsstation..

Att flash funkar eller ej verkar ganska irrelevant, då TS ska ha ett OS till en fil-/web-/databasserver, samt XBMC.
Men som sagts, det finns och fungerar till både 32/64-bit.

Som jag nämnt tidigare, har jag en XMBC-dator som jag har Ubuntu 9.04 med XBMC på, och den fungerar helt klanderfritt. Jag ser inga som helst fördelar på den datorn, med ett 64-bits Ubuntu istället.

Permalänk
Medlem

Nu har jag lagt in Ubuntu 9.10 men det är en sak som vägrar fungera.

Nätverkskortet får ingen IP-adress. Jag hade samma problem på min förra server med Ubuntu 9.04 och ett Intel Gbit-kort.

Det ligger där om man kör ifconfig men det har ingen IP-information, varken v4 eller v6.
Jag provade att sätta ett statiskt IP men det går inte in.

Kan det vara så att den inte identifierat kortet korrekt? Drivrutiner?
Det inbyggda wlanet fungerar bra.

Permalänk
Medlem

Vad säger exempelvis

$ ip link

?
Hur ser din /etc/network/interfaces ut?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av pr0xy
Jodå, håller man sig till låg upplösning (720p) så funkar det perfekt.

Precis, fungerar inte bra Sedan videotearing och skit

Permalänk
Medlem

Ok, problemet var autoconfigure till 1000Mbit. Ställde till statiskt 100 full duplex och då fungerar det. Undrar varför det strular?

Permalänk
Citat:

Ursprungligen inskrivet av Breddas
Flash fungerar väl inte riktigt bra i linux oavsett?

Typisk FUD från en MS-fanboy.

Permalänk
Medlem

Ok, felsökningen avslutad.

Problemet är min Linksys Gbit-switch.
Den klarar inte att autokonfigurera 1000Mbit så länken går inte upp. Enda stabila valet är att sätta 10Mbit statiskt.

Jävla skitgrej, blir att åka och shoppa en ny.

Med kabeln rakt in i Modem eller Router så går länken upp direkt på 1000Mbit...

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av frankwhite
Typisk FUD från en MS-fanboy.

Det är skilnad på att fungera och perfekt. Många verkar acceptera smärre fel.

Permalänk
Inaktiv
Citat:

Ursprungligen inskrivet av frankwhite
Typisk FUD från en MS-fanboy.

Han har ju rätt Varken i OSX eller GNU/Linux fungerar det riktigt bra. Det fungerar, men inte mer... Det är därför man vill ha html5. Och helst med en friare kodek än h.264, men vafan, man kan inte få allt

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av KlavKalashj
Han har ju rätt Varken i OSX eller GNU/Linux fungerar det riktigt bra. Det fungerar, men inte mer... Det är därför man vill ha html5. Och helst med en friare kodek än h.264, men vafan, man kan inte få allt

Vad är det som inte fungerar perfekt?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av rool
Nu har jag lagt in Ubuntu 9.10 men det är en sak som vägrar fungera.

Nätverkskortet får ingen IP-adress. Jag hade samma problem på min förra server med Ubuntu 9.04 och ett Intel Gbit-kort.

Det ligger där om man kör ifconfig men det har ingen IP-information, varken v4 eller v6.
Jag provade att sätta ett statiskt IP men det går inte in.

Kan det vara så att den inte identifierat kortet korrekt? Drivrutiner?
Det inbyggda wlanet fungerar bra.

Jag hade problem med drivrutinen till mitt Intel D945GSEJT.
Det kortet hade ett gbit-kort från realtek tror jag.
citerar mig själv från en annan tråd:

Citat:

Ursprungligen inskrivet av Rusiak
Fick hem ett D945GSEJT i helgen men hade en del problem med att installera Debian (lenny) på den.
Hittade efter lite googlande att det är nått knas med drivrutinen för det inbyggda nätverkskortet. Det ser ut som kortet hittas men jag kunde inte få en ip av DHCP servern från min router.
Löste det genom att köra ett nätverkskort i pci-platsen vid installationen för att sedan kompilera en ny version av drivrutinen för det interna kortet.

Tänkte bara informera ifall det är någon annan som har problem med DHCP och det interna nätverkskortet.