Ingen boot efter installation

Permalänk
Medlem

Ingen boot efter installation

Hej!
Gjorde fegis-installationen av Ubuntu 9.10 i Windows Vista. Efter ett tag startar datorn om och installationen fortsätter i Ubuntu. Så långt allt frid och fröjd. Därefter startar datorn om igen och jag kommer till en meny - Vista eller Ubuntu. Jag väljer Ubuntu och kommer till ännu en meny - normal Ubuntu, Ubuntu recovery, eller Vista. Jag väljer normal Ubuntu och datorn hänger sig. Väljer jag Ubuntu recovery kommer jag till en prompt, inte in i GUI. Vista funkar som vanligt. Samma sak varje gång. Vad göra?

Permalänk
Medlem

Re: Ingen boot efter installation

Citat:

Ursprungligen inskrivet av thompo
Hej!
Gjorde fegis-installationen av Ubuntu 9.10 i Windows Vista. Efter ett tag startar datorn om och installationen fortsätter i Ubuntu. Så långt allt frid och fröjd. Därefter startar datorn om igen och jag kommer till en meny - Vista eller Ubuntu. Jag väljer Ubuntu och kommer till ännu en meny - normal Ubuntu, Ubuntu recovery, eller Vista. Jag väljer normal Ubuntu och datorn hänger sig. Väljer jag Ubuntu recovery kommer jag till en prompt, inte in i GUI. Vista funkar som vanligt. Samma sak varje gång. Vad göra?

Kolla loggen under /var/log

Permalänk
Medlem

Om du har ATI eller nVidia skulle jag nog köra "rm /etc/X11/xorg.conf" i prompten du kommer till med recovery mode. (kanske inte hjälper, men gör inte mer skada än att du kanske måste installera om drivrutiner till grafikkortet)

EDIT: Aha, missförstod nog först. Du har inte kunnat boota in i Ubuntu en enda gång?

Permalänk
Medlem

Installera om ubuntu? Utan att köra med "fegis-installation"? Har du ett usb minne så fomatera det bara till FAT32, sen ladda du ner detta;
http://unetbootin.sourceforge.net/

Sedan så väljer du bara ubuntu så installeras ett bootbart ubuntu på usb-minnet. Sedan så bootar du bara upp från usb minnet och installerar det. Måste vara enklaste sättet.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Geckod
Installera om ubuntu? Utan att köra med "fegis-installation"? Har du ett usb minne så fomatera det bara till FAT32, sen ladda du ner detta;
http://unetbootin.sourceforge.net/

Sedan så väljer du bara ubuntu så installeras ett bootbart ubuntu på usb-minnet. Sedan så bootar du bara upp från usb minnet och installerar det. Måste vara enklaste sättet.

Jag har kört Ubuntu som "live-cd", fast med USB via UNetbootin som du föreslår, men inte installerat det den vägen. Är detta bättre än "fegis-varianten". Kan jag fortfarande ha kvar Vista parallellt?

Permalänk
Medlem

Re: Re: Ingen boot efter installation

Citat:

Ursprungligen inskrivet av Jilted82
Kolla loggen under /var/log

Hittar inte /var/log. Var ligger den?

Permalänk
Medlem

Re: Re: Re: Ingen boot efter installation

Citat:

Ursprungligen inskrivet av thompo
Hittar inte /var/log. Var ligger den?

/var/log är en en sökväg, där i ligger loggarna, kolla systemloggen och messages.

Permalänk
Medlem

Re: Re: Re: Re: Ingen boot efter installation

Citat:

Ursprungligen inskrivet av Jilted82
/var/log är en en sökväg, där i ligger loggarna, kolla systemloggen och messages.

Jo, det förstod jag. Men jag hittar inte katalogerna.
Såhär ser katalogstrukturen ut:
Ubuntu
|-disks-boot-grub
|-install
|-winboot

Permalänk
Medlem

Re: Re: Re: Re: Re: Ingen boot efter installation

Citat:

Ursprungligen inskrivet av thompo
Jo, det förstod jag. Men jag hittar inte katalogerna.
Såhär ser katalogstrukturen ut:
Ubuntu
|-disks-boot-grub
|-install
|-winboot

Du måste antagligen mounta din disk först.

fdisk -l

Listar dina partitioner

mount -t filsystem /target/folder /dev/sdX

Permalänk
Medlem

Okej, nu har jag gjort en riktig installation som Geckod rekomenderade. Fortfaranade samma sak vid boot.

Har hittat messages-loggen. Sista raderna:
Feb 10 18:49:47 Butterstreet-burken kernel: [ 33.568810] ppdev: user-space parallel port driver
Feb 10 18:52:35 Butterstreet-burken kernel: Kernel logging (proc) stopped.

Sista raderna i syslog:
Feb 10 18:50:09 Butterstreet-burken console-kit-daemon[883]: WARNING: Couldn't read /proc/842/environ: Failed to open file '/proc/842/environ': No such file or directory
Feb 10 18:52:35 Butterstreet-burken kernel: Kernel logging (proc) stopped.

Vad menas?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av thompo
Okej, nu har jag gjort en riktig installation som Geckod rekomenderade. Fortfaranade samma sak vid boot.

Har hittat messages-loggen. Sista raderna:
Feb 10 18:49:47 Butterstreet-burken kernel: [ 33.568810] ppdev: user-space parallel port driver
Feb 10 18:52:35 Butterstreet-burken kernel: Kernel logging (proc) stopped.

Sista raderna i syslog:
Feb 10 18:50:09 Butterstreet-burken console-kit-daemon[883]: WARNING: Couldn't read /proc/842/environ: Failed to open file '/proc/842/environ': No such file or directory
Feb 10 18:52:35 Butterstreet-burken kernel: Kernel logging (proc) stopped.

Vad menas?

Vid närmare undersökning visade det sig att raderna ovan loggades då jag startade i recovery-mode. Då jag försöker boota Ubuntu normalt loggas inget alls. Med andra ord tvärhänger sig datorn direkt efter Grub.

Permalänk
Medlem

Vad händer om du i recovery mode skriver "startx"?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av MarcusW
Vad händer om du i recovery mode skriver "startx"?

Då startar Ubuntu
Nu har jag installerat alla uppdateringar systemet föreslår, samt ny drivrutiner för grafikkortet. Men datorn hänger sig fortfarande på samma sätt vid uppstart

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av thompo
Då startar Ubuntu
Nu har jag installerat alla uppdateringar systemet föreslår, samt ny drivrutiner för grafikkortet. Men datorn hänger sig fortfarande på samma sätt vid uppstart

Det var underligt! Det du gör när du skriver startx är ungefär samma sak som datorn verkar misslyckas med i den vanliga uppstarten, fast som root istället. (man vill inte vara inloggad i det grafiska som root) Jag har inte någon lösning på ditt problem tyvärr (förhoppningsvis har väl någon annan det) men i recovery mode kan du skriva "su <dittanvändarnamn>" och sedan "startx" så borde det grafiska starta som en normal användare iaf.

EDIT:
Kom på en sak, i recovery mode prova "service gdm start".

Permalänk
Medlem