putty windows + ubuntu server går inte!

Permalänk
Medlem

putty windows + ubuntu server går inte!

Hejsan!
Har länge haft en ubuntu server som kör torrenflux-b4rt och har alltid funkat att använda putty i windows för att ssh'a. Men sen jag installerade om servern för ca 8mån sen så har jag inte kunnat komma in på servern genom windows.

Har nyss updaterat till nyaste ubuntu server (9.10) genom att använda min laptop med ubuntu på. Den går det att ssh'a igenom. Vad är felet?

Och en grej till. nu när jag uppdaterade kan jag inte logga in på torrentflux-b4rt heller. Det står bara att det är fel lösenord.

Permalänk
Medlem

Vilket felmeddelande ger putty? Kanske har en gammal host_key som spökar.

kan ju testa att rensa med: putty -cleanup (vet inte exakt vad det gör...)

rensa i: HKEY_CURRENT_USER\Software\SimonTatham\PuTTY\SshHostKeys

Kanske..

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Kejsarn
Vilket felmeddelande ger putty? Kanske har en gammal host_key som spökar.

kan ju testa att rensa med: putty -cleanup (vet inte exakt vad det gör...)

rensa i: HKEY_CURRENT_USER\Software\SimonTatham\PuTTY\SshHostKeys

Kanske..

Den säger att jag skriver fel lösenord. Fast jag inte gör det, kommer ju somsagt logga in genom laptopen i terminalen..

Vart ska jag skriva putty -cleanup?

Edit: rensade HKEY_CURRENT_USER\Software\SimonTatham\PuTTY\SshHostKeys... Ingen skillnad

edit2: googla reda på putty cleanup. har gjort det men ingen skillnad.

Permalänk
Medlem

Kanske är på servern? Nåt som inte tillåter den dator som kör putty att logga in?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Kejsarn
Kanske är på servern? Nåt som inte tillåter den dator som kör putty att logga in?

Skulle nästan tro det. Dock kan jag inte allt för mycket om linux så vet inte vart jag kollar och ändrar. Hittar inget när jag googlar heller.

Fast nu börjar jag känna paniken när jag inte kan logga in på torrenflux via webbläsaren heller. Förbannade uppdatering, trodde iaf någonting skulle bli bättre men vart ju bara värre.

Permalänk
Medlem

Kan du logga in på servern via SSH lokalt? Hur ser din /etc/ssh/sshd_config ut? Använder du åäö i ditt lösenord?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Ilja
Kan du logga in på servern via SSH lokalt? Hur ser din /etc/ssh/sshd_config ut? Använder du åäö i ditt lösenord?

Har en stor bokstav och ¤ tecken. Men kan ju logga in via laptopen (ubuntu på den) och det har fungerat förut med ¤ innan ominstallation.

sshd_config ser ut såhär:

# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes

# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes
# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

Permalänk
Medlem

Kanske testa ändra teckenupsättning i PuTTY? (UTF-8)

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Letrix
Kanske testa ändra teckenupsättning i PuTTY? (UTF-8)

¤ tecknet fungerar i putty. det kommer fram om man testar skriva det i användarnamnet. =/

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av guvvan
Har en stor bokstav och ¤ tecken.

Och där hittade vi felet. Window -> Translation -> UTF-8
Det som är tecknet ¤ i ISO-8859-1 är inte samma tecken i UTF-8.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av guvvan
¤ tecknet fungerar i putty. det kommer fram om man testar skriva det i användarnamnet. =/

Du ser det tecknet eftersom din teckentabell (ISO-8859-1) tolkar den teckenkoden som det tecknet, men när du skickar iväg det tolkas den teckenkoden av teckentabellen på mottagande datorn (UTF-8) som ett annat tecken.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Ilja
Du ser det tecknet eftersom din teckentabell (ISO-8859-1) tolkar den teckenkoden som det tecknet, men när du skickar iväg det tolkas den teckenkoden av teckentabellen på mottagande datorn (UTF-8) som ett annat tecken.

Ändrade till UTF-8 i putty nu. och det fungerar TACK!!!

Du kanske även vet varför det står att det är fel lösenord när jag försöker logga in på torrentflux. det vart nu efter updateringen, kanske är något i nån config fil för php eller så, men jag kan inte ett skit om php och websido saker