Problem med wow i ubuntu 9.10 64-bit

Permalänk
Medlem

Problem med wow i ubuntu 9.10 64-bit

Hallå jag är ny i Linux och har installerat wine och efter det WoW.
Problemet är att det är en massa "småbuggar" som jag stör mig på när jag spelar te x: kan jag inte trycka in båda musknapparna för att gå och styra, när jag har på autowalk så stannar jag när jag trycker in a/d/höger musknapp för att styra och en del fler saker.

Undrar om någon vet vad som är fel och vad som kan göras åt det.
har prövat att ändra till openGl med SET gxApi "opengl" i WTF mappen. Det funkade ett tag men senare blev allt tillbaka till det som är skrivet ovan. Har prövat att lägga in det igen men det blir samma sak.

Tack på förhand!

Permalänk
Medlem

Vilken version av wine testar du med?

Permalänk
Medlem

den nyasta 1.2 tror jag det är.

Permalänk
Medlem

Re: Problem med wow i ubuntu 9.10 64-bit

Citat:

Ursprungligen inskrivet av Freako
Hallå jag är ny i Linux och har installerat wine och efter det WoW.
Problemet är att det är en massa "småbuggar" som jag stör mig på när jag spelar te x: kan jag inte trycka in båda musknapparna för att gå och styra, när jag har på autowalk så stannar jag när jag trycker in a/d/höger musknapp för att styra och en del fler saker.

Undrar om någon vet vad som är fel och vad som kan göras åt det.
har prövat att ändra till openGl med SET gxApi "opengl" i WTF mappen. Det funkade ett tag men senare blev allt tillbaka till det som är skrivet ovan. Har prövat att lägga in det igen men det blir samma sak.

Tack på förhand!

Hm har för mig att jag hade problem med att vissa kortkommandon krockade med Gnome's, testa att inaktivera alla, tror det ska gå.

Permalänk
Medlem

Re: Re: Problem med wow i ubuntu 9.10 64-bit

Citat:

Ursprungligen inskrivet av Jilted82
Hm har för mig att jag hade problem med att vissa kortkommandon krockade med Gnome's, testa att inaktivera alla, tror det ska gå.

Som jag skrev tidigare så är jag ny i Linux:) . Skulle du kunna förklara hur man gör det?

Permalänk
Medlem

Re: Re: Re: Problem med wow i ubuntu 9.10 64-bit

Citat:

Ursprungligen inskrivet av Freako
Som jag skrev tidigare så är jag ny i Linux:) . Skulle du kunna förklara hur man gör det?

Om det är Gnome du kör (vilket det är ifall du kör vanliga Ubuntu och inte har ändrat skrivbordsmiljö ...) så finns det i menyn uppe till vänster. System -> Preferences ->Keyboard Shortcuts.

Permalänk
Hedersmedlem
Citat:

Ursprungligen inskrivet av Freako
den nyasta 1.2 tror jag det är.

1.39 är nyaste.

Finns instruktioner för hur du får senaste på wine's hemsida:
http://www.winehq.org/download/deb

// Oscar

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av SWE|OggE
1.39 är nyaste.

Finns instruktioner för hur du får senaste på wine's hemsida:
http://www.winehq.org/download/deb

// Oscar

1.1.39 är nyaste, står som wine1.2 i wine's repo. (om jag inte minns fel)

Permalänk
Medlem

Tanka wine manuellt för att vara säker att du har nyaste. Skumma problem btw, har alldrig hafft nått problem med WoW in Ubuntu.

Permalänk
Medlem

Hur mkt skillnad är det på WoW i wine å i "äkta" windows?

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av hobs0n
Hur mkt skillnad är det på WoW i wine å i "äkta" windows?

Väldigt små, det går lite segare, kanske 10 fps mindre, men samtidigt är laddningstiderna kortare.

De nya avencerade skuggorna funkar inte som de ska, om man drar upp dem så blir spelet ospelbart, men det är det enda som skiljer grafiken från windows och i wine.

Permalänk
Citat:

Ursprungligen inskrivet av Scirocco
Väldigt små, det går lite segare, kanske 10 fps mindre, men samtidigt är laddningstiderna kortare.

De nya avencerade skuggorna funkar inte som de ska, om man drar upp dem så blir spelet ospelbart, men det är det enda som skiljer grafiken från windows och i wine.

Slängde själv ut windows 7 betan förra veckan och tänkte jag skulle prova ubuntu ett tag, enda anledning till att jag körde windows var just wow. Testade ubuntu med wine för cirka ett år sedan och då var det helt ospelbart, sega laddtider, 3-5 fps.
Nu var det inga problem alls att lira, Som kommentarat ovan så skiljer sig grafiken lite, dock inget man stör sig på.
Finns faktiskt fördelar också , jag fick lägre ping i spelet så spelet svarar snabbare när man trycker på saker och även laddtiderna är nu snabbare.

Har dock ett litet problem när man blir afk i spelet eller tabbar ut till skrivbordet så fryser sig bilden, spelet verkar inte hänga sig bara bilden. Gick förbi detta med att köra wow i windowed mode men då får jag inte bild över hela skärmen.
Nån som har lösning på detta problem?

Permalänk
Inaktiv
Citat:

Ursprungligen inskrivet av Doomslayer
Slängde själv ut windows 7 betan förra veckan och tänkte jag skulle prova ubuntu ett tag, enda anledning till att jag körde windows var just wow. Testade ubuntu med wine för cirka ett år sedan och då var det helt ospelbart, sega laddtider, 3-5 fps.
Nu var det inga problem alls att lira, Som kommentarat ovan så skiljer sig grafiken lite, dock inget man stör sig på.
Finns faktiskt fördelar också , jag fick lägre ping i spelet så spelet svarar snabbare när man trycker på saker och även laddtiderna är nu snabbare.

Har dock ett litet problem när man blir afk i spelet eller tabbar ut till skrivbordet så fryser sig bilden, spelet verkar inte hänga sig bara bilden. Gick förbi detta med att köra wow i windowed mode men då får jag inte bild över hela skärmen.
Nån som har lösning på detta problem?

När jag lirar Warcraft III kör jag det i Windowed mode, helt utan problem. Öppna winecfg, lägg till ett program (wow-binären, typ wow.exe) och ha den markerad, satt inställningarna bara rör det programmet.
Gå sedan till grafiktabben och välj "emulera ett skrivbord", eller vad den nu heter, och ställ in samma upplösning som du har i desktop. Välj också denna upplösning i WoW, så borde det fungera fint.

Vet inte om det är för att inteldrivrutinerna ger mig bra kompatibilitet eller något, men jag kan snurra kuben medans jag lirar dota, inga problem alls

Permalänk
Citat:

Ursprungligen inskrivet av KlavKalashj
När jag lirar Warcraft III kör jag det i Windowed mode, helt utan problem. Öppna winecfg, lägg till ett program (wow-binären, typ wow.exe) och ha den markerad, satt inställningarna bara rör det programmet.
Gå sedan till grafiktabben och välj "emulera ett skrivbord", eller vad den nu heter, och ställ in samma upplösning som du har i desktop. Välj också denna upplösning i WoW, så borde det fungera fint.

Vet inte om det är för att inteldrivrutinerna ger mig bra kompatibilitet eller något, men jag kan snurra kuben medans jag lirar dota, inga problem alls

Tackar , ska prova detta när jag är hemma sen

*edit*

Har provat detta nu, och det funkade
Tackar och bockar för hjälpen

Permalänk
Medlem

Hallå igen har nu fixxat alla "små problem" i wow tackar för hjälpen med det:)

Men nu har jag ett nytt problem som är ganska så mycket jobbigare. Det nya problemet är att när jag drog ner den nya wow patchen idag och skulle starta om wow, så var det ett lås och ett X brevid min wow mapp. När jag försökte öppna mappen stog det "Du har inte nödvändiga rättigheter för att se innehållet i mappen World of Warcraft".

Jag provade att ta bort wow och sedan köra in det igen men det blev samma sak.

Nu undrar jag om det är någon som har eller haft samma problem och om någon vet hur jag kan fixxa till det.

Tack på förhand:)

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Freako
Hallå igen har nu fixxat alla "små problem" i wow tackar för hjälpen med det:)

Men nu har jag ett nytt problem som är ganska så mycket jobbigare. Det nya problemet är att när jag drog ner den nya wow patchen idag och skulle starta om wow, så var det ett lås och ett X brevid min wow mapp. När jag försökte öppna mappen stog det "Du har inte nödvändiga rättigheter för att se innehållet i mappen World of Warcraft".

Jag provade att ta bort wow och sedan köra in det igen men det blev samma sak.

Nu undrar jag om det är någon som har eller haft samma problem och om någon vet hur jag kan fixxa till det.

Tack på förhand:)

chown -R dittanvändarnamn:dittanvändarnamn /wowmappen

Eventuellt en

chmod -R 774 /wowmappen

Permalänk
Medlem

Nu funkar allt som det ska tackar ännu en gång:)

Permalänk
Inaktiv
Citat:

Ursprungligen inskrivet av Freako
Nu funkar allt som det ska tackar ännu en gång:)

Det du gjorde fel var nog att använda sudo någonstans, skapar du något med administratörsrättigheter så har din användare inga rättigheter där. Det är mycket logiskt och enkelt, men kanske ovant om man är van vid Windows.

Permalänk
Medlem

Enklare är att högerklicka på mappen och ta fliken rättigheter och klicka i så du har alla rättigheter. Det händer tyvärr efter vissa uppdateringar, ett nytt påhitt av blizzard verkar det som, det hände alldrig förut.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Scirocco
Enklare är att högerklicka på mappen och ta fliken rättigheter och klicka i så du har alla rättigheter. Det händer tyvärr efter vissa uppdateringar, ett nytt påhitt av blizzard verkar det som, det hände alldrig förut.

Hur tänkte du där? Är root ägare och grupp så kan han knappast göra så. Isåfall får han starta Nautilus som root.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Jilted82
Hur tänkte du där? Är root ägare och grupp så kan han knappast göra så. Isåfall får han starta Nautilus som root.

Jasså det är så jag gör iallafall efter uppdateringarna som gör mappen skrivskyddad, jag ger mig själv alla rättigheter igen och det funkar. Och jag scirocco är ägare av mappen, inte root, den blir bara skrivskyddad av uppdateringarna av nån anledning.