speaker-test fugerar, allt annat är knäpptyst

Permalänk
Avstängd

speaker-test fugerar, allt annat är knäpptyst

Hej!

Satte in ett nytt ljudkort i htpc:n, ett ESI Juli@. Linux (Ubuntu Server 9.10) hittade kortet direkt men ville inte spela upp något så jag installerade om alsa-base och alsa-utils. Rensade ur asound.conf och körde sen speaker-test -c 2 och jag hörde det underbara bruset. Då trodde jag att det var klart men jag hade uppenbarligen missat något.

Har testat från xmms2 och flash-player från youtube men det är knäpptyst. Google hittar mest folk som inte får igång ljudet alls.

Idé om vad jag kan testa?

Permalänk
Medlem

Har du ett inbyggt också? Kolla i så fall om allt ljud spelas upp på den istället.

Permalänk
Avstängd
Citat:

Ursprungligen inskrivet av Dark Defender
Har du ett inbyggt också? Kolla i så fall om allt ljud spelas upp på den istället.

Hittills har det varit lite olika, just nu spelas det dock inte upp på det inbyggda i stället. Båda är tysta och kör man speaker-test så går ljudet genom Juli@ som default.

Installerade om i dag och det är samma problem.

Det verkar som att jag inte kan köra speaker-test och aplay -l om jag inte är root, inte heller alsamixer funkar om jag inte är root.

Fan, speaker-test fungerar ju korrekt om jag är root. Vaaaarför ska det krångla såhär?

Permalänk
Medlem

Om du har tid och lust kan du ju alltid testa om det fungerar bättre med OSS4 istället för ALSA det ska finnas guider hur man byter till det från ALSA.

Permalänk
Avstängd

Är inte OSS lagt på is eller typ nedlagt? Har svårt att hitta vilka kort det stödjer o.s.v. :/

Har installerat Ubuntu Minimal och Ubuntu 10.04 nu och testat.

$ speaker-test
Playback open error: -13,Permission denied

Får det i alla versioner. Det här är ju löjligt, kortet fungerar ju uppenbarligen eftersom jag kan få brus från från det.

Permalänk
Medlem

det du tänker på är nog OSS3 som finns i kerneln och har varit död väldigt länge. Jag bytte till OSS4 då ALSA inte ville fungera som det skulle med mitt m-audio 192. Jag är hur nöjd som helst blev riktigt förvånad hur mycket lättare det var att fixa med inställningar m.m. Jag tycker också att jag får bättre ljud med oss4 också.
Testa vet ja!

Permalänk
Medlem

Låter som att användaren som vill spela upp ljudet inte är medlem i gruppen "audio".

För att lägga till den borde följande fungera, någon rätta mig annars!

sudo usermod -a -G audio DINANVÄNDARE

Permalänk
Avstängd
Citat:

Ursprungligen inskrivet av Dark Defender
det du tänker på är nog OSS3 som finns i kerneln och har varit död väldigt länge. Jag bytte till OSS4 då ALSA inte ville fungera som det skulle med mitt m-audio 192. Jag är hur nöjd som helst blev riktigt förvånad hur mycket lättare det var att fixa med inställningar m.m. Jag tycker också att jag får bättre ljud med oss4 också.
Testa vet ja!

Ska försöka med det när jag får tid över nästa gång, hittade den här guiden: https://help.ubuntu.com/community/OpenSound

Ska också testa PulseAudio tänkte jag...

Ljud och Linux verkar itne gå så bra ihop va.

Citat:

Ursprungligen inskrivet av blink
Låter som att användaren som vill spela upp ljudet inte är medlem i gruppen "audio".

För att lägga till den borde följande fungera, någon rätta mig annars!

sudo usermod -a -G audio DINANVÄNDARE

Nice! Ska testa detta i morgon

Permalänk
Medlem

Du skriver att du även har ett inbyggt ljudkort, provat stänga av det i BIOS?

Permalänk
Avstängd
Citat:

Ursprungligen inskrivet av blink
Låter som att användaren som vill spela upp ljudet inte är medlem i gruppen "audio".

För att lägga till den borde följande fungera, någon rätta mig annars!

sudo usermod -a -G audio DINANVÄNDARE

Success kära sweclockare! Nu har jag för första gången hört brus ur högtalarna inloggad som en vanlig användare Just nu har jag dock Ubuntu Alternate installerat så jag har inte testat om jag får ljud på "riktigt". Men det verkar ju onekligen som att gruppen audio är ett stort steg på vägen.

Trodde egentligen inte på detta riktigt för det interna ljudkortet spelade upp ljud utan att behöva göra såhär. Vi får se, ska installera Ubuntu Minimal nu.

Citat:

Ursprungligen inskrivet av [vEX]
Du skriver att du även har ett inbyggt ljudkort, provat stänga av det i BIOS?

Konstigt nog går det inte att stänga av helt. De vanliga utgångarna försvinner om man stänger av ljudkortet i BIOS, men HDMI-ljudet hittas alltid av aplay -l och fungerar också att spela igenom.

Edit: Det fungerade "sådär". Får efter en del meckande flashljudet och speaker-test att fungera, men xmms2 är tyst så det är något lurt.

Speaker-test är dessutom lite meckigt de första gångerna för jag får "error -2, No such file or directory".

xmms2 måste igång innan jag känner mig helt nöjd alltså. Får inga errors eller så, det låter inte bara helt enkelt.

Permalänk
Avstängd

Nu fick jag .mp3-filer att fungera tack vare moc (riktigt nice förresten).

Har upptäckt att en stor del av problemen beror på att operativsystemet upptäcker ljudkorten i olika ordning.

Ibland kan det se ut såhär:

# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 3: INTEL HDMI [INTEL HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: Juli [ESI Juli@], device 0: ICE1724 [ICE1724] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: Juli [ESI Juli@], device 1: ICE1724 IEC958 [ICE1724 IEC958] Subdevices: 1/1 Subdevice #0: subdevice #0

och ibland såhär:

# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Juli [ESI Juli@], device 0: ICE1724 [ICE1724] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: Juli [ESI Juli@], device 1: ICE1724 IEC958 [ICE1724 IEC958] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: Intel [HDA Intel], device 3: INTEL HDMI [INTEL HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0

detta gör ju att om man gör en .asoundrc eller asound.conf med

pcm.!default { type hw card 0 }

så är Juli@ default ibland medan nästa gång man startar datorn så kan INTEL HDMI vara default.

Riktigt jäkla skumt. Hade varit gött att bara kunna stänga av den interna ljudenheten helt och hållet, men nejdå.

Nåväl, nu fungerar det ju. Och fungerar det inte så är det bara att reboota tills rätt ljudkort är längst upp i listan. Men det största problemet med permission denied är ju löst. Tack blink

Permalänk
Medlem

Inga problem
Ditt sista problem borde du kunna lösa genom att "disable:a" det interna kortet(Svartlista så att drivrutinerna inte laddar för det).

Med denna länk ska du kunna lista ut hur du går till väga.
http://serverfault.com/questions/6623/how-can-i-control-which...

Permalänk
Avstängd
Citat:

Ursprungligen inskrivet av blink
Inga problem
Ditt sista problem borde du kunna lösa genom att "disable:a" det interna kortet(Svartlista så att drivrutinerna inte laddar för det).

Med denna länk ska du kunna lista ut hur du går till väga.
http://serverfault.com/questions/6623/how-can-i-control-which...

YES BOX!

Inget rackarns Intel HDMI som ligger och stör nu. Ljudet fungerar klockrent och htpc:n är så gott som färdigkonfigurerad. Helt underbart!