Problem med GRUB. Hjälp, snälla!

Permalänk

Problem med GRUB. Hjälp, snälla!

Det hela började med att jag delade upp min 160gb hårddisk till en partition som var 25GB, där tänkte jag lägga Ubuntu på (/, /home och swap) men sen så krånglade det och blev något fel. Jag gick då in i Windows 7 och jag som dum jag är helt enkelt tog bort / /home och swap och la till de i min 160gb så allt kommer till min Windows7 disk.

Nu till problemet: Grub har ju tagit över boot loadern eller något, och nu kan jag inte komma in i Windows 7 för jag får grub > no partition > rescue eller något sånt.

Hur ska jag komma för bi detta? Som tur var så la jag över de viktigaste sakerna på min nya hårddisk. Men jag har fortfarande viktigt på windows kvar.

Snälla, vet någon hur man får bort GRUB så datorn bootar i Windows 7 automatiskt?

MVH Alexander

Permalänk
Medlem
Permalänk
Medlem

Förutsatt att Win repair fungerar (gör det inte för mig då win påstår att jag inte har samma version av win som skivan har...)

http://www.tomstricks.com/how-to-repair-and-restore-windows-v...

tror att /FixMbr är vad du är ute efter.

Permalänk
Medlem

Har du samma problem som jag har med win recovery så kanske detta kan hjälpa: http://www.arsgeek.com/2008/01/15/how-to-fix-your-windows-mbr...

Lycka till!

Permalänk

Jag har provat Start Repair med Windows 7 skivan, det funkar inte.

Tack så mycket, ska prova detta!

Permalänk

Det funkar inte. Inget funkade av /FixMbr och när jag provade /FixBoot fick jag element not found.

Det verkar som jag får formatera om?

Permalänk
Medlem

Har du provat att testa Ubuntu liveCD enl länken ovan?

Permalänk

Nej håller på med det nu. Är inne i LiveCD nu. Men den hittar inte ms-sys.

Iaf, nu ska jag prova att pationera i LiveCDn och sen prova installera det igen.

Permalänk

Nej det gick inte :/

Permalänk
Hedersmedlem

Starta från Win 7 DVD'n, öppna en kommandotolk.

Där skriver du:

bootrec.exe /fixmbr

Starta om och var glad.

Permalänk

Ledsen för jag inte skrivit. Nu vet jag ju vad problemet va, tack vare swe ogge, X är ju ramminnet och jag visste inte det. Jag måste ju va i C: först.. >_>

Aja fick nya hårddiskar nu, så jag blev ju endån tvungen att installera om. Tack iallafall!