Permalänk
Medlem

Ett samba-mysterium

Helt plötsligt slutade de symboliska länkarna i min samba-share på min filserver att fungera. Jag hade inte gjort något med servern. Funktionaliteten bara upphörde helt plötsligt. Jag återställde detta genom att infoga raderna
follow symlinks = yes
wide symlinks = yes
unix extensions = no
i filen
/etc/samba/smb.conf

Det konstiga är att det funkade innan och dessutom är det ju en standardinställning (d.v.s. om raden "follow symlinks" saknas, är det "yes" som impliceras.)

Detta är nu inte längre något problem. Jag undrar bara om någon kanske vet hur detta mysterium kan ha inträffat.

Permalänk
Medlem

du har inte uppdaterat servern?

Såg att det var något strul med wide links eller vad dom kallade det i ubuntus säkerhetsrapport.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Poka64
du har inte uppdaterat servern?

Såg att det var något strul med wide links eller vad dom kallade det i ubuntus säkerhetsrapport.

Jag har automatiska säkerhetsuppdateringar på, så det är tänkbart att någon sådan drogs in under natten. Jag tror att mysteriet kan vara löst.

Permalänk
Medlem
Permalänk
Medlem

Om paketsystemet ersatt en conf-fil finns den gamla som regel kvar som <file>.dpkg-old (i apt/dpkg-baserade system). Likaså läggs nya filer in som <fil>.dpkg-dist om du vid installation väljer att behålla en gammal conf-fil.
Jag använder själv inte automatiska uppdateringar så jag har inte kollat men det borde finnas ett val för hur uppdatering av config-filer sker. Jag rekommenderar "keep old" och kör ett cron-job som skannar efter *.dpkg-dist och mailar dig när de hittas så du kan göra en manuell diff/merge om det inte är så att det finns någon mekanism implementerad för detta redan.

Permalänk
Medlem
Citat:

Ursprungligen inskrivet av Poka64
den här jag tänkte på:

http://www.ubuntu.com/usn/USN-918-1

Du har rätt. Mysteriet är löst.