Warcraft 3 problem med windows 7

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Feb 2010

Warcraft 3 problem med windows 7

Hej jag köpte nyligen nya delar till min dator och installerade även windows 7, alla spel funkar perfekt men inte warcraft 3.

Installation går igenom smärtfritt, men sen när jag ska köra wc3 så får jag färgernas krig på datorn, som om grafikkortet är sönder jag hör ljudet men inget mer. Det är nytt och bra saker i datorn så det är inte problemet, jag har tittat på forums och har inte riktigt hittat nån med samma problem men jag har testat o köra med xp sp3 o vista sp2 som compatibillity mode även som administratör.
Någon som har nån ide?

Tackar för svar!

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Mar 2006

är nog inget med w7 ska du se.. sitter själv på w7 och wc3 funkar till 100% utan några problem för mig.. och behöver inte köra som admin eller i kompatibelt läge

here we go!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2008

Har du den senaste patchen installerad?
det brukar fixa det mesta ;P

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Feb 2010

Försökte installera patchen men fick upp ett meddelande: The patch could not be applied because it does not match file checksum. bla bla, men jag förstår inte riktigt hur patchen skulle kunna hjälpa eftersom jag inte ens kommer till start sida på spelet, nått är skumt.

Trädvy Permalänk
Medlem
Registrerad
Okt 2009
Citat:

Ursprungligen inskrivet av Ja011
Försökte installera patchen men fick upp ett meddelande: The patch could not be applied because it does not match file checksum. bla bla, men jag förstår inte riktigt hur patchen skulle kunna hjälpa eftersom jag inte ens kommer till start sida på spelet, nått är skumt.

testa att installera om wc3 och se om det funkar eller testa i XP mode om du har Ultimate

Stationär dator: | AMD RYZEN 7 2700X | ASUS R9 290X DCII | G.SKILL Flare X 16GB 3200MHz CL14 | ASUS PRIME X470-PRO | Samsung 970 EVO 250GB | OCZ Arc 100 240GB | Fractal Design Newton R3 600W | Microsoft Windows 10 Pro |
Microsoft Surface Pro 2
OnePlus 6

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Feb 2010

Har testat, ingen ändring.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Ja011
Försökte installera patchen men fick upp ett meddelande: The patch could not be applied because it does not match file checksum. bla bla, men jag förstår inte riktigt hur patchen skulle kunna hjälpa eftersom jag inte ens kommer till start sida på spelet, nått är skumt.

File checksum = Filen är corrupt, det kan vara antagligen WC3 eller din patch som är corrupt, är det WC3 så testa att installa om WC3, är det spelet tanka ner patchen igen.

Speldator: i7-8700k, 16GB DDR4, GTX1070
Server 1: SB 2500k, MZI -P67GD55, 32GB DDR3, Corsair MX 240GB SSD
Surface Pro 2017, Konsoler: Typ alla, Oculus Rift

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Feb 2010

Lyckades få ner senaste patchen men ingen ändring, kan det vara någon codec jag måste ladda ner?

Trädvy Permalänk
Medlem
Registrerad
Dec 2005
Citat:

Ursprungligen inskrivet av Ja011
Lyckades få ner senaste patchen men ingen ändring, kan det vara någon codec jag måste ladda ner?

Låter högst otroligt.

Har du testat att ladda ner spelet via Battle.net?

TJ08B-E | SF450 PLATINUM | MAXIMUS VII GENE | 4790K | 16GB DOMINATOR PLATINUM | 212 EVO | GTX1060 6GB

Trädvy Permalänk
Medlem
Registrerad
Jan 2009

Lägg spelet på systemhårddisken!
Det funkar inte annars!

Trädvy Permalänk
Medlem
Plats
lite här och var
Registrerad
Sep 2008
Citat:

Ursprungligen inskrivet av HampStamp
Lägg spelet på systemhårddisken!
Det funkar inte annars!

hehe, högst otroligt, själv har man kört wc3 på xp, vista, win7, på andra hdds, usb minnen och externa hårddiskar xD...

min fråga.. har du testat något annat spel?, har du installerat senaste drivrutinerna för grafikkortet, uppdaterat ditt win 7?

Dator: MSI Z77A-G45, i7 377k, Crosair 24GB, MSI 970 4G, Crucial M4 64GB, Samsung 840 250GB, Crucial MX500 1TB, WD Green 2TB, Phanteks Evolv ATX, Be-Quiet P7 550W skärm: Asus PB238Q, Acer p193w kringutrustning: Corsair k70 RGB, Logitech 603, Dynavoice D-AMP + Magic S-4 EX

Trädvy Permalänk
Medlem
Registrerad
Jul 2005

om du inte redan gjort det så regga dig på battlenet och skriv in dina wc3 nycklar: https://eu.battle.net/login/login.xml?ref=https://eu.battle.n...

därefter kan du tanka hem spelen därifrån hur många ggr du vill, fullt patchade från start. det borde fixa problemet.

i5 2500K|Sabertooth P67|Vengeance 1866 8GB|Sapphire RX 480|Essence STX|Denon AH-D2000|Samsung S27A950D|Steelseries 7G|Feenix Nascita

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av PaE:

Låter högst otroligt.

Det tyckte jag med, alltså att det lät högst otroligt att codecinstallation skulle hjälpa, men efter att ha läst kommentarerna på en youtubevideo som visade uppstartsproblem med warcraft 3 så testade jag ändå att ladda ner K-Lite Codec Pack 8.1.0 och det gjorde hela skillnaden!

Innan dess hade jag suttit i ett par timmer och försökt alla möjliga kompatibilitetslägen, att stänga av skärmsläckar- och energisparfunktioner, "disable desktop composition", ominstallera, läsa på forum osv... men det var till slut codecinstallationen som gjorde skillnaden.

Egentligen är det inte så konstigt heller eftersom spelet startar med den klassiska lilla introduktionsvideo blizzard kör i sina gamla spel. Däremot är det underligt att codecen inte installeras med spelet.