Ubuntu 9.10 / 10.04 och Dwa-140

Permalänk
Medlem

Ubuntu 9.10 / 10.04 och Dwa-140

har försökt allt jag kan för att få igång min d-link dwa-140 på ubuntu 10.04 och 9.10 under ett par dagar men klarar det inte.

kan någon hjälpa mig med det??

verkar som att andra fixar det. men är ganska ny i linux världen.

tack på förhand.

/med vänlig hälsning kenny

Permalänk
Medlem

Samma sak för mig, funkar inte. Har testat flera guider på nätet men får det inte att fungera. Använder Ubuntu 9.10.

Permalänk
Medlem

Det borde inte behövas något annat än att installera firmware-paketet (firmware-ralink) om ni kör en relativt ny kärna (2.6.31 eller senare, kolla med uname -r).

Permalänk
Medlem

Använder kernel 2.6.31-20. Har hämtat firmware för RT2870 men vet inte hur man installerar den. Innehåller en .bin fil.

Installerar man med:

sudo chmod a+x rt2870.bin

sudo ./rt2870.bin

...får man fel.

Permalänk
Medlem

Använd paketsystemet så slipper du krångel.

sudo aptitude install firmware-ralink

Annars skall bin-filen läggas i /lib/firmware/.

Permalänk
Medlem

Ok, lagt bin filen i /lib/firmware/

"sudo aptitude install firmware-ralink" tog bort 2.6.31-14 när den väl hade jobbat klart startade jag om datorn men det funkar fortfarande inte.

Permalänk
Medlem

Listar lsmod modulen? Om inte, kolla så att inte modulen är svarlistad:

grep -ir "blacklist.*rt2870" /etc/modprobe.d/

Permalänk
Medlem

Hmm, ja det gör den.

Module: Used By:
rt2x00usb rt2800usb
rt2x00lib rt2800usb, rt2x00usb

rt2x00lib och rt2800usb finns listat även på andra moduler.

Permalänk
Medlem

Hmm, den borde ladda rt2870sta.ko såvitt jag kan se. Vad säger

sudo modprobe -a rt2870sta

?
Det kan också vara värt en titt med dmesg om det loggas något intressant vid boot. En annan idé är att kolla med lspci och lsusb att kontroller och adapter hittas som de skall.

Permalänk
Medlem

"sudo modprobe -a rt2870sta" sàger inget.

dmesg: kommer upp en massa men jag ser bara dessa 2 rader som innehèller rt2870

rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
usbcore: registered new interface driver rt2870

(Kan ha med nàtverkskortet att gòra)
usb 2-8: new high speed USB device using ehci_hcd and address 6
usb 2-8: configuration #1 chosen from 1 choice

lsusb:

Bus 002 Device 005: ID 07d1:3c0a D-Link System

Systemet hittar alltsè nàtverkskortet.

Permalänk
Medlem
Skrivet av Jumbo:

Bus 002 Device 005: ID 07d1:3c0a D-Link System

Tydligen så är inte den device-ID:n tillagd till rt2870sta i 2.6.32. Enligt uppgift är det rt2800usb som gäller (enligt denna länk).
Den är visserligen experimentell men finns med i mina Debian-kärnor så Ubuntu borde också ha den.

Permalänk
Medlem

Alright, men hur kan man installera rt2800usb filen? Kör man make && make install? vad gör man sen?

Permalänk
Medlem

I Debian ingår rt2800usb.ko i standard-imagen för 2.6.31 och senare kärnor. Systemet bör automatiskt ladda den om kortet identifieras korrekt och det ser det ju ut att göra. Det enda som skall behövas utöver det är att installera firmware-paketet.
Enligt tidigare post så har du rt2800usb installerad (och laddad) eftersom den är med i output från lsmod.
Jag rekommenderar dock att du tar bort firmware-filen du laddat ner själv och installerar om firmware-ralink-paketet så du vet att du fått rätt version av firmware.
Är du säker på att inte kortet fungerar? Har du ett auto-entry för wlan0 (eller vilken enhet det nu dyker upp som, se dmesg för info)? Har du testat att köra en AP-scan med sudo iwlist scan?

EDIT: Kom på att du antagligen använder NetworkManager så bortse från vad jag skrev om auto-entry och iwlist. NetworkManager borde ta hand om det. Men jag har ingen refarenhet av (eller förtroende för) NetworkManager så någon annan får hjälpa dig med den biten.

Permalänk
Medlem
Skrivet av Jumbo:

Alright, men hur kan man installera rt2800usb filen? Kör man make && make install? vad gör man sen?

Väldigt ofta vid källkodskompliering finns det INSTALL eller README i mappen, läs den.

Generellt sett är det:

cd kodmapp
./configure
make
su
make install

Permalänk
Medlem
Skrivet av NakedApe:

I Debian ingår rt2800usb.ko i standard-imagen för 2.6.31 och senare kärnor. Systemet bör automatiskt ladda den om kortet identifieras korrekt och det ser det ju ut att göra. Det enda som skall behövas utöver det är att installera firmware-paketet.
Enligt tidigare post så har du rt2800usb installerad (och laddad) eftersom den är med i output från lsmod.
Jag rekommenderar dock att du tar bort firmware-filen du laddat ner själv och installerar om firmware-ralink-paketet så du vet att du fått rätt version av firmware.
Är du säker på att inte kortet fungerar? Har du ett auto-entry för wlan0 (eller vilken enhet det nu dyker upp som, se dmesg för info)? Har du testat att köra en AP-scan med sudo iwlist scan?

EDIT: Kom på att du antagligen använder NetworkManager så bortse från vad jag skrev om auto-entry och iwlist. NetworkManager borde ta hand om det. Men jag har ingen refarenhet av (eller förtroende för)

NetworkManager så någon annan får hjälpa dig med den biten.

Blir inte klok på detta. Har testat det du har skrivit, även andra guider på nätet men det fungerar ändå inte. Usb stickan fungerar bra i Win7 och Vista. Testade även med Ubuntu 10.4 b2 och samma sak där.
Funderar på att ominstallera 9.10 och börja om från början.

Alternativt, vilka trådlösa nätverskortet fungerar bäst med ubuntu? alltså, man skall bara köra in usb stickan och inte behöva installera drivrutiner och annat?

Fòrresten, skall man befinna sig i /lib/firmware nàr man kòr "sudo aptitude install firmware-ralink" ?

Permalänk
Medlem
Skrivet av Jumbo:

Blir inte klok på detta. Har testat det du har skrivit, även andra guider på nätet men det fungerar ändå inte. Usb stickan fungerar bra i Win7 och Vista. Testade även med Ubuntu 10.4 b2 och samma sak där.
Funderar på att ominstallera 9.10 och börja om från början.

Alternativt, vilka trådlösa nätverskortet fungerar bäst med ubuntu? alltså, man skall bara köra in usb stickan och inte behöva installera drivrutiner och annat?

Har tyvärr ingen koll på USB-donglar. Har Intel i min egen laptop och det har funkat klockrent från början så något baserat på Intel-kretsar torde vara ett rätt säkert tips. Andra kan nog bidra med fler förslag.

Skrivet av Jumbo:

Fòrresten, skall man befinna sig i /lib/firmware nàr man kòr "sudo aptitude install firmware-ralink" ?

Det är inte nödvändigt, paketsystemet ser till att allt hamnar på rätt plats ändå.

Permalänk
Medlem

Förresten, kan man uppdatera kernel via en grafisk gränssnitt? Jag menar mer som Windows Update? Har testat att uppdatera till kernel 2.6.33.2 genom att följa http://www.ubuntu-se.org/phpBB3/viewtopic.php?f=54&t=46475&st... men misslyckas.

Permalänk
Medlem

Testat ndiswrapper ?

Permalänk
Medlem
Skrivet av Can0n:

Testat ndiswrapper ?

Hmm, ja via det grafiska gränssnittet. Man lägger väl till .inf filen från windows-drivrutinerna? Följde olika forumtrådar men kan möjligtvis ha tabbat mig.

Permalänk
Medlem

ingen superhjälp men tänkte bara säga att jag haft i drfit mitt DWA-140 i Ubuntu 9.10 tidigare. installerade drivrutinerna men fick ta disabla en modul som laddades av ubuntu, efter det fungerade det.

Permalänk
Medlem

Jag har också problem med ubuntu 10.04 och dlink dwa-140. Jag har letat runt lite på nätet utan framgång. Jag kan se alla tillgängliga nätverk men jag kan inte ansluta till något, jag blir ombedd att skriva in nätverksnyckeln om och om igen... Någon som har ett lösningsförslag?

Permalänk
Medlem

Även jag har haft problem med dwa-140 i 9.10, men fick det att funka med ndiswrapper och blacklista en modul också. Kommer dock inte riktigt ihåg vilken tyvärr.