Battlefield Bad Company 2 - Anti Alising fungerar inte

Trädvy Permalänk
Medlem
Registrerad
Nov 2006

Battlefield Bad Company 2 - Anti Alising fungerar inte

Hej!

Jag har lite problem med min Anti Alising i enbart detta spelet.
Tyvärr så kan man tydligen INTE ta printscreens men troligtvis så vet ni vad jag pratar om.
"Sidorna" på tex raka väggar / stolpar / staket etc blir jätte kantiga i speciella vinklar, och när man ser andra spelare på jätte långt avstånd så ser det ut som att gubbarna har fyrkantigt huvud, kropp, armar, ben etc.

Jag anser detta väldigt frustrerande för att jag är grafiknörd, det måste se snyggt ut.

Det mest konstiga är att Anti Alising fungerar perfekt i ALLA andra spel jag har, CS, CS Source, World of Warcraft, Modern Warfare2, Alien VS Predator, The Sims 3.

Jag har ställt in i både ATI Catalyst center och inne i Battlefields settings, Anti Alising x4. Som sagt, fungerar perfekt i alla andra spel jag nämnde, varför ska det inte fungera i Battlefield? gah!

Har även testat många olika inställningar i grafik kortet och inne i spelet. men det verkar som att spelet inte reagerar någonting när man fifflar i grafik kortet, som om spelet vägrar samarbeta med grafik kortet.

Har den nyaste drivrutinen till grafik kortet, och jag antar att jag har senaste uppdateringen till spelet. annars hade jag väll inte kunnat spela online?

Jag har googlat en del ang detta problemet. Som alltid, hittar folk med samma problem, men de nämner ingen tydlig lösning efter dem fixat sitt problem.

Jag hoppas verkligen att någon kan hjälpa mig lösa detta. Jag gillar verkligen spelet. Men tappar lusten helt när grafiken inte funkar som den ska när det mest logiska är att det ska funka när inga andra spel har problem med Anti Alising.

Grafik kort:
ATI Radeon HD 5800 series

//Fredde

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Mar 2005

Har du provat att googla? Tydligen stöds anti aliasing inte med DX9 i det här spelet.

Bra, snabbt, billigt; välj två.

Ljud
PC → ODAC → Objective2 → Sennheiser HD650/Ultrasone PRO 900
Portabelt → Sennheiser Momentum/Sennheiser Urbanite XL/Sennheiser Momentum In-Ear

Trädvy Permalänk
Medlem
Registrerad
Nov 2006

Hej Phod.

Tack för ditt svar.

Japp jag har googlat en del. Men hade ingen aning om att DX hade med saken att göra, har aldrig haft problem med DX förut så jag visste inte om att det kunde störa.

Hursomhelst. Jag ändrade DX till 11, men ha fortfarande problem med anti alising inne i spelet.

Är det kanske min upplösning som är problemet? eller någon annan inställning i spelet?

[WindowSettings]
Width=1680
Height=1050
Fullscreen=true
RefreshRate=60
VSync=false
[Sound]
Quality=low
VoipEnable=true
SpeakerCount=0
[Graphics]
Effects=medium
Soldiers=medium
Vehicles=medium
Overgrowth=medium
Undergrowth=medium
StaticObjects=medium
Terrain=medium
Shadows=medium
Bloom=true
HSAO=false
MSAA=1
Water=medium
MainQuality=custom
Texture=high
DxVersion=11
Aniso=2
Detail=medium
RenderAheadLimit=2
Fov=55

Trädvy Permalänk
Medlem
Registrerad
Okt 2005

Du ska väl inte ställa in i både catalyst och spelet? Antingen eller... Sätt på software handled på AA i catalyst så löser det sig.

Burk: Asus Maximus X z370, i7 8700k @5200mhz, cache 4900mhz, Corsair Platinum ddr4 3600mhz @4266mhz quad 16gig (19-21-21-42 2t), 1st Gigabyte G1 Gaming 1080ti + EK @2070/12000mhz, Samsung 840 pro 240 gig x2 raid0, 1 tb 2.5" WD Red, Skärm: Acer x34p, TJ07 custom water, Ljud: HiFiman X v2 + EONE MK2 Muses

Trädvy Permalänk
Medlem
Registrerad
Okt 2009

Drivers & Support | GAME.AMD.COM installera senaste drivrutinerna OCH senaste ATI CrossFireX™ Application Profiles

Stationär dator: | AMD RYZEN 7 2700X | ASUS R9 290X DCII | G.SKILL Flare X 16GB 3200MHz CL14 | ASUS PRIME X470-PRO | Samsung 970 EVO 250GB | OCZ Arc 100 240GB | Fractal Design Newton R3 600W | Microsoft Windows 10 Pro |
Microsoft Surface Pro 2
OnePlus 6

Trädvy Permalänk
Medlem
Plats
Big Mellosa
Registrerad
Jun 2008
Skrivet av Socka:

Hej Phod.

Tack för ditt svar.

Japp jag har googlat en del. Men hade ingen aning om att DX hade med saken att göra, har aldrig haft problem med DX förut så jag visste inte om att det kunde störa.

Hursomhelst. Jag ändrade DX till 11, men ha fortfarande problem med anti alising inne i spelet.

Är det kanske min upplösning som är problemet? eller någon annan inställning i spelet?

[WindowSettings]
Width=1680
Height=1050
Fullscreen=true
RefreshRate=60
VSync=false
[Sound]
Quality=low
VoipEnable=true
SpeakerCount=0
[Graphics]
Effects=medium
Soldiers=medium
Vehicles=medium
Overgrowth=medium
Undergrowth=medium
StaticObjects=medium
Terrain=medium
Shadows=medium
Bloom=true
HSAO=false
MSAA=1
Water=medium
MainQuality=custom
Texture=high
DxVersion=11
Aniso=2
Detail=medium
RenderAheadLimit=2
Fov=55

Jag skulle plocka ner denna : RenderAheadLimit=0
Edit: har iof inget med ditt problem att göra...

Antec Nine Hundred; Corsair HX 750W; Gigabyte GA-X58A-UD3R; I7 950; Corsair H70; Corsair 6GB; Samsung 850 evo 250GB; GTX980; Dell U3415W; W10

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Nov 2005

Ändra FoV till FoV=65-75 (välj ett tal) det ger dig ökad syn åt sidorna i spelet. jag kör 75 och har 1680*1050. Lite offtopic..

HTPC

Trädvy Permalänk
Medlem
Registrerad
Nov 2006
Skrivet av Bad Habit:

Du ska väl inte ställa in i både catalyst och spelet? Antingen eller... Sätt på software handled på AA i catalyst så löser det sig.

Det hade jag ingen aning om. Man lär sig något nytt varje dag.

Tack för all hjälp, det funkar som det ska nu.

För de som har samma problem:

Jag ändrade till DX11 genom att ändra text i filen:
C:\Users\User\Documents\BFBC2\settings.ini

Det står: DxVersion=auto

Den ändrar man till: DxVersion=11

Sen valde jag i catalyst att använda spelets inställningar: Use application settings

Tydligen kunde man inte ha manuell inställningar i grafik kort och i spelet samtidigt..

Tack igen!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2002

jag har märkt och ser också det är samma sak hos dig.. man ställer in AA i spelet till 4 för mig tex.. men när jag kollar ini filen så står det 2 och i ditt fall står AA på 1. testa köra 8 där eller nåt där

MSAA=1 -> MSAA=8

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Apr 2008
Skrivet av Luddtuss:

Jag skulle plocka ner denna : RenderAheadLimit=0
Edit: har iof inget med ditt problem att göra...

Vad är det för nåt?:)

Phanteks Ecplipse P400 | ASUS Z270F Strix | i7 7700K | Corsair Vengeance 16GB 3200mhz | Asus GTX 1070 | Creative Sound Blaster Z | Samsung SSD 830 256GB + 850 pro 256GB | Corsair HX 850W | Windows 10 | Asus ROG Swift PG278QR | iPhone 7 plus 128GB |

Trädvy Permalänk
Medlem
Registrerad
Nov 2006
Skrivet av all-seeing:

Citat:
Ursprungligen inskrivet av Luddtuss Visa inlägg
Jag skulle plocka ner denna : RenderAheadLimit=0
Edit: har iof inget med ditt problem att göra...

Vad är det för nåt?

Jag frågade en kompis på vent, han sa att det var rendering i förväg. Jag kan inte förklara det så jätte bra, men jag tror jag förstår vad han menade iallafall.