Kan inte installera WMP9 (unsupported architecture)

Permalänk
Medlem

Kan inte installera WMP9 (unsupported architecture)

Nu håller jag på att bli vansinnig. Vill få Spotify att spela upp lokala filer genom att installera WMP9 genom winetricks. Det vill dock självklart inte fungera, utan jag får följande felmeddelande: "Trying to load PE image for unsupported architecture (AMD-64)". Detta händer med två olika versioner av winetricks som jag har testat, en vanlig och en som sades vara för 64-bit-system. Dessutom har jag fått för mig att det inte ska spela någon roll egentligen, eftersom wine är 32-bit? Snälla, hjälp mig!

Permalänk
Medlem

Läste någonstans att Spotify blockat mp3-stödet genom wine eftersom det var buggigt. Men jag minns inte vart jag läste det (spotifys sida kanske det var?) så ta det med en nypa salt Men det kan ju vara orsaken.

Permalänk
Medlem

Det ska fungera om man installerar WMP9: Ubuntu Sverige • Visa tråd - Spotify - ny version med lokalt bibliotek. Felet med WMP9 borde inte ha något med Spotify att göra.

Permalänk
Medlem

Hm.. märkligt. Jag installerade WMP9 med winetricks, följde instruktionerna i länken du gav mig och det fungerar felfritt. Har inte ens mp3-stöd inkompilerat i wine men det är väl ganska oviktigt om man explicit anger en dll för det. Vilken version av wine kör du?

Permalänk
Medlem

Jag kör Wine 1.1.42 på Ubuntu 10.04 64-bit. Jag kör kommandot "winetricks wmp9" eller enligt instruktionerna i länken men får alltså felmeddelandet ovan.

Permalänk
Medlem

Testa med nyare wine 1.2-rc1, det är den jag kör o där funka det fint WineHQ - Wine Announcement
downloadsidan finns instruktioner till hur du lägger till PPA:n till synaptics sen är det bara att köra uppdateringsprogrammet.

Permalänk
Medlem

Uppgraderade till 1.2. Samma problem...

Permalänk
Medlem

Riktigt underligt, installerade just WMP9 på båda mina 64bit Debian.

Permalänk
Medlem

Löste problemet själv nu. Jag körde PlayOnLinux, så jag avinstallerade det fullständigt och installerade om Wine 1.2. Nu verkar allt fungera som det ska.

Permalänk
Medlem
Skrivet av MrPasty:

Löste problemet själv nu. Jag körde PlayOnLinux, så jag avinstallerade det fullständigt och installerade om Wine 1.2. Nu verkar allt fungera som det ska.

Aha! Bra o veta Skönt det fungerar nu iaf!