Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jun 2010

Problem med USB i GA-MA785GMT-UD2H

Hej
Jag har bytt moderkort till en Gigabyte GA-MA785GMT-UD2H men USB-portarna på själva kortet verkar inte fungera, däremot fungerar två "externa" USB-portar någotsånär som jag har kopplat in via F_USB1-kontakten på moderkortet.

Om jag t.ex. provar att flasha BIOS med ett USB-minne så kan jag bara använda de externa usb-portarna, samtliga portar som finns direkt på moderkortet fungerar inte.

Vad innebär det här? Är det nya moderkortet kasst?

Jag har provat att ta ut batteriet ur moderkortet och på så vis nollställa CMOS, men ingen förbättring. Inte heller hjälper det att flasha senaste BIOSen.

Från Linux kan jag på samma sätt se usb-minnet helt ok via de externa portarna, men usb-minnet går inte att se på de övriga portarna. Men det konstiga är att jag har en ps/2-mus (via ps2-usb adapter) som Linux i alla fall reagerar på när jag pluggar in den i portarna på moderkortet, dock får jag ett felmeddelande.

[11933.276124] hub 1-0:1.0: Cannot enable port 3. Maybe the USB cable is bad?

Någon som vet vad som kan vara fel och hur jag fixar det?

Om det bara är en fråga om att konfigurera Linux så klarar jag av det, men jag tänkte kolla först om felet är på en lägre nivå än så.

Tips och förslag mottages gärna!

Trädvy Permalänk
Medlem
Plats
Falkenberg
Registrerad
Dec 2007

Det är lite förvirrande att förstå vad du menar.
1. Baktill på moderkortets uttagspanel finns 6 st USB portar. Fungerar ingen eller alla dessa ?

2. Inne i datorn på moderkortets framsida finns 3 st dubbla (6st) USB portar för ytterligare tilläggspaneler eller interna kortläsare. Fungerar ingen eller alla dessa ?

När man byter moderkort och då även anpassningspanelen baktill så kan det hända att de tunna plåtflikarna runt hålen av misstag petar in i uttagen i stället för att ligga an mot ovansidan av kontakthöljet. Kolla detta.

Windows 10 Pro x64 | Zalman HD160XT Plus | Fractal Design 800W | AMD Ryzen 7 1800x | Asus Crosshair VI Hero | Corsair Vengeance LPX 3200MHz 16GB | ASUS Radeon R9 290 4.5GHz | Samsung SSD M.2. 960 Pro. 1TB | Philips Brilliance 40" BDM4065

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jun 2010

Hehe jo jag inser att jag uttryckte mig lite förvirrat. Strunta i vad jag sagt om ps/2-musen så länge och fokusera på följande:

Ja, baktill på moderkortets panel sitter 6 USB-portar. Ingen av dessa tycks fungera utan OS. Alltså om jag använder någon av dessa 6 portar för att försöka flasha BIOS med ett USB-flashminne så går det inte. Men om jag bootar i Linux så kan jag använda portarna, mounta USB-minnet osv.

Moderkortet har inga fler USB-portar än så, men på datorchassits front finns två inbyggda USB-portar med en sladd som jag kan koppla in på moderkortet. Då fungerar dessa "externa" USB-portar, även utan OS. Och tack vare det så kan jag flasha BIOS till senaste versionen, men det hjälper inte och de 6 "interna" USB-portarna funkar fortfarande inte (bara från Linux).

Trädvy Permalänk
Medlem
Plats
Falkenberg
Registrerad
Dec 2007

Enligt manualen så styrs samtliga 12 USB portar från samma controller.
I BIOS under "Integrated Peripherals" finns alla USB inställningar som kan ändras.
(Standard inställning är: USB Mouse Support [Disabled])

Jag kan se alla mina USB-portars anslutningar i BIOS flashminnesprogram (inkl. systemdisken).
Så var ansluter du ditt USB-tangentbord... i fronten ? eller kör du med ett gammalt PS/2 ?

Windows 10 Pro x64 | Zalman HD160XT Plus | Fractal Design 800W | AMD Ryzen 7 1800x | Asus Crosshair VI Hero | Corsair Vengeance LPX 3200MHz 16GB | ASUS Radeon R9 290 4.5GHz | Samsung SSD M.2. 960 Pro. 1TB | Philips Brilliance 40" BDM4065

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jun 2010

Nu har jag installerat OS och alla USB-portar funkar bra så faran är över. Ändå lite mysko att det inte funkar i BIOS, men det kan jag leva utan.

Jag använde ett ps/2 tangentbord i den enda ps/2-porten, vilket funkade bra. ps/2-musen gick alltså inte via ps/2-usb-adapter så nu har jag bytt ut den mot en billig usb-mus som funkar fint.

Tack för hjälpen ändå! Jag är skitnöjd med datorn.