.xinitrc fungerar inte med Ubuntu 10.04?

Permalänk
Medlem

.xinitrc fungerar inte med Ubuntu 10.04?

Hej allihopa, jag håller på att försöka lösa en skoluppgift där de vill att vi ska skapa en .xinitrc fil i /home för att bland annat kunna starta X utan en fönsterhanterare.

Mitt problem är följande:

Jag har skapat en fil med pico som heter .xinitrc i /home, den har exekveringsrättigheter.
Filen har bara en väldigt basic config:

#kommentarer

xterm &

xclock -geometry +200+400 &

xterm -geometry +400+250

Och sen är tanken att man ska starta den med "startx &", och har även testat med "sudo startx &".

Jag får felmeddelanden om:

xauth: error in locking authority file

Fatal server error - server is allready active for display 0

ddxSigGiveUp: Closing log.

edit: har även testat att använda "ln -s .xinitrc .xsession"

Jag uppskattar all hjälp jag kan få..

Permalänk
Medlem

Den skall ligga i din hemmamapp, inte i /home direkt.

Permalänk
Medlem

Testade att flytta filen till /home/användare/ och fortfarande ingen skillnad.

Permalänk
Skrivet av Xeon404:

Fatal server error - server is allready active for display 0

Betyder ju att du redan har en X-server körandes...

Permalänk
Medlem

När jag kör "sudo startx &" direkt efter start efter att ha gått över till textbaserat helt med ctrl+alt+F1 så startar det. Men jag får bara en svart skärm utan prompt och inte alls xlock xterm efter mina specifikationer i .xinitrc.

Behöver jag göra ngt mer än att skapa filen på rätt plats och ange startx & för att få det att fungera.

Tanken är jag ska starta x utan fönsterhanterare och sedan med andra fönsterhanterare och lite sådant.

Permalänk
Medlem

Kan du inte I inloggingshanteraren (GDM) välja att starta en .xinit session istället för gnome? Så slipper du hålla på med startx osv

Permalänk
Hedersmedlem

Du kan starta en X-server på en annan display med

startx -- :1

för att starta display 1. Den kommer lägga sig på tty8 som standard, dvs du kan komma åt den genom att trycka Ctrl+Shift+F8 (display 0 kommer du åt genom Ctrl+Shift+F7).

Använder inte .xinitrc så ofta längre dock, men måste du inte ha en "exec"-rad? det är det som står på denna rad som bestämmer när servern ska avslutas, så om man inte har en sådan så kanske den avslutas direkt.

Testa t ex en ~/.xinitrc med innehåll

xclock -geometry +200+400 & exec xterm -geometry +400+250

så borde sessionen stängas av när du stänger xterm.

Din .xinitrc måste inte ha rättigheter för att vara exekverbar tror jag btw, men det skadar inte heller.

startx måste du inte köra med sudo heller.

Permalänk
Medlem

Jag editerade gdm.conf och såg därmed till att ubunt startar i textbaserat läge, när jag då använder "startx &" så blir skärmen först helt svart och efter en stund skriver den ut

"no protocol specified"
xinit: resource temporarily unavailable (errno 11): osv

waiting for x server to shut down ddxSigGiveUp: closing log

xinit: server error

xauth: error in locking authority file /home/xeon/.Xauthority

Permalänk
Medlem

Om man skriver sudo först så blir man ju root-användaren som kör efterföljande kommando och då använder den väl filer i /root istället för i /home/användare. Så prova köra inloggad som din användare och inte köra sudo.

Permalänk
Medlem

FYI för att stänga av X kan du köra "sudo service gdm stop" efter du gått till en annan TTY.

Permalänk
Hedersmedlem
Skrivet av MarcusW:

FYI för att stänga av X kan du köra "sudo service gdm stop" efter du gått till en annan TTY.

Ha, har inte vetat om kommandot service Har alltid bara kört med motsvarande "sudo /etc/init.d/gdm stop", vilket är samma sak, men krångligare att skriva. Har funderat på varför det inte funnits något smidigare sätt att sköta tjänsterna, men tydligen inte tillräckligt mycket för att ens googla på det...

On topic så kan man väl sammanfatta saker som:
-Skapa ~/.xinitrc med korrekt innehåll (en exec-rad).
-Stoppa GDM: "sudo service gdm stop" och logga in som vanlig användare (den användare i vilkens hemkatalog .xinitrc skapades) i textläge.
-Kör "startx", enbart (inte "sudo", inte "&" etc.).

Permalänk
Medlem

Hejsan jag får ursäkta om ja kapar denna tråden men jag tycker att min fråga har lite med ämnet att göra. Varför funkar inte Crtl + Alt + backspace längre i det nya ubuntu för att döda X tycker att detta är pest då man ibland är i behov att bara kunna döda X om något har låst sig eller av någon annan anledning. Kan man på något sätt aktivera detta igen ?

Permalänk
Medlem
Skrivet av t0ddan:

Hejsan jag får ursäkta om ja kapar denna tråden men jag tycker att min fråga har lite med ämnet att göra. Varför funkar inte Crtl + Alt + backspace längre i det nya ubuntu för att döda X tycker att detta är pest då man ibland är i behov att bara kunna döda X om något har låst sig eller av någon annan anledning. Kan man på något sätt aktivera detta igen ?

Det är nog främst för att folk inte ska göra det av misstag. Kan man inte använda SysRq + K för samma effekt?

Permalänk
Hedersmedlem
Skrivet av t0ddan:

Hejsan jag får ursäkta om ja kapar denna tråden men jag tycker att min fråga har lite med ämnet att göra. Varför funkar inte Crtl + Alt + backspace längre i det nya ubuntu för att döda X tycker att detta är pest då man ibland är i behov att bara kunna döda X om något har låst sig eller av någon annan anledning. Kan man på något sätt aktivera detta igen ?

System->Preferences->Keyboard->Layouts->Options->"Key sequence to kill the X server"->Kryssa i