Permalänk
Medlem

Intel P55 och Linux

Hej alla Linuxälskare,

Går och funderar på att uppgradera lite hårdvara och undrar om nån av er har
stött på problem med P55 chipset?
På de flesta mobos jag spanat in, används även kretsen Realtek RTL8111DL för
LAN... jag har bara sett att Realtek RTL8111 E verkar vara problemfri (Arch
Linux) men vet nån hur läget är idag för Realtek RTL8111DL?
Och så har vi lm_sensors som för mig är viktig att den fungerar...
funkar den i kernel 2.6.35.5-1 tillsammans med moderna (nåja, det är ju relativt)
kretsar som finns idag? Jag googlade lite och fann lite äldre info om Lm_sensors tyvärr.

Och till sist, Kimtjik (tror jag), du skrev vid nåt tillfälle att du på ett smidigt sätt
flyttade över en hårddisk med Archlinux till en komplett ny hårdvara utan att
behöva manuellt konfigurera nåt.. jag har läst i Archforum att man behöver konfigga
lite här och där men det stämmer alltså inte?

Tack!

Permalänk
Inaktiv

Angående hårddiskflytt, det bör fungera rakt av, eftersom systemet känner av vilken hårdvara som finns vid uppstart, och laddar de nödvändiga drivrutinerna rakt av. Med lite tur fungerar det perfekt direkt, om du får problem så går det att lösa. Vad gäller P55 har jag ingen aning, men har aldrig stött på ett nätverkskort som inte fungerat direkt.

Permalänk
Medlem

Tuta och kör. Realtek trådbundna kort brukar funka bra och intelhårdvara har väldigt sällan problem. Processortempen hämtas väll via coretemp tjosanet så det funkar nog finfint. Jag skulle verkligen inte oroa mig. Det enda som brukar kunna bråka ibland är väll knarkade ACPI-grejer och knasiga wlan-kort. Det första går ju att disabla och det andra verkar du ju inte ha. Men båda dem är i sällsynta fall. Du kan ju alltid prova att boota med någon livelösning om du vill men jag kan nästan sätta kungens liv på att det bara är att tuta och köra utan problem.

Permalänk
Medlem
Skrivet av anon84089:

Angående hårddiskflytt, det bör fungera rakt av, eftersom systemet känner av vilken hårdvara som finns vid uppstart, och laddar de nödvändiga drivrutinerna rakt av. Med lite tur fungerar det perfekt direkt, om du får problem så går det att lösa. Vad gäller P55 har jag ingen aning, men har aldrig stött på ett nätverkskort som inte fungerat direkt.

Tack för tipset. Jag får hem hårdvarorna imorrn tror jag och återkommer med resultatet! ^^
(hm, det var kanske du som skrev om hårddiskflytt med Arch?)

Permalänk
Medlem
Skrivet av tolle:

Tuta och kör. Realtek trådbundna kort brukar funka bra och intelhårdvara har väldigt sällan problem. Processortempen hämtas väll via coretemp tjosanet så det funkar nog finfint. Jag skulle verkligen inte oroa mig. Det enda som brukar kunna bråka ibland är väll knarkade ACPI-grejer och knasiga wlan-kort. Det första går ju att disabla och det andra verkar du ju inte ha. Men båda dem är i sällsynta fall. Du kan ju alltid prova att boota med någon livelösning om du vill men jag kan nästan sätta kungens liv på att det bara är att tuta och köra utan problem.

Jag har aldrig använt realtek, men på deras hemsida finns blob-drivrutiner att ladda ner för Linux (vilket jag vill undvika så långt det går).

Vad gäller LM_Sensors, så är det lite oklart om kretsarna hittas ordentligt. Senast i januari på Phoronix så menade testarna att de inte stöds än.

55 kretsen har ju varit ute att bra tag nu, så det vore förvånande om kernelutvecklarna inte fixat det än.
Jag ska testa!

Permalänk
Medlem

Det verkar som att man bör ta bort "autodetect" i Hooks (mkinitcpio.conf) och köra en mkinitcpio -p kernel26 innan man stänger ner sitt gamla system.
Sen kan man lägga dit "autodetect" efteråt och köra (?) mkinitcpio -p kernel26 igen.

Permalänk
Medlem

stödet för lm-sensors beror på vilket sensorchip som sitter på kortet (vanligtvis något Winbond/Nuovoton). Många av de som används till P55 kort har inte linux-stöd än, men det kommer med tiden.

Permalänk
Medlem
Skrivet av pingy:

stödet för lm-sensors beror på vilket sensorchip som sitter på kortet (vanligtvis något Winbond/Nuovoton). Många av de som används till P55 kort har inte linux-stöd än, men det kommer med tiden.

Mm, märkte det när jag körde 'sensors-detect', att inget hittades.
Det märkliga är dock att processorns kärnor/temps hittas som vanligt när jag kör 'sensors'. Däremot inga volt eller fläkthastigheter osv.
Frågan är hur mycket jag ska lita på de där temperaturerna som idlar runt 27-30 grader och maxar 45-50 i prime efter några minuter...

Ett annat märkligt problem jag stötte på var att jag var tvungen att ändra IDE till AHCI i bios annars ville Archlinux inte boota.
Men annars hittade linuxkerneln allt; ljud, nätverkskrets mm.

Permalänk
Medlem

Jag såg fram emot att den nya lm-sensors version 3.20 som kom ut för ett par veckor sen ; läste på deras hemsida att F71889ED skulle supportas :

"Add support for Fintek F71889ED"

Sensors-detect hittar mitt chip, men jag ser bara kärnornas temperaturer som jag gjorde med den gamla lm-sensors.
Kollar man in lite närmare på deras sajt, ser man att det inte finns nån drivrutin till chipset än.
Är det nåt jag har missat?

Tillägg: Jag valde bort P55 och kör H55.