Ubuntu 10.04 64-bit och senaste Catalyst

Permalänk
Avstängd

Ubuntu 10.04 64-bit och senaste Catalyst

Bästa command prompts-experts.

Jag har installerat Ubuntu utöver Win7.
Hur gör jag för att installera senaste Catalyst?
Hittade en hardys installation guide, men den handlar om ett tidigare Catalyst vilket gör att de specifika kommandona inte stämmer när jag kommer till steg fem.
sudo dpkg -i xorg-driver-fglrd_8.593 (det är sifferkombinationen jag tror är fel när jag kör detta kommando eftersom uppackningen och installationen fungerar till steg 5 i instruktionen).

Önskan var att kunna testa spel i Ubuntu, men jag insåg att mina kunskaper i kärnor, Unix-kommandon etcetera var alldeles för skrala. Alla versioner och tillhörande specifika kommandovärden förskräcker nästan.

Permalänk
Avstängd

He,
jag har också läst att Ati ska vara problematiskt. Därav förhoppningen att någon kunnat lösa problemet och att denne någon även är svensk och Sweclockersmedlem.
Annars får jag helt enkelt lira i Windows o pilla i Ubuntu övrig tid.

Permalänk
Medlem
Skrivet av wereaz:

He,
jag har också läst att Ati ska vara problematiskt. Därav förhoppningen att någon kunnat lösa problemet och att denne någon även är svensk och Sweclockersmedlem.
Annars får jag helt enkelt lira i Windows o pilla i Ubuntu övrig tid.

Jag körde in Ubuntu 10.04 på min laptop med ATI-grafik för ett tag sen, har för mig att den installerade Catalyst tillsammans med drivrutinen om du går in i System-> Administration - > Hårdvarudrivrutiner
Så ska den själv söka upp lämpliga drivrutiner.

Fast ser nu att det står min inte använder några proprietära drivrutiner, vilket verkar konstigt då jag har full grafik, med compiz extra grafik aktiverad (wobbly windows mm)

Detta kan ha att göra med att jag uppgraderat version till version från 8.04...

Hur som helst, enligt en träff på Google ska det bara vara att ladda ner din drivrutin från AMD/ATI och installera den, välj bara Linux som OS-> Graphics Drivers & Software

Permalänk
Medlem

Ladda ner senaste drivrutinen.
Förbered för installationen genom att starta ett terminal-fönster...
...bläddra dig fram till korrekt position (cd Skrivbord till exempel)...
...starta installationen genom sudo ./ati<tab>...
...du blir frågad efter lösenord...
..installationen startas.

sudo säger till systemet att du vill köra följande kommando med fulla rättigheter.
./ indikerar att du vill exekvera en fil.
Istället för att skiva in filnamnet bokstav för bokstav så matar du in de första bokstäverna och trycker sedan på tab. Antingen kommer filnamnet att fyllas i eller så kommer du få förslag.

När du ska avinstallera drivrutinen så kör du den här filen istället (/usr/share/ati/fglrx-uninstall.sh).

Stabilast stöd får du genom att använda den öppna drivrutinen istället för den stängda. Nackdelen är att man än så länge inte hunnit implementera fullt 3D stöd. Mycket fungerar men inte allt. Det beror sig väldigt mycket på vilket grafikkrets man har och hur man vill använda den.

Permalänk
Medlem
Skrivet av Eduardo:

Fast ser nu att det står min inte använder några proprietära drivrutiner, vilket verkar konstigt då jag har full grafik, med compiz extra grafik aktiverad (wobbly windows mm)

Du använder troligtvis den öppna drivrutinen.

Följande kommado berättar för mig att jag just nu använder ett grafikkort från AMD av typen R600 och att jag använder en utvecklingsversion av den öppna drivrutinen Mesa 7.10-devel.

glxinfo | grep OpenGL OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: Mesa DRI R600 (RV630 9588) 20090101 TCL DRI2 OpenGL version string: 2.1 Mesa 7.10-devel OpenGL shading language version string: 1.20 OpenGL extensions:

Mesa 7.10-devel blev av misstag inklisstrat på mer än ett ställe.
Permalänk
Medlem
Skrivet av Korkskruv:

Du använder troligtvis den öppna drivrutinen Mesa 7.10-devel.

Följande kommado berättar för mig att jag just nu använder ett grafikkort från AMD av typen R600 och att jag använder en utvecklingsversion av den öppna drivrutinen Mesa 7.10-devel.

glxinfo | grep OpenGL OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: Mesa DRI R600 (RV630 9588) 20090101 TCL DRI2 OpenGL version string: 2.1 Mesa 7.10-devel OpenGL shading language version string: 1.20 OpenGL extensions:

Jo men Det är mycket möjligt och väl högst troligen därför som min erfarenhet av ATI och Linux avsevärt förbättrades sen sist jag testade för nästan ett år sedan!

Permalänk
Medlem
Skrivet av Eduardo:

Jo men Det är mycket möjligt och väl högst troligen därför som min erfarenhet av ATI och Linux avsevärt förbättrades sen sist jag testade för nästan ett år sedan!

Haha, jag skulle klistra in lite text (Mesa 7.10-devel) men jag blev av med urklippet. Såg nu att det hamnade lite galet.

Ja, troligtvis har du de öppna drivrutinerna. De fungerar enormt bra så länge man inte får tag på ett program som använder nån funktion som inte blivit implementerat än. Skrivbordseffekter genom compiz är ett av de program som fungerar bra ihop med de öppna drivrutinerna.

Här finns det en sida där man kan få en ledtråd om hur pass bra ett specifikt program kommer att fungera med de öppna drivrutinerna. X.Org Wiki - RadeonProgram

Permalänk
Medlem

Hade en del problem med senaste Catalyst, men det fixades i en hotfix av AMD. Nu var detta inte exakt TS problem, men det är helt klart värt att nämna.
GPU-83: ATI Catalyst? Linux Driver broken after Linux kernel security update

Permalänk
Avstängd

Körde precis installationen. När jag nu bläddrar för att komma till slutet av denna tråd så går det väldigt hackigt jämfört tidigare. Det vill säga när jag scrollar med musen så är det inget jämnt flöde, utan det uppdateras ett sjok i taget, som på min gamla bärbara.
Kanske har jag inte 32-bitars drivar installerade som kravet var?

Tack för hjälpen om sudo-kommandot med mera!

När jag pillade med Catalyst så började det rendera bra igen. Var något orolig när uppstartskärmen hade mycket sämre upplösning jämfört med innan installationen.