problem med apache och domännamn

Permalänk

problem med apache och domännamn

Hej alla

innan jag börjar så måste jag säga att jag är lite trött när jag skriver detta, ställ gärna frågor om jag är otydlig.

jag har en debian stable maskin 32-bitar .

Jag har skapa en wordpress sida

jag har skapat en katalog under /var/www/ alltså /var/www/namnetpåsidan/

sedan har jag skapat en symbolisk länk mellan /usr/shar/wordpress och katalogen jag skapade.

jag har skapat ett domännamn som är samma som katalogen jag skapade under /var/www/.

jag har också skapat en vhost i apache2 för domän namnet och att det pekar mot denna katalog.

men när jag går in i webbläsaren så kommer jag till index.html som ligger i /var/www/ . Jag kommer alltså inte till den här katalogen jag har skapat som är länkat till wordpress.

om jag döper om index filen till något annat så blir sidan istället en filhanterare

vad är det som jag gör fel?

Permalänk

Jag löste det genom att avaktivera default sidan i /etc/apache/available-sites/default

Kan det a att göra med att jag har döpt servern till samma som domännamnet och att det är därför det gick till default istället för den specificerade katalogen?

Permalänk
Medlem

nja det löste sig ... en annan lösning som jag kör med är att ha en index.php som länkar lr rättare sagt leder till den katalogen som du vill använda. Själv experimentera jag lite med olika CMS nu. har flera mappar /cms1,/ cms2 osv i /var/www och min index.php innehåller ett script som leder till cmsét jag vill visa som startsida, funkar finfin det med

Permalänk

Hejsan igen

Jag försökte att lägga in en ny domän i apache genom att skapa en ny katalog under /var/www/ med domänens namn och att kopiera den förra domänen i /etc/apache/enable-sites/ och ändra den till den nya domänen . Jag skapade också en index.html i /var/www/domänen/ . men när man nu skriver in den nya domänen så kommer man din den andra domänens sida som är en wordpress sida. ,,, om jag stänger ner den wordpress domänen så kommer jag till index.html filen i /var/www/domänen/index.html . jag förstår inte varför det är på detta sätt. Är väldigt tacksam för hjälp

Permalänk
Medlem

Även jag har liknande problem som TS, så det vore kanon om någon hade lite tips.

Skrivet av rosaluxenburg:

nja det löste sig ... en annan lösning som jag kör med är att ha en index.php som länkar lr rättare sagt leder till den katalogen som du vill använda. Själv experimentera jag lite med olika CMS nu. har flera mappar /cms1,/ cms2 osv i /var/www och min index.php innehåller ett script som leder till cmsét jag vill visa som startsida, funkar finfin det med

Du skulle inte vilja dela med dig utav scriptet?

Permalänk
Medlem

För att kunna hjälpa er får ni nog ta och dela med er av era config filer. Det säger inte så mycket att ni kopierat en config till en annan, det kan ni göra hela dagen utan att det blir rätt, så om ni visar hur era konfigs ser ut så ska jag nog kunna hjälpa er.