Fedora 14: Nätverksproblem vid uppstart/Kommandot "man" fungerar inte

Permalänk
Medlem

Fedora 14: Nätverksproblem vid uppstart/Kommandot "man" fungerar inte

Hej!

Har ett litet problem. Installerade nyss om min server (från Fedora 10) till Fedora 14, och har nu fått lite problem med att datorn inte vill läsa in startscript för nätverk. Är inte den vältaligaste när det gäller Linux, men jag har pillat en del med det. Det var dock ett tag sedan sist, så jag har säkert missat en del. Såhär ligger det i alla fall till:

Såhär ser min konfigfil ut för interfacet:

/etc/sysconfig/network-scripts/ifcfg-eth1 DEVICE=eth1 BOOTPROTO=dhcp ONBOOT=yes HWADDR=<Mac-adress>

Hade i mitt stilla sinne tänkt att detta i princip var allt man behövde göra. Kör jag bara ifconfig eth1 i prompten så får jag, som tänkt, upp lite info om interfacet, men ingen ip-adress. Däremot kan jag sätta en ip-adress manuellt genom att köra:

ifcfg eth1 add 192.168.0.2/24

och då kan jag pinga alla andra datorer i nätet (åt båda håll), men startar jag om så måste jag ju upprepa hela proceduren.

Som tilläggsfråga kan nämnas att kommandot yum inte hittar sitt repository (misstänker att detta hänger ihop med nätverksproblemet).

EDIT: Nätverksproblemet löst. Körde chkconfig och såg att "network" inte var konfigurerat vid några runlevels...

Permalänk
Medlem

Du har ställt att den ska plocka automagisk IP-adress från en DHCP-server. Det är sällan fallet om man vill ha en server, så tillvida du inte har låst IP-adressen till en viss MAC-adress.
Justera tills det passar dig!

DEVICE="eth0" IPADDR="192.168.1.100" NETMASK="255.255.0.0" ONBOOT="yes" BOOTPROTO="none"

Permalänk
Medlem
Skrivet av zyberzero:

Du har ställt att den ska plocka automagisk IP-adress från en DHCP-server. Det är sällan fallet om man vill ha en server, så tillvida du inte har låst IP-adressen till en viss MAC-adress.
Justera tills det passar dig!

DEVICE="eth0" IPADDR="192.168.1.100" NETMASK="255.255.0.0" ONBOOT="yes" BOOTPROTO="none"

Jag har för närvarande en router som sköter IP-tilldelningen och har reserverat en specifik adress till serverns MAC. Tack för påpekandet, dock!

Dock så fungerar inte DNS-tilldelningen genom DHCP (vilket fungerar för alla andra datorer i nätverket, dessa är dock windowsburkar) utan har statiskt fått lägga till dessa i /etc/resolv.conf. Några idéer kring detta?