Sätta up en DHCP-server i Ubuntu 14.04 server?

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Sätta up en DHCP-server i Ubuntu 14.04 server?

Hej

Jag har satt upp en Linux-server med Ubuntu 14.04 server (med Xubuntu-desktop installerat i efterhand). Jag har installerat isc-dhcp-common paketet men jag förstår inte hur jag ska konfigurera dhcp-servern? Jag har ett vanligt C-nät hemma och jag vill att dhcpservern ska dela ut ip-adresser från 192.168.0.2 till 192.168.0.89, samt att jag har en lokal dns men jag får inte servern att starta. Min nuvarande DHCP-server är inbyggd i min Huawei B593 router, den har inte riktigt koll på hur den delar ut DHCP-adresser eftersom det allt för ofta händer att två enheter får samma ip-adress med konflikt som följd. Därav mitt projekt.

Så här ser min dhcpd.conf ut.

default-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option routers 192.168.0.254;
option domain-name-servers 192.168.0.98, 8.8.8.8;
option domain-name "mydomain.example";

subnet 192.168.0.1 netmask 255.255.255.0 {
range 192.168.0.2 192.168.0.89;
range 192.168.0.150 192.168.0.200;
}

Jag har två nätverksinterface och det aktuella heter visst p2p1 istället för eth0 eller eth1. Det är säkert där felet ligger, servern startar inte. Hur anger jag nätverksinterface?

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
Hufvudstaden
Registrerad
Dec 2007

Din conf ser rätt ut, p2p1 är ubuntus nya namn på interface så det är inte problemet.

Glöm inte sätta p2p1 under INTERFACES= i filen /etc/default/isc-dhcp-server.
Och installera paketet isc-dhcp-server för att i isc-dhcp-common innehåller program runt om och inte själva dhcp servern.

Starta sedan server med service isc-dhcp-server start

#Speldator: Xeon W-2155 | X11SRA-RF | EVGA 1070GTX | 64Gb Samsung DDR4 ECC 2666Mhz | Samsung 960 Pro M2/NVME 500Gb o 1Tb | Win 10
#ESXi: Xeon E5-1620v3 3.5Ghz | X10SRH-CLN4F-O | 128GB ECC 2133MHz | Intel 910 800Gb | 3st Samsung SM863 960Gb | Intel X520
#NAS4Free: X10SDV-TLN4F-O | 32GB ECC 2400mhz | 5st WD Red 10TB | Intel X520
https://hackernet.se | Wiki med inriktning open source och nätverk.

Trädvy Permalänk
Medlem
Registrerad
Maj 2003

Det var ett tag sedan jag bråkade med ISC DHCPd, så lita inte blint på mig.
Men jag tror att ditt subnät ska sluta med en 0a, och inte en 1a, och att det är ett allvarligt fel:

subnet 192.168.0.0 netmask 255.255.255.0 {

Och precis som Sparc0 skriver så bör du även ange interface som DHCP-servern ska agera mot. Det bör vara INTERFACES="p2p1"
Med "" runt namnet.

Och tänk också på att du manuellt behöver sätta en statisk IP på din DHCP-servers nätverkskort som DHCP-servern delar ut adresser på. Låt den inte dela ut adresser till sig själv så att säga. Så i /etc/network/interfaces så får du sätta statiskt IP för det kortet.

iface p2p1 inet static address 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255 network 192.168.0.0 gateway 192.168.0.1

Och i /etc/resolv.conf så får du manuellt sätta vilka DNS-servrar som ska användas, förutsatt att servern kommer åt internet genom p2p1, som den också delar ut adresser genom.
För samma servrar via DHCP så ska den filen ska innehålla:

nameserver 192.168.0.98 nameserver 8.8.8.8

Och tänk på att ha mer än en dhcp-server i ett subnät är en riktigt dålig idé. Så stäng av din DHCP-server i din router så fort du får denna att fungera.

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Mar 2005

Hej.

Du ska inte behöva ange något interface alls, så det ska inte vara bekymret i detta fall. Den känner automatiskt av vartifrån DHCP-requesten kommer. I och med att du även kan få requests från andra nätverk via DHCP-relay som inte behöver sitta lokalt på servern.

Som inlägget ovan så bör du ange "nätidt" efter subnet, dvs, adressen som slutar på 0 i ditt fall. Testa även ta bort allt som absolut inte är nödvändigt och sätt dina options i blocket för subnätet istället. Nedan är hur konfigurationen hemma ser ut vilket har fungerat fint genom många år.

daniel@bottenskrap:~$ cat /etc/dhcp/dhcpd.conf subnet 192.168.0.0 netmask 255.255.255.0 { range 192.168.0.150 192.168.0.220; option domain-name-servers 192.168.0.1; option domain-name "minzon.local"; option routers 192.168.0.1; }

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Hej

Tack så mycket nu funkar allt! Det var denna rad i dhcpd.conf som gjorde det där jag bytte ut 1 mot 0.

subnet 192.168.0.0 netmask 255.255.255.0 {

Jag ändrade interface oxå
i min /etc/default/isc-dhcp-server fil står det nu INTERFACES="p2p1"

Jag hänger inte med i ditt inlägg jagardaniel att det även skulle funka på fler nätverkskort än det jag har mot mitt LAN. Vad finns det för vits med det? Jag har ytterligare ett nätverksinterface och det heter p1p1 som är ett pci-e kort. Det är tanken att när jag någon gång i framtiden får en bättre anlutning till internet t ex ADSL eller fiber att jag ska köra iptables mellan dessa nätverksinterface. Idagsläget har jag fri surf på 3G Telenor (gammalt abonnemang).

Hur som helst, nu är jag jättenöjd och nu delas inte samma ip-adress ut till flera nätverksenheter. Väldigt konstigt fel egentligen.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Mar 2005
Skrivet av stoffe_83:

Hej

Tack så mycket nu funkar allt! Det var denna rad i dhcpd.conf som gjorde det där jag bytte ut 1 mot 0.

subnet 192.168.0.0 netmask 255.255.255.0 {

Jag ändrade interface oxå
i min /etc/default/isc-dhcp-server fil står det nu INTERFACES="p2p1"

Jag hänger inte med i ditt inlägg jagardaniel att det även skulle funka på fler nätverkskort än det jag har mot mitt LAN. Vad finns det för vits med det? Jag har ytterligare ett nätverksinterface och det heter p1p1 som är ett pci-e kort. Det är tanken att när jag någon gång i framtiden får en bättre anlutning till internet t ex ADSL eller fiber att jag ska köra iptables mellan dessa nätverksinterface. Idagsläget har jag fri surf på 3G Telenor (gammalt abonnemang).

Hur som helst, nu är jag jättenöjd och nu delas inte samma ip-adress ut till flera nätverksenheter. Väldigt konstigt fel egentligen.

Förlåt, det är jag som snurrade till det. Jag fick för mig att det försökte konfigureras interface i dhcpd.configen. Det är helt rätt, specifiera interfacet mot ditt "LAN" där du förväntar dig att dhcp-requests kommer in. Det kan bli galet om man tillåter dhcp ifrån alla interface och glömt konfigurera brandväggsregler och liknande

Härligt att det fungerar

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@jagardaniel: Ja och nu fick jag wifi på mobilen att fungera eftersom jag via DHCP nu får två olika adresser till min laptop och min mobil. Vissa frågor kvarstår dock om min internetanslutning.

Stort tack till alla för alla råd och tips jag fått här i denna tråd!

Mitt äventyr med min internetuppkoppling fortsätter här eftersom min korkade router ej stödjer NAT-loopback.
DNS-server projekt

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

Ett tips är att du laddar hem och installerar webmin till ubuntuserver. Mycket enklare att confa där igenom. Den .98 burken är vad är det för nån som agerar dns? Jag rekommenderar att du anger din router som dns. Så du får en intern dns som hanterar allt internt, sedan skickar den vidare till ispens dnser om den behöver hjälp. Om du anger googles också så kan det bli att du får svarsfel om du gör något internt. Då googles dnser inte vet om klienterna på ditt nätverk.

Du är 100% säker på att din router inte stödjer bridge-mode? Så du kan ta en vettigt router istället?

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@fragwolf Ja just webmin kan man ju installera, tack för tipset. Dock så vill jag ha bra säkerhet då denna burk är öppen mot internet. Det kanske går med webmin?

min .98 burk är en Ubuntulinuxsever som kör massor av tjänster, t ex wordpress och owncloud, ssh, ftp http, php5, mysql och även egen dns. Jag har startat en eget tråd om mitt dns projekt så för att inte förvirra så skulle jag vilja ha de tips om dns där istället för i denna tråd som handlar om min dhcp-server som nu fungerar klockrent tack vare hjälp här.

Jag är absolut 100 % säker på att min router inte stöjder varken NAT-loopback eller bridge-mode. Det verkar inte heller som att det kommer någon uppgradering från Huawei heller. Annars hade jag aldrig behövt allt detta trassel med egen DNS-server och kunnat gå en mycket enklare väg. Jag har inte hört talas om någon 3G router med inbyggt 3G modem som har NAT-loopback eller bridge-mode. Jag skulle vara mycket tacksam om jag kunde få tips på någon, ingen av Huaweis routrar har stöd för NAT-loopback eller bridge-mode tyvärr. I dagsläget har jag en Huawei B593. Jag har tidigare haft en 3G dongle med en Dovado Tiny router men då får jag ingen stabil internetuppkoppling tyvärr vilket jag får nu med min B593.

Här är min DNS-tråd.
DNS-tråden

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Förresten så finns det en tråd här på forumet som handlar om att det inte går att brygga en B593 router.

http://www.sweclockers.com/forum/trad/1162519-huawai-b593-sup...

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

@stoffe_83:
Ah det var du med den egna ubuntuservern Kör isf bara den som dns hos dina klienter inte 8.8.8.8 finns ingen anledning.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@fragwolf Ja det är så jag gör oxå Jo det är jag som är samma stoffe_83 som i den andra tråden gott nytt år förresten.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

@stoffe_83:
Vad gäller webmin så är det säkert så länge du inte öppnar port 80 utåt, eller 443 om det är https. Jag installerar alltid webmin istället för nått gui. Då har du bara möjlighet att komma åt det inifrån. Vet inte hur säkert det anses vara, men jag skulle nog inte öppna det utåt. Bättre att köra VPN in isf. Tips är att du lägger till webmins ppa/repo. Så att du alltid får nyaste versionen. Laddar man hem det och installerar det manuellt så är risken att man inte uppdaterar det så ofta. Vilket bidrar till att göra det säkrare och bättre.

Gott nytt år!

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@fragwolf Tack, men jag har port 80 öppet utåt eftersom jag kör owncloud och wordpress. Jag vill gärna lära mig att göra det mesta manuellt i Linux då jag tycker det är viktiga kunskaper för att få en bättre förståelse för hur det verkligen fungerar.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

@stoffe_83:
Okej tror webmin kör https. Det är inte omanligt att använda webmin Även om det inte är dumt att lära sig knacka kommandon i shellet.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@fragwolf Jag kan ju faktist testa det, men jag har lyckats bra med att konfa det allra mesta genom terminalen och gör detta för att lära mig oxå. För mig har terminalknackande hög coolhetsfaktor

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

@stoffe_83:
Jo det är ju just detta med coolhetsfaktor som är "problemet" Det är bra att kunna, men det är också bra att kunna med webmin. Varför ska man göra det svårare för sig än vad det behöver vara? Sen är det ju inget som hindrar dig från att använda terminalen också.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@fragwolf Ja du har helt en poäng där. Men jag gör allt detta pga av att jag vill lära mig oxå, så det är lite av den anledningen som jag håller på med detta oxå

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX