Forumdelen sponsras av

Spel öppnas på min sekundära monitor istället för min primära. FPS problem.

Trädvy Permalänk
Medlem
Registrerad
Mar 2017

Spel öppnas på min sekundära monitor istället för min primära. FPS problem.

Tjenare gott folk,

Är i ett galet overwatch flow, spelet är ju det roligaste som finns just nu. Är lite smått irriterad över mina tekniska problem dock. Ska bara ge er mina pc specs, orelevant egentligen men bättre och ge för mycket info än för lite.

GPU 1080 TI
CPU intel core I7-4790 K
16 GB ram.

Två skärmar;
AOC 144 HZ 1080 p Anslutning display port
Acer 60 HZ, 1080 P. Anslutning DVI
Värt att notera, har en kabel inkopplad som inte är aktiv, en 4k samsung tv skärm, den är satt som disabled, vill inte ha den igång när jag ej använder den, den använder givetvis hdmi 2.1 eller vad det nu heter som kan klara 60 hz i 4k. nåväl, den är inte aktiverad.

Har satt primär på min bästa skärm, AOC 144 hz och sekundär på acer skrämen, detta är dubbel, trippel kollat i nvidas kontrollpanel.

Nu har jag även testat o mixra med spelet i fråga, Overwatch. På video settings kan man ställa in vilken skärm man vill spela spelet på, standard alternativet är " best match" men har även testat alla andra alternativ men spelet vill tvunget starta upp på min Acer, sekundära skärm där jag får 144 hz i window mode, testat borderless window också, om jag drar över spelet till min primära skräm får jag 15 fps för att sen återigen dra tillbaka till min acer och få max fps. Enda sättet som fungerar är att helt inaktivera min acer och köra på en skärm, då fungerar det felfritt.........

OBS det är inte bra overwatch som har problem, i stort sätt alla mina spel och program öppnas på min sekundära.

Vad sjutton är det för fel, sökt i så många timmar på google utan framgång, kan ni hjälpa mig kanske?

Trädvy Permalänk
Medlem
Plats
Tranemo
Registrerad
Feb 2014

har du kopplat in den primära skärmen i de integrerade grafikkortet?

i7 4790 | CRYORIG H7 QUAD LUMI | MSI GTX 1070 | Msi Z87-G45 | Corsair 16 GB | Fractal R4 | 1 TB WD Blue + 850 Evo 250 GB |

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Jan 2011

Jag hade samma problem med just Overwatch, fixade det genom att starta skärmen med displayport innan jag startade själva datorn.

CPU : 6700K @ 4,7GHz GPU : Titan X (Pascal) RAM : 16GB 3600MHz 15-15-15-35 SSD : Samsung 950 PRO 512GB NVME Bildskärm 1: Strix PG279Q 1440p@165Hz G-SYNC Bildskärm 2: QNIX Q2710 1440p@60Hz

Trädvy Permalänk
Medlem
Registrerad
Mar 2017
Skrivet av gylldevik:

har du kopplat in den primära skärmen i de integrerade grafikkortet?

Jajamän, och det fungerar bra när jag väl stänger av min sekundära, 144 hz konstant, inga konstigheter, cruxset är ju att jag varje gång måste stänga av min dumma sekundära skärm för att kunna spela på rätt skräm. Jag kan också koppla tbx min sekundära skräm när allt funkar riktigt och då uppstår inga problem.

Trädvy Permalänk
Medlem
Registrerad
Mar 2017
Skrivet av Boozfob:

Jag hade samma problem med just Overwatch, fixade det genom att starta skärmen med displayport innan jag startade själva datorn.

Fan vad knas, ska testa det dirr, tack

Trädvy Permalänk
Medlem
Registrerad
Mar 2017

Nej det här var ju besvärligt, nu märkte jag en intressant detalj.. När jag bootar windows ser jag allt på min sekundära skärm. Och att ha igång skärmen innan man startar PC:n hjälpte för att starta spelet i rätt skärm men fpsen låg på 20-ish, drar jag över den till min sekundära skärm så får jag återigen 144 fps.

Kopplar jag ur min sekundära så får jag max fps på min primära, enda sättet vad jag hittat.

Trädvy Permalänk
Medlem
Plats
Kronobergs Län
Registrerad
Mar 2012

Uppenbar fråga: Har du gått in i windows inställningar och kollat att rätt skärm är primärskärm?

Fractal Design Arc | Gigabyte Z77X-UD3H | LG G4 | Intel i5 3570k |
Noctua D15 | MSI GTX 970 | Asus Xonar DGX | Sennheiser HD598 |
Corsair RM850x 850W | Corsair Vengeance 4x4GB

Trädvy Permalänk
Medlem
Registrerad
Mar 2017
Skrivet av FuzzyMcFluffens:

Uppenbar fråga: Har du gått in i windows inställningar och kollat att rätt skärm är primärskärm?

Jajamän, min AOC 144 hz är även där satt till primär. Märkte att jag löste problemet genom att sätta fullscreen, och sen gå tbx till boarderless window, då fick jag max fps på min primära men allt det här är ju jätte jobbigt, ska ju inte behöva hålla på och fixa med sånt här när man tycker att allt bara ska fungera.

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Sep 2013

och om du testar att rycka ur den sekundära skärme, bootar in i windows och startar allt ser det bra ut då?
Testa sen att stänga av allt som det ska och koppla in andra skärmen igen.
Kan vara värt att testa att ta ut sladden för 4k skärmen också bara för att utesluta att den spökar till något!

4930k | R9 290 CF | Gskill Ares 2133MHz 16GB | Asrock x79 Extreme4-m | Corsair AX1200i | Parvum s2.0 Extended | EK Supremacy EVO | EK-FC Original CSQ Nickel | 360+240 | EK D5+EK-D5 X-RES 140
Bygglogg: Chandra | by lowngcawt
Galleri: Aether | Chandra

-=CITERA FÖR SVAR=-

Trädvy Permalänk
Medlem
Registrerad
Mar 2017

Har mer info.

Spel fungerar felfritt i helskrämsläge på min primära skärm, om jag kör boarderless window eller bara window mode så får jag låga fps, om jag drar över spelet till min sekundära skärm får jag höga fps, om jag väljer alternativet helskärmsläge får jag max fps på min primära skärm, den vill alltså fungera rätt på helskärms alternativet men inte på window mode, då blandar den ihop mina skärmar.

Trädvy Permalänk
Medlem
Registrerad
Mar 2017
Skrivet av lowngcawt:

och om du testar att rycka ur den sekundära skärme, bootar in i windows och startar allt ser det bra ut då?
Testa sen att stänga av allt som det ska och koppla in andra skärmen igen.
Kan vara värt att testa att ta ut sladden för 4k skärmen också bara för att utesluta att den spökar till något!

Ska testa allt du skriver, återkommer strax, tackar

Trädvy Permalänk
Medlem
Registrerad
Mar 2017
Skrivet av lowngcawt:

och om du testar att rycka ur den sekundära skärme, bootar in i windows och startar allt ser det bra ut då?
Testa sen att stänga av allt som det ska och koppla in andra skärmen igen.
Kan vara värt att testa att ta ut sladden för 4k skärmen också bara för att utesluta att den spökar till något!

Sådär, då testade jag din metod och tack vare det verkar det som att det inte är så mycket relaterat till dem andra skärmarna. Nu är bara en skärm inkopplad och jag får SKIT fps, runt 15-20 i window mode, boarderless window och om jag väljer köra helskärm får jag normal prestanda.

För att vara övertydlig, jag har enbart en skärm inkopplad just nu och får ändå samma beskymmer som jag hade med fler skärmar.

Trädvy Permalänk
Medlem
Registrerad
Mar 2017

Testade att inaktivera G-sync och det löste ALLA problem, oavsett hur många skärmar jag har inkopplade... Så min G-sync fungerar helt plötsligt inte nu, får väl köra utan, pfff....

Det är nog ett vanligt problem, nu vet jag vad jag ska googla i alla fall, tack för hjälpen allihopa, nu vet jag vad felet är.

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Sep 2013
Skrivet av MatteusG92:

Testade att inaktivera G-sync och det löste ALLA problem, oavsett hur många skärmar jag har inkopplade... Så min G-sync fungerar helt plötsligt inte nu, får väl köra utan, pfff....

Det är nog ett vanligt problem, nu vet jag vad jag ska googla i alla fall, tack för hjälpen allihopa, nu vet jag vad felet är.

Spökande drivrutiner?
Nog för att g-sync moduler inte är helt ovanliga att de dör, men då borde det ju inte funka bra i fullscreen heller.

4930k | R9 290 CF | Gskill Ares 2133MHz 16GB | Asrock x79 Extreme4-m | Corsair AX1200i | Parvum s2.0 Extended | EK Supremacy EVO | EK-FC Original CSQ Nickel | 360+240 | EK D5+EK-D5 X-RES 140
Bygglogg: Chandra | by lowngcawt
Galleri: Aether | Chandra

-=CITERA FÖR SVAR=-

Trädvy Permalänk
Medlem
Plats
Karlskoga
Registrerad
Jul 2001

G-sync har 2 alternativ, endast vid fullskärm eller vid fullskärm och window.
aktivera och se till att du har på du får G-sync alltid och se vad som händer

| MSI Z270i | Core i5-7600K | 16GB 3200Mhz DDR4 | GTX 1080 Ti Hybrid | Define mini C TG| Pg348q | MSI GS65 Stealth Thin GTX 1070 MQ |

Trädvy Permalänk
Medlem
Registrerad
Mar 2017
Skrivet av lowngcawt:

Spökande drivrutiner?
Nog för att g-sync moduler inte är helt ovanliga att de dör, men då borde det ju inte funka bra i fullscreen heller.

Skrivet av Cequence:

G-sync har 2 alternativ, endast vid fullskärm eller vid fullskärm och window.
aktivera och se till att du har på du får G-sync alltid och se vad som händer

Spökande drivrutiner kan det eventuellt vara, för det är ju som du säger väldigt konstigt att det funkar i fullscreen då.

G-sync har två alternativ, japp.. Jag har testat båda utan framgång, kör just nu g-sync i både helskärm och fönster, no luck.

Tror jag får ominstallera drivrutinerna och hålla tummarna, nu väntar en god fredags pizza för att dämpa eländet Återkommer om det löser problemet