helt grön på nätverk. Hjälp mig mounta min NAS

Trädvy Permalänk
Medlem
Plats
Mancave
Registrerad
Maj 2007

helt grön på nätverk. Hjälp mig mounta min NAS

Som rubriken säger så är jag grön och vill mounta min NAS.

Kan använda den via samba utan problem. Men vill mounta den i /home/bredin/NAS/

den har ip:t 192.168.0.198 och filerna kan nås via ftp:/192.168.0.198 och då kommer jag till de olika diskarna på NASen. En som heter "nas" och en som heter "media" då "nas" är själva nasen medans "media" är en USB disk som jag har hängt på.

själva disken heter nas-1 och nås i dolphin via: "smb://nas-1"
och det låg som sagt en "smb://nas-1/media" och en "smb://nas-1/nas".

"smb://nas-1/nas" vill jag mounta som/i /home/bredin/NAS/
"smb://nas-1/media" vill jag mounta som/i /home/bredin/Media/

Och det ska vara read/write/execute rättigheter för mig som användare+root.
hur går jag bäst tillväga? Förstår mig inte riktigt på fstab än.

Sitter förtillfället på kubuntu 8.04 64bitars. Testade dess monteringshanterare i kontrolpanelen men när jag klickade på samba shares så stannade bara det.

tack.

4690K, 16GB ram, 1,25TB SSD, Radeon 7750
100% PASSIVT

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Feb 2003

Kan lägga upp min rad när jag är inne i linux.

Trädvy Permalänk
Medlem
Plats
Mancave
Registrerad
Maj 2007

det hade varit snällt

4690K, 16GB ram, 1,25TB SSD, Radeon 7750
100% PASSIVT

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Mar 2008

Kan det kanske vara något?
http://ubuntu-bossieman.blogspot.com/search/label/NAS
"Den har stöd för NFS och efter att ha aktiverat funktionen så modifierade jag /etc/fstab och la in dessa rader

192.168.1.123:/Backup /Backup nfs _netdev,auto,user 0 0
192.168.1.123:/Nerladdat /Nerladdat nfs _netdev,auto,user 0 0"

--
Tompa

Trädvy Permalänk
Medlem
Plats
Mancave
Registrerad
Maj 2007

har QNAP ts-201. Frågan är hur mkt den skiljer sig ifrån hans ts-209. Min bör också ha stöd för nfs.

UUID=e22780f3-8e75-489d-afa9-5f2a64eac831 none swap sw 0 0 /dev/scd0 /media/cdrom0 udf,iso9660 user,utf8,atime,noauto,rw,dev,exec,suid 0 0 /dev/scd0 /media/floppy0 auto user,utf8,atime,noauto,rw,dev,exec,suid 0 0 192.168.0.198:/nas /home/bredin/Nas auto nfs _netdev,auto,user 0 0 192.168.0.198:/media /home/bredin/Media auto nfs _netdev,auto,user 0 0

Så ser min ut nu och ingen framgång. Editerade det i Kate och såg att den sista nollan i de raderna jag lagt dit är röda medans de andra är blåa. Och har installerat så mkt nfs som jag kan.

[http://pici.se/pictures/gTKuQBxUb.jpg]

[/url]
Här ser ni vad jag menar. Och ser ni något som är fel kanske?

4690K, 16GB ram, 1,25TB SSD, Radeon 7750
100% PASSIVT

Trädvy Permalänk
Medlem
Plats
Câmara de Lobos, Madeira, Portugal
Registrerad
Nov 2005

Raderna borde vara:
192.168.0.198:/nas /home/bredin/Nas nfs _netdev,auto,user 0 0
192.168.0.198:/media /home/bredin/Media nfs _netdev,auto,user 0 0

Fagerja

Trädvy Permalänk
Medlem
Plats
Mancave
Registrerad
Maj 2007

Testade det men inget resultat.
han i guiden använde programmet som finns i NASen. Men problemet är att den ska in via http://192.168.0.198 och port 6000. Bara konqueror som släppt mig vidare efter inloggningen. Men det stödjer ej gränssnittet.

192.168.0.198:/nas /nas nfs _netdev,auto,user 0 0

så ser min /etc/fstab ut nu. Och jag har kört sudo mkdir /nas och den mappen existerar.

Kan det vara rountern som måste konfigureras?

4690K, 16GB ram, 1,25TB SSD, Radeon 7750
100% PASSIVT

Trädvy Permalänk
Medlem
Plats
Câmara de Lobos, Madeira, Portugal
Registrerad
Nov 2005

Det är tydligen så att din NAS inte har stöd för nfs, så du måste använda samba. I fstab gör du det genom att ersätta nfs med smbfs.

Fagerja

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Feb 2003

Här kommer min rad, sorry att det tog sån lång tid men har haft annat för mig än att fixa nvidia

/etc/fstab:
//192.168.1.3/Volume_1 (ip-nummer till din share) /media/nas (vart den ska mountas) smbfs username=användarnamn,password=lösenord 0 0

http://ubuntuforums.org/showthread.php?t=255872 - Väldigt bra guide. Läs den.

Trädvy Permalänk
Medlem
Plats
sverige
Registrerad
Mar 2008

Har lite problem jag med. Har försökt mountat win share på min ubuntu burk
med hjälp av följande i fstab;

//192.168.0.7/musik /mnt/musik smbfs username=user,password=lösen,uid=htpc

user och pass är den användare som jag har lagt till behörighet på i win xp datorn på den utdelade mappen (musik).

När jag skriver "mount /mnt/musik" i terminalen får jag följande:
5694: session setup failed: ERRDOS - ERRnoaccess (Access denied.)

Har provat med flera users och även default. Har satt läsrättighet för alla på utdelningen också, hjälper inte.

Sätter jag bara user i fstab så får jag skriva in lösen i terminalen då jag kör mount men sen så blir det ERRDOS meddelandet :S

Kan ju inte vara fel lösen!?

Trädvy Permalänk
Avstängd
Plats
::1
Registrerad
Jul 2002

Det är endast Qnap Pro produkter som har stöd för NFS, dock kan du själv få igång NFS på icke-pro med att confa lite.

Information wants to be free.
Internet: 1Gbit/1Gbit LAN/WiFi: Cisco/Meraki
Laptop: Dell XPS 9550 4K touch HTPC: Raspberry Pi 3 LibreELEC
Desktop: WIP

Trädvy Permalänk
Medlem
Plats
Mancave
Registrerad
Maj 2007

Det förklarade lite NASen är förövrigt tillbakalämnad. Blev riktigt missnöjd med den. Ska köpa en komplett dator om bara någon dag som jag ska använda som "NAS".

4690K, 16GB ram, 1,25TB SSD, Radeon 7750
100% PASSIVT

Trädvy Permalänk
Medlem
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av Breddas
NASen är förövrigt tillbakalämnad. Blev riktigt missnöjd med den.

Är inte riktigt nöjd med min heller, men "snart" kommer kanske Debian-saken bli tillräckligt stabil för att det ska vara någon mening med att lägga in den.

För övrigt är väll smbfs förklarat förlegat och cifs är rekommenderat att användas istället?